How to install UBPorts on Fairphone 2?



  • I tried to install UBports with the installer for macOS, but the app couldn’t establish a connection with my Fairphone. This wasn’t a surprise, because I failed to install Fairphone Open on macOS either.

    Then I switched to Neon VM and tried to install UNPorts with the installer for Linux. Unfortunately after rebooting the device in the recovery mode, the installation process got stuck.

    I think I have the same problem, that was described here and here in this forum. Does someone know a step by step guide for an installation, maybe with the classic tool fastboot.



  • @marc_aurel Try the UB Welcome and Install group on telegram (https://t.me/WelcomePlus). They should be able to sort you out.



  • @lakota said in How to install UBPorts on Fairphone 2?:

    https://t.me/WelcomePlus

    Unfortunately, this is a dead link.



  • @marc_aurel Hi again, just tried the link again from the forum pages in web browser and it took me to the join group page for telegram. Also from forum app.
    I tried double and single tap both worked. Not trying to be patronizing but have you tried just typing it straight into your web browser if all else fails. As not sure why its not working for you.



  • Thanks for your response. The link works only in Chromium and fails in Safari and Firefox. Unfortunately the chat room requires the installation of Telegram and an account with a valid phone number. This is a problem, because Telegram is not secure any more after the Russian court decision.

    I will try to find an answer in the Fairphone community forum. Maybe I’ll find a solution there. I have to evaluate UBPorts as a platform for a commercial product road map.



  • @marc_aurel Ok not sure about the Russians asking for the access codes or even if it happens yet but its your right to be cautious about what you have planned. As a work around try search Fairphone 2 Ubports install issues from your favorite browser or such. If the problems been solved or already questioned that might throw up an answer. Also search on this forum for Fairport 2 issues and see what thatvdoes. I'm not familiar with Fairphone 2. I'll also ask in the forum for someone to pop in here when they can to help. Might be a delay due to bank holidays etc.



  • @marc_aurel @slowflash has published this https://forums.ubports.com/topic/1092/howto-make-mac-see-your-phone-in-bootloader Maybe it is related to your problem?

    Looks like the os x sierra does not allow installer to use Fastboot.
    Let's force it.
    Just open terminal and type
    sudo open -a ubports-installer
    This will give proper privileges to the installer.
    After that install as usually



  • @marc_aurel Another point of access, the UBports supergroup is linked irc on Freenode.



  • Thanks for your help. I got help in the Fairphone forum. I had to start the app in Linux with the sudo command in the terminal app. I recommend to update the installation instructions for UBPorts.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.