Aquaris BQ E5 HD (vegetahd) Android -> Ubuntu -> ubports



  • So I recently bought a BQ E5 HD with Android, checking the chipset and device so it would accept ubuntu touch.
    It was not recognised in Android mode by the ubports installer (on windows), as the device names are all set to "Aquaris_E5_HD".
    So I used sptools to flash the latest ubuntu touch 15.04 scatter from BQ. This worked, and I have a dual sim working ubuntu phone. Super.

    Now however I try to update this to ubports, I cannot succeed.

    The ubports installer hangs at the 'adb pushing files' and eventually gives an error about '...\ubports/pool/ubports-e5cf0885f061c9615931cf863a43f65d8590aa71027315ad71999252ce118868.tar.xz file not exist'. The file does exist, and is a valid archive.

    I have tried magic-flash-tool on ubuntu 14.04LTS. This appears to work, but fails at the reboot and puts the phone back to the startup wizard in the BQ 15.04 ubuntu.

    I have tried ubuntu-device-flash, but it fails to find an image for vegetahd on server-image.ubports.com (using --channel=ubuntu-touch/stable --device=vegetahd).

    SO...

    My next steps (why I'm asking):

    1. Is there a scatter file for ubports on vegetahd that I can use with sptools?
    2. What do I need to do to succeed with the ubports installer?
    3. Is there some magic (further options) I can use with ubuntu-device-flash to succeed?

    I know how to use adb, fastboot, mtk tools and looked into the contents of the available downloads, but I can't get the whole thing to work together. Any solutions - no matter how lengthy - are welcome :)



  • Hello,
    Maybe have a look to this thread
    Regards
    Pulsar33



  • @docmathoc If the above doesn't work go to
    https://t.me/WelcomePlus
    Thats the UBports welcome and install group on Telegram. They will have all the advice you need.



  • @pulsar33 thanks
    unfortunately...

    I have got this far, and all that works, but the installer still fails on all three four platforms: windows, ubuntu 17, ubuntu 14, osx.

    ...still working...



  • Cheers @lakota. I have been there and met some kindly experts.
    Not there yet, unfortunately.

    I think my (originally android) BG E5 HD (16GB, 2GB RAM) has a locked bootloader. ...investigating...



  • @docmathoc Glad your moving forward even if its taking sometime. You will get it sorted and then you can fully enjoy UBports and all it has to offer. Don't forget to pop back to the welcome install group if you have any further issues, and welcome to the community.



  • @lakota cool Nostromo btw


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.