No WiFi on Nexus 5



  • I installed Ubuntu Touch last night using the UBports installer. Everything went fine. My home network was detected and WiFI connected straight away. I don't have a SIM installed. I downloaded some apps and data access worked fine. I turned the N5 off and went to bed.

    Woke up this morning, turned on the N5, and the WiFI was not working. In the WiFI settings, no networks are showing up (I usually can see some of my neighbors networks and my own when scanning for my home network). I tried turning WiFI off and on and rescanning. That did not work. I restarted the N5 a couple of times but that did not work either.

    My home network is listed in the settings but the Forget option is grayed out and there is no Connect option. I should add that I installed the stable version of Ubuntu.

    Any ideas?

    Jon



  • @pavejon Hi, Swop the update channel from stable to development in System Settings, updates (bottom of the panel ). Download and install the update and restart the phone. That should fix it. You should then be able to swop back to stable if you wish.



  • Thanks, I'll let you know if the steps work.



  • No dice. I used the installer to install the dev channel but I still do not have WiFI.

    UPDATE: I reset the phone and now I have WiFi again.
    Second UPDATE: Turned phone off then on and lost WiFI again. I confirmed I'm on the dev channel.



  • @pavejon i'm only a user and i have had problems with wifi on a Nexus 5 like you with no SIm inside.
    I noticed some things : if you wan't the wifi works, turn the wifi button off each time before switch off the phone. When you will reboot the phone, turn the wifi button on and it will works normally. DON'T FORGET TO TURN THE WIFI BUTTON OFF EACH TIME BEFORE SWITCH OFF THE PHONE.
    For the moment, reboot your phone, and see if you have wifi and how is the wifi button. If it is off, put it on and normally it will detect networks.
    This procedure works well for me.
    I hope it will help you.



  • @pavejon Hi, Just for future reference, if I have read your post right, you don't have to use the installer to swop update channels. You can do it from the system settings on the phone. Open system settings and at the bottom of that page it says updates. Open that and at the very bottom it says update settings tap that and you can change the channel from there.
    If you do that and have wifi after restarting you should be able to swop the channel back again to the stable channel using the same method, and should keep wifi.



  • @lakota When I go to Updates/Update Settings/Channels, "Channels to get update from:" is displayed with no option to change from stable to dev.



  • @pavejon Hi pavejon, When you tap on Channels dies anything happen you should get options of stable, release candidate and development. What setting is in the auto download section above. Try changing that option to any Data connection and see what happens. You do have a sim with data alliwance in don't you.
    I'm out at the min in bad reception area. So if your still having issues ask again in the welcome and install room in telegram at
    https://t.me/WelcomePlus.
    Other than that I can have a look again later.



  • @lakota I may have found a temp fix/workaround. If I reboot into Recovery Mode and then press the Power button the phone boots into UT and WiFi works. I can then go into Update Settings and see the option to choose Stable/Release Candidate/Development. If I just restart the phone, WiFi doesn't work.

    This is the only way I can get WiFI working. I'm currently on Stable and WiFi is working. I do have a SIM from another phone I could swap into the N5 to see if WiFi works with a SIM installed.

    Is the Release Candidate a better option than Development?



  • @pavejon Hi pavejon, The best for everyday use should be stable. I have dev on my Nexus 5 and have not noticed any issues with it on a daily basis. Yes try another sim to see what happens.
    Also I think Flohack put up a post to update the radio firmware on the nexus 5 on the forum. Try searching for that and give it a go, it may help. Sorry but I'm working at present so can't search for it but can look it up later.
    The work around should only be a short term fix. Lets try and get this sorted. Did you try the welcome and install group at all. All the best.



  • @pavejon This is the link I mentioned earlier. It might help with the wifi.

    https://forums.ubports.com/topic/815/howto-n5-update-baseband-firmware/2



  • @lakota Thanks.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.