Sound issue with MX4 after OTA3

  • Hello everybody,

    I have a meizu MX4, which I update to OTA3 a while ago. Since then, I have a lot of trouble with sound. It doesn't work reliably with phone call and alarm : sometimes yes, sometimes not ! But no problem with headphones.

    So I tried everything I know :

    • look carefully in the forum and elsewhere,
    • switch back and forth between different channels,
    • I think I tried 16.04 as well,
    • clean install,
    • clean install form firmware upgrade.

    Finally, I am using an old NEXUS 4 with OTA3 without any problem. But, the big screen and the camera of the MX4 is waiting on the shelf.

    Did anyone encounter the same issue ? If not, I would like to go back to OTA2 to have at least a usable phone but I don't know how to do it.


  • @ll other thing you can do is to file a bug report (here).

    PS This is the guide about making a good bug report.

  • i don't dedicated such problems on my mx4 with ota3

  • @advocatux, this is a good point. I will do it today (which means tonight...)
    Meanwhile, do you know how to switch back to OTA2 ? (This will confirm the issue comes from OTA3 only.)

  • @ll I really don't know how to install ota2. If you feel adventurous maybe you can play with MDT ( and see if it can install a legacy image for arale, or look for a legacy image in and flash it directly to your phone (*), or something like that.

    Obviously not an easy task and I don't know what could happen to your phone is something goes wrong.

    (*) This is the "old" method is you want to learn more about it

  • @advocatux I try again whatever I can: format from scratch, start to OTA1 (not the 2), update to OTA3, switch rc/dev/stable. But I still have some troubles. The speaker does work times to times.
    I will fill now a bug report.
    Moreover, I just saw today another guy with similar issue on a MEIZU pro 5.

    By the way magic-device-tool was not working because the link for the recovery image was not correct.

    Thank again.

  • @ll I think the Magic Device Tool is pretty much finished for now as Marius doesn't have the time to maintain it. Which is why your link is out of date. Shame really as I have found it quite useful in the past.

  • By the way magic-device-tool was not working because the link for the recovery image was not correct.

    @ll yeah I know, that's why I said "if you feel adventurous" and "you can play with MDT".

    What I mean is there's some ways to do that, for example looking at the code of MDT you can see it tries to download the recovery image from which doesn't exist anymore so you can replace it with (probably that's the one you need BUT I really don't know because you're trying to do some archaeological thing).

    I think you get the idea, you can customize your own MDT or see what that script does and type the commands (pointing to the right server) in your CLI. Of course, the recommended way to get the best results is to do this using Ubuntu 16.04 with all the needed tools installed (like phablet-tools).

    Edit: the legacy channel for your device is still online as you can see here

Log in to reply