Howto setup framework "ubuntu-sdk 16.04"

  • The more I read the more I get irritated:

    with "clickable init" I can generate atemplate for a ubuntu-sdk:15.04 framework. Running "clickable" gives the following error message.:
    "Unable to find image 'clickable/ubuntu-sdk:15.04-armhf' locally"
    I would like to test the app on my desktop, but even this fails:
    "Unable to find image 'clickable/ubuntu-sdk:15.04-amd64' locally"
    Since I run ubuntu 16.04 on my desktop, I tried to update the revision to 16.04, but without success:
    "Unable to find image 'clickable/ubuntu-sdk:16.04-amd64' locally"

    In any case the subsequent docker command filed.
    Command '['docker', 'run', '-v', '/virtual/UBports/streamtest/ddd:/virtual/UBports/streamtest/ddd', '-w', '/virtual/UBports/streamtest/ddd/build', '-u', '1000', '--rm', '-i', 'clickable/ubuntu-sdk:16.04-amd64', 'bash', '-c', 'cmake /virtual/UBports/streamtest/ddd']' returned non-zero exit status 125

    Even with the updated manifest entry nothing changes.

    I have build an initial docker image according to the docker documentation. Unfortunately I cannot use this image with clickable. Furthermore I have lxc images for ubuntu 16.04 amd64 and armhf from the original ubuntu sdk ide. At the moment I cannot see any way to use them too.

    I would strongly recommend to generate a howto for the 16.04 environment since the actual documentation (so far I could find ) is useless. For any developers which has installed a running build environment the switch may be small. But to set up a fresh build environment is described only in fragments and finally (from my point of view) incomplete.

    So I would like to ask for some guide to set up a fresh environment for Clickable for ubuntu 16.04.

    Thank you in advance.

  • Yes.

    deb package from ppa repository says version 4.2.1
    installed clickable -v says version 4.2.0

    So what!

    4.2.1 shall have support for 16.04, 4.2.0 not. What do I have????
    And with the installed version I initiated the docker usage (clickable setup-docker) and get the above listed error messages.


  • It looks like you might have an issue with docker or something. Normally docker will pull those images from docker hub if they don't exist on your machine. Try running docker pull clickable/ubuntu-sdk:15.04-armhf , that should manually fetch the image.

  • dear bhdouglas,

    thank you for your hint. This failed too.

    Finally Docker needs a specific setup for the proxy server to use. Having done this in the right way docker can load the images.

    There is still the issue with the revision mix.

  • @hoh61 perhaps you want to try clickable --desktop -k16.04 then... But for me it also works with the 15.04 image on my laptop...

  • @hoh61 I wondered if it was a network related issue. I'm glad you got that sorted out. As for the version mismatch, there will be another release soon that'll fix that.

  • @hummelbach:

    thank you for your proposal. I tried it already for test purposes on my desktop. After resolving the network issue I could install the necessary image. However, when testing I get an error message related to missing graphics drivers, which are installed according to apt.

    Nevertheless, for the small tests I actually run it is still working.

Log in to reply