ufw problems with OT4



  • Hi everyone,
    I upgrade recently from 15.04 to 16.04 stable on OPO.
    On 15.04, i used ufw as firewall, as it's pre-installed.
    But after uprading to 16.04, I couldn't manage to have it working.
    Here the error I get when I try to enable it :

    phablet > sudo ufw enable
    sudo: unable to resolve host phablet
    [sudo] password for phablet: 
    WARN: uid is 0 but '/etc' is owned by 109
    WARN: uid is 0 but '/' is owned by 109
    ERROR: Couldn't stat '/etc/ufw/user.rules'
    

    And when I try to get the status :

    phablet > sudo ufw status
    sudo: unable to resolve host phablet
    [sudo] password for phablet: 
    ERROR: Couldn't stat '/etc/ufw/user6.rules'
    

    Any idea?
    I know that 16.04 introduced some changes in the core, but I don't really know what.



  • @ellypsis I can only report that it is working on OPO on the rc (13) channel. You may want to try that. I have been running it for a few days as there have been a few issues on the dev channel lately.



  • @lakotaubp I'm not sure to switch to dev channel as it's my daily driver.
    I suppose that the problem will be corrected in OTA5



  • @ellypsis You should be ok on the rc (release candidate) channel that is running fine. Please let me know how you get on. You should be able to change from the settings menu. Leave the dev channel at present have not had time to check it today.



  • Hi All,

    Glad to hear someone talking about firewalls, am a linux noob so had not considered the ufw command.

    Installed 16.04 stable with a full wipe on the Oneplus One lately and these are the results when I run the commands:

    0_1536343063155_cropUB.jpeg

    Is that helpful?

    It seems the firewall is working for me.

    If someone has time could they comment briefly on what the WARN outputs mean?

    A blog post about the firewall and how to configure and use it would be great.

    Wonder if someone is making a GUI for the openstore.

    Still on UBports on the Oneplus One and am impressed with how it's coming along.



  • @brangdoet Glad its working for you and that your enjoying UBports Ubuntu Touch. Seems that the wipe option might be the the issue. Mine was also a wipe install. Lets see if anyone else has more info on that part.
    As for the outputs other than it nit letting anything in on certain ports I have no idea (I'm not techy enough for that) but someone will. Have a look at https://ubports.com/telegram-welcome for more Ubports info



  • @ellypsis I haven't dug deeper to find the culprit but something is inherited from vivid that makes ufw fail in xenial, so the easier and quickly way to fix the issue is to do a factory reset once you're running 16.04.

    Note that you'll need to backup any data you want to keep before doing that wiping.



  • @advocatux hmm that's something I wanted to avoid. Maybe if I reinstall ufw? How can I make the / writable? It was easy on 15.04, but I'm not sure on 16.04



  • @ellypsis IIRC some users tried that road before but it didn't work, but of course YMMV so sudo mount -o remount,rw / :)


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.