Development testers for Anbox

  • I have another issue. With adb installed on my phone I got problems on OPO because no connection is possible. The command 'adb devices' states the emulator is offline, even though it was possible to start apps. But can't install others. How can Anbox be visible as device again?

  • Can it made possible to use emojis for the Android Keyboard in Anbox for typing? For now they are not usable, because they all are displayed as crossed boxes.

  • This post is deleted!

  • @joe I agree. I would like to draw everyone's attention to this issue, and as I say, we need a way to start from fresh with Anbox without having to reinstall Ubuntu Touch. This is especially important for when Anbox is entirely stable and becomes a part of the system image for a future UT OTA.

    Sister issue regarding the importance of being warned or even blocked from installing problematic apps, as desktop snap-based Anbox implementations already do:

    I'm also wondering if Anbox can be destabilised if users try to install APKs beyond a certain storage level? Like, if we install several apps which are each ~100MB, and this is from a starting point of say 1.5GB free storage space left, is there a point at which things start to break? And I mean before running to to 0MB left.

  • @gb I had to enlarge the system partition on my Nexus 5 to install everything, if I remember correctly. Maybe that's your issue? I think I followed this script with minor adjustments, but caution I don't remember since it's been a while – do it on your own risk 😉

  • @padraic said in Development testers for Anbox:

    anyone successfully get frieza working? I tried but am told that

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!

    Pretty sure I went through the procedures correctly but maybe I missed something. If I don't hear back from anyone I'll try again in a couple of days and open an issue if it still doesn't work.

    I have the same problem

  • @gb

    @gb said in Development testers for Anbox:


    I´m testing it in M10 FHD (frieza).
    I just installed ubports from scratch (16.04 dev) and try the instructions post by Marius.

    Doing "sudo apt-get upgrade", I´m facing:
    "E: You don't have enough free space in /var/cache/apt/archives/."

    How can this be possible? I just installed the system and there is no space left?
    Do I have to install the hole thing into a Libertine container?

    You can try (it has helped me):

    sudo mount -o rw,remount /

    sudo rm -r /var/cache/apt

    sudo tune2fs -m 0 /dev/loop0

    sudo apt update

    sudo apt install anbox-ubuntu-touch

    sudo rm -r /var/cache/apt

    sudo mount -o r,remount /

  • @pawlinski I'm having the same issue. Installation was successful after cleaning the cache several times. but when I try to install anbox-tools I get the same error as @padraic .

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

  • @honigwald What does sudo anbox-tool status say? On my Nexus 5, sudo vs no sudo shows different status.

  • @gmelchett Hi. This is the Output I get.
    0_1540939338796_Screen Shot 2018-10-30 at 23.41.55.png

    Until now, I've resized /dev/loop0 to 3GB and reinstalled everything without success.

    Btw.: I'm using BQ M10 FHD

  • @pawlinski Have you installed the boot.img for frieza with fastboot?

  • Just tried anbox for the first time on my Fairphone 2. Installed a few apps (pulling APKs from my android device using this description).

    As expected, my bike sharing app doesn't work as it uses google services.
    But spotify works 😉

  • @ursfan Yes.

  • Hi, has anyone tried to install anbox on a bq M10 HD yet?

    i have , but anbox-tool is telling me i need to flash the kernel, but i did that?!

    i followed instructions from here:

    might there be some step missing? or is the anbox-boot-cooler.img not functional?

  • @yougo: Just stating the obvious, but it is a mistake that I made initially when trying anbox on my M10FHD: Did you use the correct name for the boot partition when flashing the boot image (boot instead of bootimg)?

  • Exciting progress. I sucessfully installed Anbox on my FP2. For installing additional apks; I tried to install adb android-tools-adb:

    phablet@ubuntu-phablet:~$ sudo apt install android-tools-adb
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 108 not upgraded.
    Need to get 64.1 kB of archives.
    After this operation, 152 kB of additional disk space will be used.
    E: You don't have enough free space in /var/cache/apt/archives/.

    This is confusing, because the system info says, that there is more than 23 GB free space on my FP2.

    Some idea to resolve this issue?

  • Using pawlinskis approach from

    sudo mount -o rw,remount /
    sudo rm -r /var/cache/apt
    sudo tune2fs -m 0 /dev/loop0
    sudo apt update
    sudo apt install android-tools-adb
    sudo mount -o ro,remount /

    The system image has just 2 GB and the commands above free some of that space. The 23 GB free storage you mentioned is the part of the storage reserved for user data.

  • @honigwald I have the same problem. BQ Aquaris FHD (frieza).
    Flashed the the kernel as shown at, but anbox-tool status says:

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: NOT OK
    System: NOT FOUND
    Enabled: NO
    Running: NO

    Prior to installing I grew the ubuntu.img / system.img to have enough space for apt on /.
    Somehow the kernel does not get installed... Anyone has solved this?

    Maybe this is relevant: I bought the Android version of the tablet - then installed UBports UT. Maybe this changes the boot partition / image?

  • @arubislander So did I. Maybe boot is incorrect?

  • I just used ubports-installer to flash 16.04/rc onto the frieza, then resized the partition, then installed anbox using the tutorial. No success 😞
    @mariogrip How did you do it?

Log in to reply