Development testers for Anbox



  • @ricardo65 said in Development testers for Anbox:

    @Ingo I've installed anbox on the nexus 5 channel devel and I can not connect by wifi.is any known bug?.I have restarted the mobile several times and I do not detect it

    corfirmado, in RC works perfectly the wifi with anbox installed.



  • Not sure if it was you, but here is a fresh issue about the WiFi problem: https://github.com/ubports/anbox/issues/36

    I don't have a Nexus 5, so unfortunately no idea 😞

    What I know, in devel channel the so-called "edge merge" has happened (https://forums.ubports.com/topic/3293/what-s-this-edge-merge-anyway) and AFAIK it's not on RC yet. Not sure if that is related but it's an abvious difference between the two channels.



  • @Ingo What command should I use to uninstall anbox? thank you



  • Here is a topic about that question: https://forums.ubports.com/topic/2963/uninstall-anbox

    If you don't mind some remaining files laying around in /home/phablet you can just re-install UT without wipe. Kernel and rootfs modifications will be gone. The android rootfs plus apps will still be there, though. Not sure if anyone ever wrote instructions how to get rid of all anbox related things.



  • Hey all. I'm trying to install Anbox on my PRO 5 and am running into a problem with anbox-tool install. I'd welcome any illumination, perhaps information on compatible versions of UBports and Anbox for the PRO 5.

    I've got UBports 16.04 (OTA-11, stable) and anbox-boot-turbo-test.img flashed (as described here). When I attempt to install Anbox with anbox-tool install, I am presented with a Python error that concludes with the following:

    json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)
    

    Does anyone happen to have any ideas on what is going wrong and how I might get the latest possible Anbox running on the device?

    I attempted to install anbox-ubuntu-touch on UBports 16.04 (20200107, devel) but it did not appear to be available.



  • @BlandCorporation Hi, as far as I know, on devel channel you don't need to flash the kernel image anymore because already embedded in the OS image. This step, according to my experience, led to break something (for instance the wifi connection). I didn't try myself yet and I don't know if it will resolve your issue either but I think that the best would be to restart from scratch in the devel channel and skip the part related to flashing the kernel image.



  • @matteo Magic, thanks for that suggestion. Anbox was installable using the development channel without the need to flash a kernel for it separately, as you guessed. Regarding your Wi-Fi experience, I am not experiencing any Wi-Fi problems for native applications running while Anbox is running or for Anbox applications. For you and any others reading, the following UBports and Anbox versions were those I observed as being compatible:

    System Version
    UBports OS build number 2020-01-08
    UBports Image part 20200108-27502
    Ubuntu build description Ubuntu 16.04 LTS - armhf (20200108)
    Device image part 20170608-43243
    Device build description turbo-user 5.1 LMY47D 15 test-keys
    Anbox pool/xenial/main/a/anbox/anbox-ubuntu-touch_8+0~20180916133012.39~1.gbpe34b59.deb


  • @ricardo65 It may be too late now, but I had the same issue and the video posted by a member of the forum helped me solve it.

    @HendriXXX said in Series of my Ubuntu Touch related videos:
    New video of Anbox install.. Because of fixed "wifi killer bug", installation is much easier and faster. ☺
    https://youtu.be/dOfVTp1XtX4



  • @mariogrip
    But can Anbox error be the lack of video and audio playback in all android applications? And the fact that I use Anbox on the OnePlus 3t device.



  • Would you be so kind and add
    oneplus3t: "android-armhf-64binder"
    to https://cdimage.ubports.com/anbox-images/devices.json.
    It will work for the oneplus3t too, if this entry is in the .json file. The devices are very similar. I have tested it with a modified anbox-tool (changed the .json url in anbox-tool to a http server of mine and used a modified devices.json).



  • Hello together, I've tried Anbox now after installing UT with OTA-12 (stable channel) on my FP2.

    To deal with the battery drain, here is an Explanation how to set up an "Anbox-Toggle" button for disabling/enabling Anbox with an easy button (in german, but the script itself could help anyone): https://wiki.ubuntuusers.de/Ubuntu_Touch/Anbox/#Automatisches-Umschalten-per-Icon

    I've tried several apps.

    • Conversations (F-Droid): starts, but I have not set up an XMPP account
    • Dir (F-Droid): seems to work
    • DB Navigator (APK extracted via adb fromAndroid Smartphone): the latest version from Google Play crashes while starting up. A very old version of the app, which I am using on an old Android 4.0 Smartphone, starts up. But I cannot load online tickets (app crashes). I can also not look for Transport Connections because there is no Dropdown menu Opening to select a Train Station. So unfortunately, it is not usable at all.
    • KVV.ticket (APK extracted via adb fromAndroid Smartphone): it's an very "old style" Android app and it works
    • F-Droid (F-Droid Webpage): works
    • Öffi (F-Droid): Looking for Transport Connection works

    Generally, the apps don't start up always, even when Anbox is definetively enabled. I have to try various times and sometime even reboot the phone. The apps in Anbox are all very slow, especially the touchscreen responds slow and sometimes I can hardly touch a button etc. Often, Anbox is just crashing for me, once also Lomiri crashed while I was using Annox.

    As a result, unfortunately I would say that Anbox is still not for "productive daily driver use" and I'll say that realistically you still have to stick to the (web-based) UT apps for serious usage on a UT device. This is a pitty, because especially for public Transport many tickets can only be bought via iOS/Android mobile app.



  • Hi, I think one of the script creator wrote a post also on this Forum on the same subject. I'm referring to this if it's of any help for you or other interested people, at least it's in english. I'd like to help with Anbox myself, but I'm not competent enough, sorry to say.



  • I have an interesting problem - running Anbox on a Nexus 5. Fdroid can access the internet and install apps, but my android apps cannot. I've searched the forum and see the same question asked several times, but no answer. So hoping someone knows how to fix this?



  • Is there a way to get Anbox up and running on Nexus 7 2013 (deb)?



  • Hi! Does someone know how to build anbox from source and set it up in a mobile device?

    I would like to do some development on anbox for ubports, but I am struggling with making my builds work. I am using a Nexus 5 to test, which I managed to get up and running with the current release version of anbox in the repositories via apt.

    So far I managed to compile the code following the steps on this thread, but I unfortunately didn't manage to get it up and running. Any ideas of what can I try? Do you know how to get the debug logs out of this anbox version? (All the info I found about that was regarding the snap version of anbox)



  • @gischpelino
    had a quick look and nothing was jumping out so,
    Just out of interest what did you alter? I'd love to use this on my OnePlus3t.
    I have a op3t also and would love this feature.

    Many thanks


Log in to reply