Development testers for Anbox

  • Coming from here:

    Do I have to build the Anbox boot image for myself?
    Do I need to modify the anbox-tool package?

    And in general: Are there any tips on getting started with Anobx development for UT?

    Thanks, Jan-Luca

  • Banned

    Ok been goofing with ubports for a few days again first installed with multirom a couple years ago but now that app seemingly fails to receive any updates doesnt give option to install anything I fear completely dead( correct me if you found a fix for this so I can go back to dualbooting with And9), hoping someone can catch me up on somethings. Found these instructions which worked for me one oneplus one. Installed FDroid internet is working. Some apps dont like to open without clearing app cache but not bad. Tried to install play store/services using this tutorial, cannot install the file due to snapd not starting being listed as unavailable but installed. A no snapd.socket cannot communicate with server error. Anyone manage to bypass this (possibly install this another way without snapd) or get snapd fully running? old version? found this for a different device not sure if it is a 32/64 bit issue or if there is a way to install this old snapd version/ acceptable kernel.

    Any luck with play store with Micro g or the crackberry patch google apps route? Also anyone enable a backbutton/ navigation keys? I did the suggested fixes for apt-get running out of space but I keep running out again how can I make apt-get use my full 64 gb storage? mounted rw permenantly using
    $ adb shell
    $ sudo touch /userdata/.writable_image
    $ sudo reboot
    from here Can I symlink something possibly to get full space for apt-get(not just storage?) Hopefully this thread isn't dead thanks in advance for any help

  • Banned

    with multirom dualboot install I never had the space issue it must be something simple but I'm not pro linux level to figure it out

  • @errorcodevortex you cannot install snapd on Ubuntu Touch. It will not work. Please use the instructions for installing Anbox in this thread or in the documentation.

  • If you want to use apps from play store which don't require too much play services, you're probably better off just installing the microG packages, and Aurora Store.

  • Banned

    @UniSuperBox I got anbox going good no problems. From what I gather it is flashing same kernel but simpler unified instructions? Just happened to runinto that tutorial first. This anbox is still based on android 7.1.1 right?. How did that guy get snapd running tho I wonder

  • Banned

    @dobey downloaded aurora and yalp store through frdroid, but have never had much success with microg in past have not done that yet but thats probably what I'll end up doing. I don't see any better method than that for full play store ability without fixing snapd unless I could figure out how to install/ run a without it, or pull off installing each non play-serviced modded apks separately through something like this but I feel like its a stretch. Anyone try those yet?

  • @errorcodevortex said in Development testers for Anbox:

    How did that guy get snapd running tho I wonder

    It was an extremely experimental image from when Canonical still was developing Ubuntu Phones and Unity8, as the plan was to move the whole system to snaps. Had that happened, there would be no rootfs to resize. Your only option to get debs would have been to install the "classic" snap, and install things in the container it provides, much like how libertine works.

  • Banned

    On my oneplus one fresh install of anbox the webviewshell doesn't run but everything else does is connected to the internet with other apps. I was trying to add the key to add the gms repository to frdroid but I couldnt confirm it all the way without entering a browser on the android side. Workaround to this? Anyone find any browsers that work or a solution to this? And also has anyone managed to enable Magisk superuser yet? Is it possible to flash any zips through recovery I have not yet tried.

  • @errorcodevortex said in Development testers for Anbox:

    Is it possible to flash any zips through recovery I have not yet tried.

    I can't imagine that this can work at all.

  • @errorcodevortex said in Development testers for Anbox:

    And also has anyone managed to enable Magisk superuser yet?

    This seems possibly not necessary, though I don't know what your specific goal is with that.

    @errorcodevortex said in Development testers for Anbox:

    Is it possible to flash any zips through recovery I have not yet tried.

    There is no concept of a "recovery" as far as the anbox part is concerned. It is an android container running on top of UT.

  • Banned

    @dobey Yes flashing magisk through recovery broke system didn't boot but had to try app installs fine. I am going to try and patch with magisk the anbox-boot.img and see if that pulls anything off.

  • Banned

    @mariogrip @Ingo @ursfan

    I wanted to attempt to give root anbox apps permission through a superuser app was my intention. Any other ways without a normal superuser? Magisk Manager app successfully patches the anbox-boot.img and anbox is still installed, nothing crashes.
    Replacing these commands
    sudo fastboot flash $PARTITIONNAME anbox-boot-$CODENAME.img"
    with "sudo fastboot flash boot anboxmagiskboot.img" (which I put in my /home/username folder[same place wget download would go too]) succeeds and anbox does appear to get installed correctly.
    Magisk app does shows magisk is uninstalled still but I believe if I flashed onto a fully 100% read-write system it might work or there may be a solution I can't figure out.
    I anbox installed a terminal apk typed su which leads me to "/system/bin/sh: su: can't execute: Permission denied" error.
    Went to over to regular phablet shell and issued "sudo chmod 755 /system/bin/sh" & "sudo chmod 755 /system" etc but led to read only file system error. Any ideas or input?

  • @BryWilson Man that's my thoughts exactly ! Everything you said. Kudos here.

  • @baddea I had the same problem with a game. Anbox installs and runs smoothly, and so does game installation but it's meant to be played with screen rotated- and it gives me the same kind of half baked display, with touch input in full disarray

  • By the way, is all this fiddling with anbox has the goal of eventually making it a click package ? Or at least a dedicated installer, sth available in the openstore ? Or are we stuck with adb and reboots ? Thanks for the work, love you all

  • @Emphrath it cannot be just a click package, as it needs kernel modifications and elevated priviledges for installation. Because we cannot provide them currently for all supported devices, there is no end in sight of manual steps for the time being. Sorry!

  • @Flohack Well, once the kernel side can be stable and not cause issues without anbox container installed, then it at least can be included in the images by default.

    Once the container side is stable/usable enough, and doesn't kill battery and such, then probably the bits for installing and setting up anbox could also be included in the image, like how we have libertine.

    But indeed, for now, anbox is not a priority, as there are many other things that need fixed in the system first.

  • @dobey That's what I wanted to know. Thank you

  • @tricky i am trying to install anbox but unable can u help me

Log in to reply