Development testers for Anbox

  • @marc_aurel Storage is in ~/anbox-data/data/media/0/

  • @bodow Thanks for the clear advice. Unfortunately I'm struggling with accessing the storage for Anbox.

    I tried to copy my address-book to the Anbox container:

    adb push contacts.vcf /home/phablet/anbox-data/data/media/0/
    adb: error: failed to copy 'contacts.vcf' to '/home/phablet/anbox-data/data/media/0/': remote Permission denied
    contacts.vcf: 0 files pushed. 142.5 MB/s (720808 bytes in 0.005s)

    I also can't access the media directory. I only can list the content of the data directory, but I can't switch to a subordinated directory.

    phablet@ubuntu-phablet:~/anbox-data/data$ sudo ls -l
    [sudo] password for phablet: 
    total 5136
    drwx------  2 root   root             4096 Dec 13 18:20 adb
    drwxrwxr-x  2 system system           4096 Dec 13 18:20 anr
    drwxrwx---  4   1023          1023    4096 Dec 13 18:20 media
    phablet@ubuntu-phablet:~/anbox-data/data$ cd media
    bash: cd: media: Permission denied
    phablet@ubuntu-phablet:~/anbox-data/data$ sudo cd media
    sudo: cd: command not found

    I have a similar problem if I use the file manage on the device. But I also tried an adb push command within the device without success.

    phablet@ubuntu-phablet:~/Downloads$ adb push contacts.vcf /data/sdcard/Download
    failed to copy 'contacts.vcf' to '/data/sdcard/Download': secure_mkdirs failed: Permission denied

    Some idea?

  • @marc_aurel just my 2 cents here. Did you try, before to navigate into the anbox folder, to type sudo su and gaining the root access?
    Second hint: you could try to move first your contacts file to an accessible folder, as for example Documents or Downloads, with adb push from your PC and then, from the terminal on your PC, you could type phablet-shell instead of adb shell, since I found out the latter has some limitations in writing on the phone partition. In the end, you could just copy your file, maybe better with root privilege, to /home/phablet/anbox-data/data/media/0/ using the cp or mv command.

  • Someone suggested the following somewhere

    mkdir -p /home/phablet/AnboxHome
    sudo chmod -R 777 /home/phablet/anbox-data/data/media/0
    sudo mount --bind /home/phablet/anbox-data/data/media/0 /home/phablet/AnboxHome

    But with the clear hint that making things 777 generally is not a good idea.
    Of course the minimal way would be just the second line. The other are just there to have an easier/shorter path.

  • @marc_aurel You're right. Sorry, I didn't have a shell open when I was writing my response and didn't remember that you had to "sudo su" or "sudo -i" first (as @matteo mentioned). I'd prefer this way as I would have a bad feeling about 777ing a directory permanently.
    Besides that: Does it work now?

  • @bodow Thanks for the advice. The following approach works:

    sudo su
    cp contacts.vcf /home/phablet/anbox-data/data/media/0/contacts.vcf

    I resume. The system integration of Anbox seems to be very limited. The apps are shown in the app scope and the apps have hardware access with network and storage. I think, that's it.

    It's possible to copy files with adb shell, but this is not for an average consumer.

    It seems there is not service or data sharing. I haven't tested notifications, yet.

  • hi, i was trying use anbox on my nexus 5 device, and got /bin/bash: pm: command not found error, do you know this?

    # install command
    ➜  Downloads adb install MobileAssistant_1.apk
    [100%] /data/local/tmp/MobileAssistant_1.apk
    /bin/bash: pm: command not found
    # adb shell infos
    root@ubuntu-phablet:~# dpkg -l | grep anbox
    ii  anbox                                                8+0~20180916133012.39~1.gbpe34b59                            armhf        Container-based approach to boot a full Android system on a regular GNU/Linux system
    ii  anbox-common                                         8+0~20180916133012.39~1.gbpe34b59                            all          Common files necessary for Anbox
    ii  anbox-ubuntu-touch                                   8+0~20180916133012.39~1.gbpe34b59                            all          Files necessary for Ubuntu touch
    root@ubuntu-phablet:~# dpkg -l | grep android-tools-adb
    ii  android-tools-adb                                    5.1.1r36+git20160323+ubports1+0~20181125103222.6~1.gbpc708bb armhf        Android Debug Bridge CLI tool
    ii  android-tools-adbd                                   5.1.1r36+git20160323+ubports1+0~20181125103222.6~1.gbpc708bb armhf        Android Debug Bridge Phone Daemon
    root@ubuntu-phablet:~# anbox-tool status
    Kernel: OK
    System: OK
    Enabled: YES
    Running: YES

  • Are you executing adb install MobileAssistant_1.apk on your PC? That would explain the pm: command not found.
    You have to transfer the apk to the phone and do adb install ... there (assuming you have installed adb on the phone first; which by the output of dpkg is the case).
    Basically this:

  • @ingo thanks for the reply, I have install the apk successed

  • @mariogrip Excuse me. How can I build this : ?
    I followed this step : and lunch anbox_armv7a_neon-userdebug
    Using my built android.img can't work.
    I still have a question, why use android-armhf-64binder.img instead of android-armhf-32binder.img

  • @mariogrip Excuse me. Can you share your local anbox project to build android-armhf-64binder.img ?
    when i use to build , There are a few 、anboxd 、 netd

  • I want to test some of the applications we rely on. like : qq、weixin、etc.

  • for my building , network cat not work

  • I case anyone wants to run the Anbox AppManager by tapping on an icon, here is my .desktop file to do that:

    [Desktop Entry]
    Name=Anbox AppManager
    Exec=/usr/bin/anbox launch --package=org.anbox.appmgr --component=org.anbox.appmgr.AppViewActivity

    Save this as /home/phablet/.local/share/applications/anbox_appmgr.desktop

    The logo is this one:
    I saved it as anbox_logo.png on the phone in /home/phablet/.local/share/applications/

  • On my OnePlus One test phone, FDroid cannot find the network connection so cannot download its repositories. Has anyone with a OpO gotten it to work?

  • Have time to test anbox on Nexus5. Have lots of time after career as engineer, but am Newbie on Development testing!

  • @Frank great, with your expertise you'll get the hang of it in no time 🙂

  • @advocatux Thanks man! 🙂

  • @Frank you're welcome!

  • oh guys i face two problem

    Rotate App not in full screen please check the link below :


Log in to reply