Development testers for Anbox



  • usually when I anbox is not starting, I just restart the ubuntu. It works most of the time. Is there a better way to make anbox run again? Also, for those not doing this, if you are connected to anbox through adb shell and lxc-console you can see debugging msgs of anbox in realtime on your PC. This helps a lot to understand what anbox is doing, since it includes error msgs.

    "does is work in 'other phones'?"

    The only thing specific to each phone, I belive is the modification in the "boot image" to include the requeried kernel modules (for ashmen and binder nodes in /dev). Modifications in the anbox.img are the same for everyone, I believe.

    Hey mario, if you are going to confirm this, are there other modifications to the kernel or the boot img that you do?



  • @mihael Yes it do work on a Pro 5...



  • @mihael Haven't tried that yet as I'm on holiday and have not access to a PC to flash it.



  • On Telegram advocatux give me a link that worked to install apps, as Marius told me he need to do more work on the anbox-tool...

    https://docs.anbox.io/userguide/install_apps.html

    I have test this and indeed it install the apps.



  • @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sudo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    EDIT: sorry, I miss typed the sudo command.



  • @alkis said in Development testers for Anbox:

    @xray2000 The method I have used to install apps is

    $ sudo mv $APP ~/anbox-data/data
    $ sduo lxc-console -ndefault -P /home/phablet/anbox-data/container -t0
    $ cd data && pm install "app.apk"

    substitute "app.apk" for the name of the apk you are installing and $APP for it's path outside anbox

    sudo lxc-console -ndefault -P /home/phablet/anbox-data/containers -t0



  • I just tested the new anbox update and yes, both the keyboard and network is working. I even made a whatsapp call to my father, for shits and giggles. It doesn't have sound as expected, but it did connect.


    this is a screenshot of a msg, but I also made a call with no sound.
    If we get the sound server working, we would be able to start making whatsapp calls! That would be awesome.
    Anyway, it is already a great achievement.

    Also, I noticed that sometimes, if you already have a anbox app window opened, anbox won't open another app



  • @alkis This dont work on a Pro 5, it seems the lxc-console is running anbox output on my device continues and i can not give any command there. With the link advocatux give me that works a lot better no need to move any apk or anything...



  • This post is deleted!


  • MEHHH!!!!
    0_1537192699518_70dbbac8-da0d-439e-8663-90d426686a16-image.png



  • I can confirm that the turbo-test img works on the Pro 5. I also installed WhatsApp and it works. I am so very glad and delighted about all this work!!!



  • anyone successfully get frieza working? I tried but am told that

    phablet@ubuntu-phablet:~$ anbox-tool install
    Anbox kernel is not installed! Please flash this first!
    

    Pretty sure I went through the procedures correctly but maybe I missed something. If I don't hear back from anyone I'll try again in a couple of days and open an issue if it still doesn't work.



  • On N5 I recognized: Installing System updates seem to cause the reinstallation of the native kernel. This causes a disfunctionallity of anbox and heating of your device (100% CPU). I recommend to disable automatic System updates.



  • @mariogrip
    you are God?



  • @jor1196 No he created (programmed) god! ^^



  • @mihael Fair play to you on getting Anbox apps to work on the Pro5! Any chance you can reveal how you did it? When I try (on turbo/devel), like a previous poster, I'm getting "Anbox is not running" errors and when I type "anbox-tool status", it reads "Running: No" - but the preinstalled apps open and seem fine.

    Using the "lxc-console" method either tells me that I don't have "sufficient privileges for default" or if I use "sudo" for the command, I get endless debugging verbiage...


  • Administrators



  • @brywilson
    try this method if it still woks



  • @brywilson I only did what is recommended on this page, using the anbox-boot-turbo-test.img. I had previously tried to install anbox and it didn't work (the previous anbox-boot-turbo.img kernel) so an anbox android image was already on my device so anbox-tool install didn't work. I then used anbox-tool upgrade and then everything worked. Regarding logging into the container, yes, I use the sudo way. Yes, there are a lot of debugging messages flooding the screen but in spite of that I type the commands (thanks @Alkis for the code above)and then I hit enter and this is how I got the apk(s) installed.



  • Hi all,
    Somehow my anbox on OPO is still not runing even after few restarts.
    Is there any option to start it via terminal?

    phablet@ubuntu-phablet:~$ anbox-tool status
    Kernel: OK
    System: OK
    Enabled: YES
    Running: NO
    

Log in to reply