Morph Browser



  • Hi

    Indeed, since 533 dev in OPO, I have on my phone MORPH BROWSER, BROWSER NEXT, no old BROWSER.

    So, I thought BROWSER NEXT became unnecessary and desinstalled it.

    ******* A LITTLE TRICK ********

    We can install bookmarks.sqlite of old browser in MORPH BROWSER. So you take a duplicate of this file you have done... or you can find this file in .local/share/webbrowser-app because there are always old folders and files of old browser on phone. After this, paste the file in .local/share/morph-browser



  • @3arn0wl Is there a click package to download, to try Morph Browser?



  • @stefano afaik you can only try it for now running the latest xenial devel (it's included in the image) or using the ubports-qa script and installing ubuntu-touch but it should land in the RC channel "soon".



  • @advocatux I'm on stable channel, thought there might be a standalone .click somewhere...never mind, I'll wait for it. Thanks for the info.



  • But... UI Tweak doesn't appear to know about it! So I can't let it run in BG?



  • @vandys I need this...



  • @vandys I think it's because Morph is a deb package, not a click package (but maybe I'm wrong)



  • @advocatux If Tweak Tool worked for the old webbrowser-app then it should also still work for new morph-browser, but could be there is something hard-coded in the app for the browser?



  • @dobey now that you say it, I don't remember if UT Tweak tool worked for the oxide browser, but it worked for browser-ng.

    I'll ask in the QA group.



  • @advocatux I confirm UTTT works with webbrowser-app. I have a bq on 15.04 yet.



  • @domubpkm ah, perfect. Thank you!



  • I really need to prevent Morph Browser from suspending... Anyone figured out how to do this? đŸ™‚



  • After the latest updates, Morph-Browser doesn't start anymore on Hammerhead.

    I got this error on syslog each time I try and launch it:

    Oct 13 11:38:08 ubuntu-phablet dbus[2346]: apparmor="DENIED" operation="dbus_method_call" bus="session" path="/com/canonical/libertine/Service/Operations" interface="com.canonical.libertine.Service.Operations" member="list" mask="send" name="com.canonical.libertine.Service" pid=9883 label="morph-browser" peer_pid=3958 peer_label="unconfined"

    Oct 13 11:38:08 ubuntu-phablet dbus[2346]: apparmor="DENIED" operation="dbus_method_call" bus="session" path="/com/canonical/libertine/Service/OperationsMonitor" interface="com.canonical.libertine.Service.OperationsMonitor" member="running" mask="send" name="com.canonical.libertine.Service" pid=9883 label="morph-browser" peer_pid=3958 peer_label="unconfined"

    Seems to be related to Libertine, but I have no container installed.

    Anybody knows how to get rid of it?

    Thanks.

    M.



  • @eupalino Is your morph browser part of OTA-5 or download separately?. If not wait for OTA-5 and see what happens then. Or clear the cache and data with uTweakTool and try again.
    Lastly remove browser restart device and see how that goes. One other thing you could try removing any other browsers also.



  • @lakotaubp How can I find Morph Browser in UT Tweak Tool?



  • @mihael You won't find it there.



  • @stefano Do you know how to prevent going into suspend mode? - because the option to restore tabs on start doesn't work so each time it goes into suspend mode and then is brought back it goes to the homepage and I lose all the opened tabs...



  • @mihael If you open the browser and open new tab do the old visited pages show there. Not quite the same I know. As for not being in utweak I didn't know that need to find out why.



  • @mihael No, I don't know. I don't use this option at all.



  • @lakotaubp

    So, I finally seem to have gotten around to discovering the problem with my N5.

    Apparently, there is a conflict between the script below, reported in this and other forums, and Morph Browser. The script is used to increase the overall font size displayed on the phone. It's very useful, since at the moment there is no way to increase the size of the GUI fonts, which are very small to read—at least for me, they are.

    The script is called gu.conf, and is placed in /home/phablet/.config/upstart/gu.conf

    This is its content. The pixel number can be changed at leisure.

    start on starting dbus
    exec initctl set-env --global GRID_UNIT_PX=27

    It looks like that the variable set here doesn't go down too well with Morph Browser.
    Removing or commenting out the script restores the functionality to Morph Browser.

    That's all I found.

    M.


Log in to reply