Nexus 5 GPS Errors and other issues



  • Here are some issues I am currently having. Just wondering if other nexus 5 owners are going through.

    1) For me UNAV just doesn't recognize my current position at all. It always tells me I am like at my university while I am actually like 10 miles or so away. I did go out of state to Nevada where out of curiosity it told me exactly where I was correctly. I have refreshed cache with ut tools, left location data on, ran unav in background it just never works. Especially when trying to use gps it set starting position in california when I actually was in Utah?

    2) My Cellular data is not consistent always going to unregistered or denied some times. Only works in certain locations. Especially frustrating when it auto disconnects in ones pocket and won't reconnect by itself to initial carrier in my Case T-Mobile.

    Extra: I am currently on OTA 5 and noticed with the Morph Browser, It broke compatibility with the app UTmedia It launches but won't load a video any more. Just wondering what's the current eta for local video playback on nexus 5. It still does the green and purple colour effect when playing video.

    Love the os just thought I list some of the issues I am going through. For contexts my nexus 5 is full refurbished by me and I have many more spare parts for it. Thanks.



  • @that_rin

    1. for you GPS, have you wait up to 10 minutes with unav and screen on ?

    Extra : Green and purple while playing the video is a known bug :/



  • @ernest Sorry for late reply.

    Sadly I tried this just went around town location data on. Unav running, even told it to never suspend on with ut tweek tool. Sadly when I checked my current location it told me I was currently at an amusement park which in my area is about 50 miles away. Was running for about 3 hours like this always same starting spot.



  • @that_rin

    Strange, do you have any cover on this phone ?
    What does mean location data on ? Location on or data on ?

    First it will localize you with the cells tower then GPS will find satellites.



  • @ernest
    No cover at all its wierd when I am at home it says I am at university. In town it says I am somewhere 3 hours away. Its just never finds my location.



  • @that_rin Just tried on my m10 and it took 10 mins to find me. Location settings on GPS in UBports, online style Mapbox in uNav settings. M10 is on dev channel ota-5.



  • Just tried OPO same settings did take nearly 20 Mins but bang on target.



  • tried gps on my nexus 5 OTA 5, location access allowed only for osm and unav in system settings:

    OSM:

    • quick with position (less than 1 minute) but wrong: ~about~ 30 km too far west and a bit too far north
    • but popup asks permission even though its enabled in system settings already (edit: maybe that´s normal, no idea, never tried before)

    unav:

    • quick with position (less than 1 minute) but wrong: ~about~ 30 km too far west and a bit too far north

    to me it looks not like a software problem but more like a system-wide problem with interpretation of gps-data maybe (?)



  • @obacht Try allowing clock access though I don't see why it would change much unless timezones in someway. Also try the,sensorstatus app in the opensore see if that show an issue.



  • @costales (uNav author & developer) recommends to reboot the device after configuring uNav or after the GPS stops working properly. That should fix the issue with the GPS.



  • @Lakotaubp Sensorsstatus app is pretty close and does not show issues. And after restart of the phone and playing with allowing clock and scopes to gps both apps (unav and osm) show correct position also without gps access for clock and scopes .
    (every once in while unav states it doesn´t have gps permission (which is not true), restarting the phone fixes that.)
    But both apps start with the same wrong position (as stated before) for a few seconds before they jump over to the correct position. I assume that could be my internet-providers "physical entrance point" that is checked by the apps before the gps signal is available and digested - could that be the case?



  • @obacht Yes have had the odd off starting point soons sorts out though.



  • Sadly still no correct location.

    1)Gave Clock gps access (cleared cache with UT Tool) says I am in Greenville? thats like 4 days drive. I noticed that in settings menu for time in ub touch it says correct area.

    1. Waited 20 minutes for UNAV Sadly still sames same area. Even when I initiate gps to go somewhere it starts me in that area not where I actually am not at.

    Do you think its the cellular issues I mentioned in first post that mess with gps location? (Currently tested with wifi and cellular data).



  • @that_rin
    in my case wifi and cellular are active (I have the impression that restarting did the main job...)
    if you got wifi access just give it a try without cellular data (?)



  • @obacht I have tried many combination cellular on/off, wifi on/off , and both same issue. Appear in same spot never exact location. It worked out of state tho when I was in Nevada.



  • @that_rin in system settings time and date check your timezone is correct (type in your home town/City) and set time and date is automatic.If I think if anything else I'll get back to you.



  • Have you tried upgrading your radio-firmware? I'm was running the N5 with the OTA3 15.04 RC image with unav for 6.000km in 2 weeks on european roads, it worked pretty well. Just twice the GPS refused to work, i had to reboot.
    With OTA5 RC I didn't test on the road, but it finds home in less than 1 minute (wifi).
    I extracted my radio firmware long ago from the last google-image.





  • @lakotaubp I have time settings set to atomatic it list a town thats about 12 minutes away from me as the time zone.

    As for the radio upgrade Yes I have done that already.

    Dont really know what else it could be because it just seems gps doesnt work anywhere In my home state it seems.



  • @that_rin just about the running out of ideas now one last one are you on the dev channel for updates. If not try that you can always go back afterwards, restart and see if that fixes it. Also try switching flight mode on and off.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.