[HowTo] [N5] Update baseband firmware


  • Infrastructure

    Motivation
    Baseband firmware has a lot to do with battery life. Since the battery life on the N5 is not the latest and greatest on the planet, small improvements could have an overall bonus effect.

    How

    1. Grab the latest factory image for the N5 from Google´s developer page: https://developers.google.com/android/images#hammerhead - currently that´s 6.0.1 (M4B30Z, Dec 2016)

    2. Open the archive and extract only the radio firmware, probably named like this:

    0_1513955196264_dfea01ef-48c3-4108-9b16-0a15e8c8cad2-grafik.png

    1. Connect the device to USB and bring it into fastboot mode by either using adb and adb reboot bootloader from console, or by pressing and holding Vol-Down button and then powering up the device. Verify you are connected with the device:
      0_1513955359755_aa7b7c4c-2b80-4f3a-8f4f-30639b074de1-grafik.png

    2. Flash the radio firmware by using this statement:
      0_1513955458954_ecd6a287-4750-4519-b6fa-376a4aff92cf-grafik.png

    3. Reboot your device and test if it was successful: Radio and internet should work, have 3G/4G etc. Observe battery drain over the next days. Also maybe this helps WiFi hotspot, who knows ;)

    BR Florian



  • Great post Flo! I know there are some people in the SG that are already testing with the radio firmware etc. It would be good to have a list with the recommended ones. Thank to everyone who is brave enough to mess with these stuff :)



  • Thank you!

    TIL: a phone's radio firmware is separate from its OS firmware.

    I have downloaded this, but my Nexus 5 already had Android 6.0.1 installed when I flashed Ubports. So, this radio firmware is possibly already installed on my phone.

    Is there any way with Ubuntu Touch (or some external software) to check which radio firmware is already installed?



  • @tupp, boot your phone to fastboot mode and look for "baseband" or open terminal and "cd /usr/share/ofono/scripts" and run "./list-modems". Look then line "Revision".



  • @hendrixxx
    Thank you!

    The only revision number that I could see (I could not scroll up in the terminal) matched the current one shown above for Android 6.0.1!

    By the way, can anyone recommend another Ubuntu Touch terminal emulator? It seems difficult to navigate the stock terminal (no arrow keys, and I can't figure out how to hide the keyboard).

    Thanks!



  • @tupp you can hide keyboard by swiping down. and you can get arrow by press and hold "keypad" button and select "SCR" then slide top panel to right and there you have arrow keys.



  • @HendriXXX
    Thanks for the terminal tips!

    However, I am still curious if anyone likes other terminal emulators for Ubuntu Touch.



  • @tupp no problems! Happy to help!

    Ps. You can scroll terminal screen up and down by swiping two fingers on screen.


  • Infrastructure

    @hendrixxx swiping down? never works for me :P



  • For anyone using the terminal quite often, it's easier to setup ssh on the phone. That way you can just run ssh phablet@<phone-ip> and use your desktop terminal.

    Anyway, this is my output: Revision = M8974A-2.0.50.2.30

    Looks like I should benefit of this firmware upgrade, correct?

    Sidenote, this was also in the ouput:
    Manufacturer = Fake Manufacturer
    Model = Fake Modem Model

    This is normal?



  • @flohack said in [HowTo] [N5] Update baseband firmware:

    @hendrixxx swiping down? never works for me :P

    Yes. When keyboard is visible put your finger on it and swipe down. Keyboard will go down (hide). Very useful IMO.. I use that all the time. ☺



  • @randomuser said in [HowTo] [N5] Update baseband firmware:
    Anyway, this is my output: Revision = M8974A-2.0.50.2.30
    Looks like I should benefit of this firmware upgrade, correct?

    Probably, there is no need to upgrade, as you seem to already have the most recent version (see image in OP showing file "radio-hammerhead-m8974A-2.0.50.2.30.img") installed.


  • Infrastructure

    @tupp Yeah there is no younger one on Android pages right now ;) I took the latest...



  • @hendrixxx said in [HowTo] [N5] Update baseband firmware:
    @tupp you can hide keyboard by swiping down. and you can get arrow by press and hold "keypad" button and select "SCR" then slide top panel to right and there you have arrow keys.

    Good to know! Thanks!



  • I checked and I had radio-hammerhead-m8974a-2.0.50.2.29, so I updated to 30 following the @Flohack instructions.

    Everything seems to work as expected but the WIFI hotspot is still not working. It starts OK, but the wifi signal is not seen by nearby devices. Then when it is turned off, wifi does not work any more in the Nexus 5. A reboot is needed to get it back.

    I will report on battery life if I see any change.



  • @Flohack Thank you for help. UBports rocks.



  • After some days of usage, I can't see any improvements in battery life with the 30 version. Maybe the 29 version which was the one I had is not so different.



  • I have been using latest baseband over week now. Battery now lasts maybe 30% longer in my case. Much better thing is that there are no network dropouts anymore. Before a had few locations where it was almost impossible to use mobiledata, but now also those locations works very well.

    I did some testing with powerstat. "3g ON" it almost doubles consumption.

    Wifi on:
    https://paste.ubuntu.com/26277621/

    3g on:
    https://paste.ubuntu.com/26277635/

    I also tried to check system wakelocks but N5 kernel doesn't have "/proc/timer_stats" support. It needs "CONFIG_TIMER_STATS=y" option compiled in the kernel. N4 has it already but N5 doesn't. I want to use "eventstat" to examine wakelocks but it wont work without it..



  • @flohack Thanks for a very nice and simple instruction.

    I have a problem with the mobile connection after installing r3, and i hoped that doing this could solve the problem. Unfortunately it didn't. The problem is that mobile data connection does not work anymore after upgrading to r3. The "4G" icon comes up when enabling mobile data, but the internet connection does not work and there is only the loopback interface in ifconfig.

    Do you (or anyone else here, of course) have any solution for this or any suggestions on how to debug it?



  • @hans1977se If your not on the development channel swop to that in update settings, update the phone and see what happens. That has fixed a few issues before. You can then swop back to whatever channel you want.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.