Nexus 5 - keep losing WiFi since OTA 5 update.



  • Since last update, my WiFi connection gets lost in unpredictable intervals. Sometimes I can recover my WiFi by toggling the network slider off and on. In battery settings WiFi is enabled. When the connection goes down it is impossible to switch to System Settings. Sometimes it needs a restart to get my WiFi settings back.

    Does anyone have similar problems? I read about something that sounds like it could be my problem, but that was in 15.04.

    Any help is appreciated.



  • Hi,
    I have had constant problems with wifi, with both Nexus 5 and OPO. To me it started before OTA5 though.
    Sorry I am not able to provide a solution, but it could help if we had the same problem. A good test for me, to check:

    1. if wifi works after boot, get something streaming from the internet. I use one of the internet radio apps - radio starts to play
    2. then get to the web browser and browse until the pages stop loading (to me, after 4 or 5 pages...).
    3. in my case, despite the fact that web pages stop loading, the radio keeps playing OK... which means that wifi is working, but new connections cannot be established.
    4. if I go into terminal and ping my router (192.168.0.1 for me), it works. In some cases, just sending pings to my router is enough to reinstate the loading of web pages (but not always!).
      Doesn't make much sense to me...
      Also, this problem does not appear with all routers. I live in the UK and it seems like UBports doesn't like routers from SKY (I tried in two different houses). But at the office wifi never drops out.
      I can't see anything obvious from the logs but it's hard to interpret...


  • My pro5 is doing this also, I have an ext SD,with keeps getting remounted as a result.
    this has happened a while back but was fixed.



  • @truscellino, i tried your suggestion with the radio playing. The radio stopped playing after a while and all routers in my vicinity have disappeared from the list. WiFi returned after toggling the off/on slider. I havent also tried to ping my router. "Network unreachable". I am open for more suggestions. It could of course be a hardware problem, but I haven't observed it with an earlier release.

    Thank you for your support. Perhaps there will be a fix in a newer version.



  • @marathon2422 , so I will wait for a future release. Hope dies last.



  • OK so your problem is slightly different to mine... but overall I would say that wifi is not robust on UBports.
    I remember that the Ubuntu 16.04 desktop also had problems in the early days, sometimes with kernel drivers (Realtek particularly) but sometimes also with IPv6 libraries messing up the connection.
    Does your problem appear with all routers?



  • @truscellino, yes all routers that are near by disappear upon losing WiFi. It's just like I had disabled WiFi with the slider in the settings menu, or even like a hardware failure. It's quite mysterious.



  • @marlboro50
    I would like to add that, I have since, operated the device with the sdcard. and sim out of the device,and the wifi stays connected no problem.
    so it seems like the sim and wifi are arguing with each other, I can turn the data off with the sim installed and it keeps losing wifi, but remove the sim card,and all is well



  • @marathon2422 , thank you. i will give your suggestion a try.



  • My Nexus 5 keeps loosing WiFi often - how often I don't know since I have it on my desk at home without a SIM to play around with. When WiFi is lost, the phone wants me to enter the password to my access point. Most of the time, toggle WiFi on/off makes WiFi work again - without entering my password again. If I do as the phone suggest, enter my password again, I usually have to restart the phone to get WiFi working.
    Since this phone is a preowned one (with a cracked, but functional screen) and I've never tried Android on it, it might be hardware specific to this unit. So maybe completely unrelated to this topic.



  • @marlboro50, thank you for your advice, unfortunately my connection broke after less than 5 minutes.



  • Then all that can really be suggested is to check the github bug reports and see if one exists. If so add to or confirm it, if not create one and others can then help by confirming it or not. Bug reports mean things are logged and fixed.
    Please just make sure that one doesn't already exist.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.