Ubuntu Touch Programming Course



  • I comment you the state of the chapter:

    • The source code is now complete. You can check it at GitHub
    • The calculator after the end of the chapter has the following appearance
      0_1498934608590_05_button_size.png

    I have to review the text and edit the chapter. I'll let you know when I have it published. I do not know if it will give me time to finish it this weekend.

    PD: I have published the source code that generates the book. It is also in GitHub (Book)



  • Good evening.

    I have already published the next course chapter:

    • Organizing components
    • The Row Layout
    • Grid Layout
    • The Button
    • Color Settings
    • Changing the Button Size

    You can read it on the course website



  • Very nice, thank you!

    While scanning through it, I see lot's of replicated code in the last example with the Buttons. Isn't there a way to make something like a CalcButton, which has all the common properties (sizes, color) and can be reused. I don't actually know what the syntax for this is (guess why I'm interested in a UT programming course :-P ), but I expect that this is possible and would be a nice rounding up of the chapter.



  • Hi @doniks,

    You're right, but the code may still get worse. In a calculator there are buttons that have two or three functions. So far you have seen the buttons of the basic calculator but there is also a scientific calculator.

    In one of the future chapters (it is written in Spanish and I have not yet translated it), a custom component is created that contains the button and the extra functions. You can see an example between the current design and the future.

    Design comparative

    Both versions use QML. Just change the design. If you have any questions related to the chapters that are published do not hesitate to ask.



  • Great that you write this tutorial for us :-)

    I have follow the instructions to install the SDK.
    So far so good.
    but i can not install the developer kitś.
    I get every time the following error message:

    Creating image with: framework: ubuntu-sdk-15.04 arch: amd64
    error: No storage pool found. Please create a new storage pool.
    ---Task exited with errors, please check the output---

    Why it can not find the pool? Have I forgot something?
    System is up to date.
    Ubuntu SDK IDE is installed.
    PPA is added.
    Iḿ in the usergroup lxd.
    PC is restarted



  • @TischlerWilly said in Ubuntu Touch Programming Course:

    error: No storage pool found. Please create a new storage pool

    What version of Ubuntu are you using?



  • Linux Mint 18 Cinnamon 64-bit

    Have I to use the Ubuntu Gnome Desktop?



  • @TischlerWilly,

    It may be a particular Linux Mint bug. This weekend I can create a virtual machine and check if I can replicate the bug. The course I'm programming in Ubuntu 16.04 with the Mate desktop (although it should work with any desktop).



  • Hi guys.

    At the end of the week I'll be uploading the resources I used at Ubucon Paris 2017. The virtual machine uses Ubuntu Mate 16.04 and has the SDK ready to work. Just download the file, configure VirtualBox and start programming applications.

    The link to the presentation is temporary, when I publish it I will update the link.
    https://drive.google.com/open?id=0B1tk1v5ejGZzY2VKWWh0cWhHTVk

    I hope at the end of the month to upload the translations of several course sessions. My intention is to match the Spanish and English versions before continuing with the new content.



  • Good afternoon.

    You can now download the resources I used in the UbuconParis 2017 workshop. The virtual machine has the following features:

    • Ubuntu 16.04 with the Mate desktop.
    • SDK already configured with IDE icon on the desktop.
    • The workshop exercises are saved in the User Folder.

    The credentials are:

    • User: ubucon
    • Password: ubucon

    Links are public. I would ask you to download the resources using the short link because that way I can have some statistics.

    It is possible, in the future, to add new elements to the virtual machine. It all depends on the suggestions you make. If you have any problems with the file you can indicate it in this thread.

    I hope to publish new translations of the course next week. When the English and Spanish versions are ready, I will create new content.for both.



  • Great. Thank you. I am nota developer but afiu now we are able to use the SDK again. I will give it a try anyway.



  • @mimecar
    Hi,

    It seems that the link to the VirtualBox VM is down...
    Could you provide it again?
    Thanks
    W.



  • Hi @wilfridd. I've fixed the link, check again.



  • @mimecar
    That's ok! Many thanks



  • Thank You. Works great!



  • Is it possible to run an „only“ C++ projekt with qt and on the device? I need, for example, the QNetworkAccessManager, its only in c++. If I try to compile it, it says „no executable found“... Thanks for help.



  • If it is a C++ project that needs external libraries, you have to add them to the project configuration. Did you do it? Is the application running well on your PC?



  • @mimecar Hello, thank you for helping. Im not sure. There are 3 modes: 1. Desktop: it works fine 2. UbuntuSDK for Desktop, it does not work, whants me to give him the executable „please specify one“ the 3. UbuntuSDK for device, I didn‘t tried yet. How do I give him the right libs? And where? Is there a documentation? I don‘t know exactly what I should search for to get the specific instruction... My experiences are only with visual-studio... and not cross anything :0) But I would like to get through this...



  • Hi, @Tewel,

    So far I have only worked with QML and JavaScript. If you send me the project you want to compile (with the minimum code the library uses), I'll check it over the weekend.



  • @mimecar Thank you, thats a nice offer! You led me to a thing I whant to try first „Integration of qlm and c++“ there is a documentation. In the web are some hints that its nessesary to do this first, if you whant to use c++ with qml and ubuntu. But there was no time until now to figure it out. I will tell if its the solution....


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.