How to install UBports 16.04 on BQ E4.5 with limited storage?



  • It I try to install UBports with the installer, I get an error, because of not enogh storage. The phone has 4.5 of 6.9 GB free storage.

    Is are mote installation possible or could an SDcard solve the problem?



  • @marc_aurel hi, can you paste here the exact error message? fwiw I have xenial running in my krillin without any issue.



  • I have made some screenshots.

    If I start the UBports installer, I get the message, that the installer is not up to date:

    (Unfortunately the image syntax does not work in this forum. I add the links instead)

    First screenshot

    I have installed the app with snap and snap tells me, that the app is up to date:

    Second screenshot

    First steps of the system updates work properly:

    This screenshot

    Fourth screenshot

    Then the error occurs. It’s not enough disc space, But the device has just the pure old Ubuntu touch installation:

    Sixth screenshot

    Seventh screenshot



  • Have you enabled the wipe option in the ubports-installer? It might solve your problem.
    This will remove everything on the phone - including personal files.



  • I don't think enabling wipe will help. This error is thrown when the /cache partition is not big enough (or empty enough) for the whole tar file to be downloaded to it.

    You would either need to try to empty the /cache partition before trying to flash again, or you would need to increase the size of the /cache partition.

    I wonder though, how come we have not had anyone else with this issue.

    I still have an E4.5 with OTA-3 on it. I might try to flash OTA-5 on it to see what issues I encounter.



  • @marc_aurel you need to run fastboot erase cache before starting the installation.

    See https://github.com/ubports/ubports-installer/issues/6



  • Thanks for your help. The last suggestion did help to run the installation script without the storage space error. UBports installer shows a successful installation:

    installer screenshot

    Unfortunately the device remains stuck in recovery mode. I could validate this with adb get-state.

    device photo

    If I reboot with adb reboot, the old system 14.10 is booting. Some ideas?



  • @marc_aurel if you get stuck in the recovery screen more time than the "normal", you can unplug and plug the phone (it seems that sometimes adb and fastboot keep fighting for the usb port control)



  • @advocatux Thanks for your response. I tried the installation again:

    The UBport installer shows the „success“ message, but the device keeps in the recovery mode. I can access the device with adb.

    I seems, that the files are copied to the device, but the installation process hasn’t started.



  • @marc_aurel how long is it stuck in the recovery screen? If it's too long, say more than 3 or 4 minutes, you can try to reboot the phone pressing and holding the power button until it reboots.

    I used that method successfully with my Nexus 5 a couple of times already :)



  • I have waited for half an hour, then I tried to reboot. The device doesn’T respond to the power button. I have to use adb reboot. But then the old system starts.



  • Some more suggestions? The UBports Installer completes with a success message, but the new UBports version isn’t installed. Is there a different approach for installation, maybe with fastboot within terminal?



  • Finally I could manage to update the phone.

    The update failed with macOS Mojave and my Windows 10 VM. Both systems seem to have driver problem although I'm able to flash phones with macOS Terminal commands. The update with my Linux VM failed either as I reported. Howsoever after I managed to clean the cache in the recovery mode on my phone, the process with Linux was successful. A assume, there is also driver or USB controller issue with MacBook Pro.

    Thanks for your support. Sometimes one need to try it again and again and aigain.



  • @marc_aurel you're welcome. The usual issue with MacOS & the installer is that the necessary tools (adb & fastboot) are not in the user's $PATH and the user needs to fix that :)



  • @advocatux Thanks. I’ve installed the full Android SDK on my MacBook for App development. Is this a conflict?



  • @marc_aurel maybe the whole Android SDK is a little bit over the top but it shouldn't be a problem.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.