How to enable the desktop mode for the convergence use case?



  • I followed the instruction of the documentation. I have connected my MacBook with adb shell to my Fairphone 2 with the recent UBports release:

    phablet@ubuntu-phablet:~$ libertine-container-manager create -i linux-desktop
    I: Retrieving InRelease 
    I: Failed to retrieve InRelease
    I: Retrieving Release 
    E: Failed getting release file http://ports.ubuntu.com/ubuntu-ports/dists/xenial/Release
    ChrootContainer.py:78: ERROR: create_libertine_container():	Failed to create container
    libertine-container-manager:123: ERROR: create():	Failed to create container: 'destroy_libertine_container() missing 1 required positional argument: 'force''
    

    Unfortunately this doesn't work. Has someone an idea?



  • Desktop mode can be enabled from the System indicator in tablets or, on most devices, by UT Tool Tweak app tapping on Use Mode.



  • I would like to install and run desktop apps for the covergence use case, if I connect a large screen and kayboard. I think this is a different requirement than showing widowed apps.



  • @marc_aurel said in How to enable the desktop mode for the convergence use case?:

    I would like to install and run desktop apps for the covergence use case, if I connect a large screen and kayboard. I think this is a different requirement than showing widowed apps.

    Oh, ok. We have a confusing nomenclature here :)

    Convergence means that the system on the phone will act like a desktop, with windows (ergo, desktop mode versus stage mode that is to have one app running at the time).

    What you are trying to achieve is to use x11 apps in the device (and has little relation to convergence). That's handled by Libertine. It's experimental and you have to expect bugs and that not all desktop programs will run.
    You can go to System Settings > Libertine and add a container, then look for the package name and wait.

    Have in mind that it will take a lot of time and a lot of space in your device. And probably they will not scale correctly :D
    I have installed successfully Gargoyle and gPodder (even I had to delete them as I run out of space :)



  • Thanks for your reply. I tried to activate Libertine. Unfortunately I just see the spinner after my Faiphone was running the whole night and half of the following day.

    Screenshot

    Some ideas?

    The phone has 24 GB free storage. That should be enough, shoudn't it?



  • @marc_aurel Put the lock when idle setting in battery settings to never and try it again.
    When its starting and circle is spinning, tap on the container name then the cog wheel top right to watch progress.



  • @marc_aurel yes, follow @Lakotaubp instructions and you'll see the installation output.

    Another tip: you don't need to link to a screenshot on an external server, you can insert that image on your post. Just drag the image from your computer and drop it in the compose box ;)



  • Thanks for your suggestions:

    Unfortunately I don't understand this sentence:

    "Put the lock when idle setting in battery settings to never and try it again."

    Do you mean, that I would switch off the automized process to lock my phone after a selected time frame?

    If I tap on the spinner, then on the gear in upper right corner, then on the button "container informatiob". Afterwards I can see the installation process.

    It seems that the installation process in paused, if the device is locked with a black screen.



  • @marc_aurel Yes, stop the screen from locking. System settings, battery, lock screen when idle = never



  • It seems, that the container is installed, but I can't install the Desktop Apps Scope like decsibed in the UBports documentation:

    0_1542474907003_20181117_180453.jpg



  • @marc_aurel you don't need to it's already there. Go to apps scope, Pull up on little white inverted v/arrow and it's there.



  • Perfekt. I found thus scope. Thanks very much for your help. Now I have to find a way to install a desktop app.

    Is this only posiible by pushing an rpm file, say from OpenOffice, to the phone with adb and then triggering the installation within the adb shell?

    libertine-container-manager install-package -p PACKAGE-NAME
    

    I realized, that I can't download rpm files from the browser. I get an error message from Sourceforge for downloading OpenOffice.



  • You cannot install rpm packages really. You can also only install packages which are built for the armhf architecture. If you want to install LibreOffice for example, you would use libertine-container-manager install-package -p libreoffice or you can use the GUI in System Settings to install any package in the Ubuntu 16.04 archive for armhf.



  • Thanks so much. This is fascinarting easy. Unfortunately my phone crashed and restarted during the installation pricess. Now the spinner doesn't stop since last evening and no log is shown any more, if I tab on the row with the spinner and select "view". Some idea to stop the process and retry the installation? I think something was installed, but it seems incomplete. This, I may need to clean up the broken installation.



  • Hmm. I'm not sure if there's any way to resolve such an issue via the GUI (and I'm not quite sure what the issue is there anyway, beyond the crash during an install as you stated). It seems though you have found a bug in the libertine GUI. I'd suggest first to open an issue at https://github.com/ubports/libertine about it, with perhaps a few screenshots of the broken UI, and also any relevant logs, such as from the System Settings log, and perhaps there may be some libertine specific logs elsewhere too.



  • I destroyed the container with adb shell:

    libertine-container-manager destroy -i xenial

    Unfortunately re-installing the container failed. See the creenshot:

    0_1543055405694_20181121_121753.jpg

    I tried to remove some documented filed manually via adb shell:

    rm -r ~/.cache/libertine-container/xenial
    rm -r ~/.local/share/libertine-container/user-data/
    

    I could reinstall the container, but my Fairphone restarts while installation and shows an infinite spinner afterwards next to the container in the settings. Does someone know the location of the installation log? I could link it here in the forum to clarify the issue.

    Then I just tried to install LibreOffice as described in this thread with the user interface of the conainer onmy phone. The spinner disappeared and I can see some apps in the app scope now. I will check, whether and how they work.



  • @marc_aurel For future info I've always found that setting the screen sleep feature in Battery Settings to never while installing containers helps.



  • I was happy too early. UBports has installed something, but not correct.

    0_1543071738283_20181124_155838.jpg

    This is shown, if I open one of the apps.

    0_1543071750255_20181124_155828.jpg

    Then another scope was opened with an error message:

    0_1543071819479_20181124_155808.jpg

    I try to destroy the container and re-install everything. I would like to show a business partner the convergence use case next week. So I need to make this feature running.



  • It seems, that UBports is a diva ;-) It seems, that the installation has been successfull, after I hold my FP2 in the hand and watched "her" installing.

    0_1543074407140_20181124_164233.jpg


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.