Is it possible to flash from TWRP (with .zip file)?



  • Hello all,

    I own a OPO (bacon) device, which has been gathering dust, and I wanted to install ubuports, but the device is not in it's best shape, no matter how much I try it doesn't seem to "keep" the RSA key of my computer, so when I get into Fastboot Mode (bootloader) nothing happens, the installer just keeps spinning endlessly. I tried via the fastboot command (platform-tools) and I get the permissions error (regardless of me having accepted the computer already).

    So long story short: I can't use the provided installer, is there a way I can get my hands on a .zip file which I can flash through the TWRP Recovery?

    Thanks in advance,

    minkiu.



  • no. Ubuntu Touch is not a single zip file you can flash from TWRP.
    you can join the telegram group @WelcomePlus to get help about the installer if you haven't done it yet...



  • @minkiu if you have Ubuntu 16.04 in PC, you can install phablet-tools and ubuntu-device-flash
    Then you can easily install without Ubports installer.
    If you have Ubuntu 18.04, then this is no compatible, but, you can create Usb startup disk with 16.04 Ubuntu on it, reboot the PC with F12, boot the Usb stick you previously created as a startup disk and install phablet-tools and ubuntu-device-flash and then flash it with Terminal. Search the forum how.



  • Over the last couple of weeks I noticed several people asking for an alternative way to install UT.

    If not via TWRP + ZIP file, wouldn't it be possible to install manually with fastboot and adb (that's what the installer does anyway)?



  • Indeed you can unzip/install it manually from TWRP. Maybe @mateo_salta wants do describe that(?).

    I think ubuntu-device-flash mentioned by @Stefano does not involve fastboot either, if you however managed to flash Ubuntu touch recovery before.



  • Hi,

    Thanks all for the replies, trying to answer them all:
    I'm on Fedora and I know I can do a VM or Live Boot a USB, but I believe my problem is on the actual phone.

    While I managed to get adb working, once it boots into fastboot it just won't detect it, I don't know if it's the OS, the micro USB port or (the multiple) cables I tried, but can't do this through the normal PC - > Phone procedure,

    thus my question about the zip file.

    Thanks,

    minkiu.



  • @minkiu
    you may get lucky someone with the same device,may have a twrp backup they could share ( OTA does not work with twrp, reflash stock recovery to fix)



  • @minkiu said in Is it possible to flash from TWRP (with .zip file)?:

    While I managed to get adb working, once it boots into fastboot it just won't detect it

    I had something similar on opensuse with the AppImage installer (would affect deb as well AFAIK). And the cause there was that I had adb and fastboot in /usr/local/bin. But when run with sudo (explicitly starting the installer with sudo or letting the installer use sudo internally), /usr/local/bin is not in the $PATH. And the command to detect if the phone is in fastboot mode ignores the custom paths you can specify so that doesn't help either.

    So it might be worth a try to either place/softlink adb and fastboot in /usr/bin or adjust your system-wide sudo config to also include /usr/local/bin (or wherever you have installed adb/fastboot).


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.