Camera save problem: "Capture failed: Restarting your device might fix the problem." on PRO 5 with UBports OS Image Part 2018-12-08-31252



  • Hey there. Until a recent build of UBports 16.04 LTS, the camera was working beautifully on this MEIZU PRO 5 here, taking and saving pictures. In recent builds, including this current UBports OS Image Part 2018-12-08-31252, the camera application opens and displays live images as normal, but on taking a picture it displays the following error message:

    Capture failed
    Restarting your device might fix the problem.
    

    This is the case for all of taking front-facing or back-facing photographs or videos. I've tried the obvious of restarting without success. Can anyone guess at what might be wrong or how this might be fixed? I'd appreciate any guesses or tips.

    In case it is somehow related, I have been running Antox with success and this has also broken recently (wherein it just crashes on launch).

    Otherwise things seem to be working well and I commend the hard efforts of the developers.



  • @blandcorporation I have no knowledge of the pro 5 and not seen this before. But, one thing you could try if your not on the dev channel is update to that first and see if that helps. Dev will give you the latest updates for your device just incase it has been fixed already.
    If you are already or it doesn't we will need help from someone else.



  • I have the same problem on my BQ E4.5.

    Making videos works fine but when making photos it tells me

    Capture failed
    Restarting your device might fix the problem.
    

    A few weeks ago it was the other way round - photo worked but video not.
    I use the dev channel with latest update.
    Anyone knows how to fix?

    Thanks.



  • @ah12 hi, anything relevant in the camera log?


Log in to reply