Fairphone 2 cant get detected in fastbootmode

  • Hello everyone,
    in normal(android 1.13.0) mode, Device getting detected with number
    @Fastmode only a clear list (adb)...

    • i have win 7 64bit, bitdefender
    • downloaded allmost every driver and tested (kush and sdk latest driver)
    • activated the usb debugg mode and authorised it
    • used both installer win and linux 16.04

    no device found, thx for help

  • Community

    I never tried using fastboot on Windows, so i'm not an expert, but you could try to use a different USB cable and also different USB outlets on your computer. You say your device is reachable over adb? Then you're probably in recovery mode (Power + voulume up), for fastboot (bootloader mode) you need to press power + volume down. It takes a while for the phone to boot into fastboot mode and the FP2 does not tell you when it's ready. In the linux command line, you can just type sudo fastboot devices to list the attached devices if you want to check if the device is reachable, not sure about the process on Windows.

    If you have a Linux machine nearby, try using that. If not and you can't resolve your issue, ask at https://forum.fairphone.com/ for Fairphone-specific issues.

    Are you trying to install Ubuntu Touch? Then i recommend using MDT (Only available on Linux atm iirc).

    Good luck!

  • yes i tried to install cpt installer and magic device tool to install ubuntu touch.
    i installed linux about virtual box, but the program ends at the same point.
    Have 3 different usb cable, 3 different usb slots, all the same.
    @linux i get nothing after typing fastboot devices same like adb
    I started the phone with volume -(down) and power button.
    I have only a little lubuntu pc nearby...
    strange thing is that the phone doesnt work only at fastbootmode,
    its normaly connected at the systemproperties
    its a brand new fairphone 2 slim, hope they didnt chance something on softwarebase
    thx for respond

  • Community

    Weird, I'm out of ideas. I suggest asking over at https://forum.fairphone.com/ or opening a support ticket here: https://support.fairphone.com/hc/en-us

  • Community


    If you have any spare computer laying around to run Linux, I'd really recommend that. Linux inside of Virtualbox won't work correctly for flashing your phone.

    On that computer, try typing dmesg -w before you plug in your phone in Fastboot mode. Let us know what comes up when you do that.

    Also, you need to run adb, fastboot, and mdt with sudo.

  • @UniSuperBox said in Fairphone 2 cant get detected in fastbootmode:

    Also, you need to run adb, fastboot, and mdt with sudo.

    Sudo is key. You need to be root. So try

    sudo adb devices

    Or if you want General root access:

    sudo su

    Than after typing your password you can follow up without sudo.

Log in to reply

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.