Im not tech savvy

  • First off let me apologize if this is not the place for posting this. Ive never used a forum before. Also im not a dev or even tech savvy (im a welder) just a privacy conscious guy trying to deGoogle his life. I have recently switched to Ubuntu from windows and I am loving it. So happy that there are people out there creating alternatives and i do try to donate and buy devs coffee whenever i can afford to. so my question is this, I installed ubuntu touch OTA 6 on my nexus 5 using UBPorts snap. Everything works and looks great except i cant make phone calls. My carrier is Cricket Mobile(ATnT) . I looked at the APN settings in the UBtouch GUI and there is no setting for MCC/MNC. I tried to enter them manually using adb shell but i dont know how. Like i said im a noob to command lines. I would really like to use this as my daily driver as i really like and appreciate the work you beautiful people have done. Any thoughts or help would be greatly appreciated. Thanks

  • Hi, and welcome!

    Usually the carrier should be picked up by the OS. Sometimes it takes a while for it to find the right network and signal. I don't think you have to do any settings changes manually.

    If you haven't already given it a bit of time or a reboot with the SIM in the device, then give that a shot. Hopefully someone else has more insight.

  • @joe Hey thanks for the fast reply! You guys really aren't that bad I dont believe all that terrible stuff they say about you guys(Microsft). Just kidding. So if I could be more specific the OS is picking up the carrier, it shows Cricket under carrier settings and everything else seems to be working. Text cellular data and internet browser all work even without wifi. Only thing thats not working is calls. I used adb shell to inspect the APN context and there dpesnt seem to be a setting there for country code(MCC). Not sure what to do I even called Cricket and had them reset my tower connection to no avail. Not sure what to do

  • (^_^')
    That is indeed a bit strange.

    I guess Cricket Wireless needs some manual settings (

    I'm not familiar with it, so I can't say too much. Unlikely that it's different in newer versions of the OS, but you could try reslashing the device on the RC or devel channel if you are currently on stable.

    Hopefully someone else knows something about manual settings.
    You could try asking here too

  • @joe Maybe i should clarify about me being "tech noob" as i put it. So im 35 and im a gamer meaning i learn quickly and am interested in tech just never learned any of the technical side of things and i dont code or truly understand IT. That being said, I follwed this guys thread( who seemed to have the opposite problem meaning with his carrier he had calls and texts but no wireless internet. By following his thread I was able to learn how to adb shell and inspect the internet context0_1546838692964_Screenshot-20190106211932-1366x768.png I dont see anything in there about Mobile Country Code or MNC Mobile Carrier Network. Perhaps I am overlooking something? I really hope it is something simple Im overlooking. Anyhow I dont think its related to the version as i did try flashing Dev version 15 and Dev 16 and had the same issue, everything worked except calling. Been researching this issue for a week now but dont really know where to look. Any ideas? Im currently Using OTA-6 Stable version

  • @jack_mawang Firstly welcome to UBports you may find this useful On to the next issue try reading this thread as it may well help. I think this is mentioned in that thread but sometime updating to the development channel in System settings, updates, update settings (bottom of the page) then ch.oosing dev and installing the update works.good luck and you can always pop back whenever you need
    Edit: I see you tried the dev channel thing already. Missed that bit earlier : ( still half asleep my nexus has a dev version of 758 showing in update settings. I think yours is a missing apn setting issue. However OTA-7 is due tomorrow which may help also please double check you have 16.04 installed (Settings, About, OS) just to rule out anything else.

  • @lakotaubp Hey thanks for the reply! You guys are so awesome. I took Joes advice and got desktop telegram and I love it. I joined the ubuntu welcome and instalation conversation on there and reposted my original messge. But telegram is so cool Im going to put it on my android phone until i get ubtouch working. Everything you Linux guys make is so cool from telegram to bitwarden to audacity(im a musician) to the new ubuntu i love it all. Forget buying devs a coffee, I want to buy all you guys a beer and hangout with you guys! On the topic tho, I will def read through all the material and code of conduct and join the telegram focus link yousent and the other thread when i have time tomorow, Im unemployed temporarily so I will have time . Thanks. Oh who am I kidding I cant stop Linux-ing lol. I want to learn how to code now.:) anyway I just read your edit and yes I agree I think its a missing APN setting . I do have 16.04 installed on Stable but I may try the Dev version again. I will def update to OTA-7 tomorow when it comes out. Also I started to read throgh the linked thread you sent and I think youre on to something in there about the baseband firmware not being updated. I just learned about firmware two days ago (been burying myself in Linux tech forums ever since I decided to deGoogle) . Anyway when I bought the Nexus 5 It kept updating through Android updates one at a time. It started at 4 I think(Nougat?) and updated through several versions of Android 5 and then a couple 6s. I stopped the updates in 6 (Marshmallow) somewhere because I was impatient and also a bit paranoid of Googles firmware so thats when I installed OTA-6 Stable with the Snap whiched worked great, very user friendly. Im still amazed with the userfriendly-ness of open source apps. Anyway its possible that I shoud have let Android continue to update and by stopping it short I missed out on an important firmware update. I will look onto it more through the thread that you posted and continue to research. Im determined to get this working haha. At least until the Librem-5 comes out. Fingers crossed for Purism wish i ha the 350$ to pre-order right now so I could help more with the Librem project. I fully believe that all this privacy stuff is going to come to a head soon in this country. Many people have become complacent with the technology and allowed these big tech companies to gain an unprecedented influence over their lives. Anyways I dont want to get on a rant so Ill just say thanks for the great(and important) work you guys do and I will def read through the material. 🙂

  • @jack_mawang No problem. Glad your enjoying UBports so far and lets get this fixed. The community here is what makes it special. I have found there is always someone who can help and most importantly willing to help. Like you I am no techy and whatever I now know about Ubuntu Touch (which is still not alot) has been from what someone else has been willing to pass on.

  • So Im still awake 😛 Why? Coffee . Thats why. Anyway in between coffee and Pandora and coffee Peter Jacksons Tolkien adaptations and Human Resource machine and coffee (I think Im going to fit in here) I read through some more threads and checked the radio firmware in my Nexus 5 0_1546856073886_Screenshot-20190107013738-734x496.png
    It matches the latest version of the radio firmware on Googles dev page. Just fyi. Ill keep on looking ; )

  • Update, the kind folks in the Telegram group figured out that my calls are going thru because the call timer is on the each time. I just dont have audio for calls so I mistakenly thought the calls were being dropped

  • You're making progress, @jack_mawang - keep at it!

  • update, i was mistakenly mistaken. Call timer never starts

  • But my Keurig Does! + Baldurs Gate!

  • Soooo now im downloading the factory image im gonna try and flash it back to android and see if calls work

  • @jack_mawang hi, just in case you don't know it: if you click on those 3 dots on the right hand side of your posts, you can edit them (among other options) 😉