Help testing new legacy image

    I just flashed my BQ E4.5 about 5 minutes ago and it works fine.
    But be aware, all your data and contacts will be deleted, it's like a brand new phone from the factory.

    I just downloaded the image, where the link to that image is on this site:

    I set the phone to developer mode and connect it via USB to my computer.

    Then I enter in the Terminal:
    adb reboot-bootloader
    This takes some time, until the phone was in fastboot mode.
    On the phone was ablack screen, where at the bottom is a very tinny like written "fastboot"
    cd Downloads # where I stored the downloaded image
    sudo ubuntu-device-flash --server= touch --channel=ubports-touch/legacy --bootstrap --recovery-image=./recovery-krillin.img

    After 3 minutes I can see in the terminal:
    2017/05/15 16:53:16 Rebooting into recovery to flash

    Then the phone reboots, which took some other minutes.
    After it was initialized, you can see the phone booting and the ubports logo.
    Phone is up and running.. 🙂

  • @WLBI Thank You!

  • I tested a little bit the mx4.

    • WiFi: OK
    • Camera: OK
    • Flashlight: OK
    • BT connection to Ubuntu Desktop: OK
    • lockscreen notifications: OK
    • phone crashes when App is allowed to use a device for the first time:
      • utorch: Phone crash when allowing access to camera service for the first time (worked after boot)
      • unav: phone crash when allowing access to navigation data for the first time (worked after boot)

    Not tested: Phonecalls/SMS as the phone does not recognize SIM anymore (hardware defect)

  • @sk Didn't crash for me, but I had this issue when I was using CM13 and Ubuntu dualboot on my phone.

  • @zubozrout said in Help testing new legacy image:

    @sk Didn't crash for me, but I had this issue when I was using CM13 and Ubuntu dualboot on my phone.

    How did you managed dualboot? I would love to dualboot my fairphone 2 with FP OSOS and UT. Than i could help testing whithout being lost in business access.
    I looked into EFIdroid a little bit which seems promising at least for someone with Mord development skills as I have.

  • Joining in (fairly) late ...
    I own a M10 FHD, I'm willing to switch to UBports and help with bug reporting and such. However I feel like I need a more detailed flashing guide ( something dumb proof ...) or at least some link with information about the procedure and requirements.
    I truly appreciate your effort, keep the ball rolling!

  • I migrated bq e4.5
    to ubports channels,but the location does not work,missing the scopes own bq.Any solution?
    I have reflashed two times and still the same.

  • I would love to test UBports on M10 FHD, but as I see it: "Status: Update fails, tested", I'm not that eager to test it. I presume that at the moment there are some issues to install it on the tablet. Am I right? If that is the case, then I will wait for the image that will work/install and test it then.

  • @mariogrip since the M10 and Meizu devices are currently not in core, legacy or development in the device list how should you see them.
    And back to another question where can you read some release note ex which feature / bugs that been fixed?


  • Besides being a happy monthly patron and funding device supporter of the FP2 I would like very much help testing the legacy image.
    Due to business requirements I am not able to switch fully to UT for the time being and flashing/backing up/restoring vice versa is too inconvenient for me. If a multi boot option would be available I would be able to switch as often as possible to UT.

    Furthermore I think, that providing multi boot options would gain more users anyway. In 2007, when switching to ubuntu on my desktop it helped a lot to have my Windows OS as backup in the first weeks.
    I know that it is to early to talk about apps because you guys have to generate the stable core framework first, but I think in terms of stability it is good to have as much devices running UT as possible as soon as possible.

    I am not a developer, but I am a very experienced user. So I would be able to help a little if one developer who at least is able to give a little love to e.g. this approach will accompany .

  • Hey,
    I've flushed my Meizu PRO 5 and it works great except fingerprint unlocking everything that worked before the flush works now after flushing the new image.
    It also seems a lot faster taking ~1 second o open an App instead of the loooong 5-10 seconds it was before.

    Also i really like the new scope design 🙂

  • @darkeye is fingerprint security working on Ubport image?

  • @zsoltmd Sorry forgot about that fingerprint doesn't work i`ll update my post.
    (I wasn't using it too much as it's not that reliable on my device)

  • @darkeye , thanks for info! Hmmm...., this fact means for me that Ubports image is not same as original, stable release...
    What is the reason? Fingerprint driver is not open source? Had been mirrored from not stable image - I mean rc-proposed or something...?

  • BQ 4.5 flashed yesterday, it is my daily companion, so I will try to report, what needs to be looked at. Great work so far, thank you for all your efforts to make this happen.

  • Administrators

    @zsoltmd said in Help testing new legacy image:

    Ubports image is not same as original

    Yes, it's not. The difference is, that it's (except for the binary blobs in the drivers) completely compiled by us. We were expecting issues (actually we expected more), that's why we did not do an official release yet. We are still testing.

  • @NeoTheThird Thanks for info! Based on my experience, the fingerprint unlock of PRO5 (and its stability with UT) is the almost representative feature (the wooow factor) next to Scope design. Android AOSP ROMs have very, very unstable fingerprint unlock - I think, they can not use original, Flyme driver/solution (?).
    I am looking forward the Ubports news, I need a little push to switch back to UT... 😉

  • Any word on the M10 FHD image?

  • I flashed the M10 fhd ok got a warning about not able to format cache.
    Did this manually ok and currently running with no major issues.

Log in to reply