Help testing new legacy image

  • @Stefano do you know what are they called as I couldn't find it with the obvious names ( contacts,favorites,holidays,events,etc... )

  • @zsoltmd Hi I use the RR (

    But for me it works close to great. The fingerprint I don't use, and initially I had issue with that it lost network connection. But the last month no issue at all...

    So for me it's the daily driver now...


  • Downloaded the .IMG for the M10 FHD, pasted the command from the Ubports wiki page, but get:

    ronnie@ronnie-desktop ~ $ sudo ubuntu-device-flash --server= touch \ --channel=ubports-touch/legacy --bootstrap \ --recovery-image=/home/ronnie/Downloads/Linux\ Distros/UBports\ M10/recovery-frieza.img

    2017/05/25 19:18:22 Expecting the device to be in the bootloader... waiting

    2017/05/25 19:18:22 Device is |frieza|

    Device frieza not found on server channel ubuntu-touch/stable

    Any ideas? The frieza files do seem to be on the server.

  • Oops! Cancel that. The command on the wiki page has two backslashes (/) that aren't part of the command

    Command should be:

    sudo ubuntu-device-flash --server= touch --channel=ubports-touch/legacy --bootstrap --recovery-image=[Downloaded adb recovery image]

    (obviously all on one line)

  • @darkeye Cinema, Messages Scope, Tasks, Events Scope, Youtube Scope, Calls Scope, Nearby Articles Scope, Places, Points of Interests... you need to find them there...

  • Hi All, Help needed. Trying to flash bq 5hd with legacy image using magic device tool. All went well up to start with. Got to flashing legacy channel and all seems to have stopped. Phone still on fastboot scredn, laptop still indicating flashing legacy channel it's been over half an hour . Any ideas

  • @nikhilbhalwankar
    thats sounds great
    are you using the Installmethod "using MDT" or the Installmethode "using system-image server" ?
    I ask because i own the same phone ... 😉

  • @mike Had to install Git then use git clone. Info on UBports devices page. Think it's worked now will let you know when I'm sure.

  • @mike Hi again used the magic device tool. Very straight forward and quick. My initial problem was due to a fault with the usb cable not connecting properly. One other thing if you get a device not detected message during the installation just swop usb ports. Have fun and enjoy.

  • @Lakota sorted my fault must have knocked usb cable.🤔

  • @mike I used system image server method.

  • @mariogrip one humble request. There must be many people who r using BQ E5. If you decide to rebase it to 16.04, then it will be really great !

  • I'm looking forward to try the Nexus 4 image when it comes. Maybe not a completely untested one since it is my primary phone, but something that is likely to be usable. 🙂

    Is there any description on how to do backup and restore somewhere? I have done backup by packing phablet into a zip-file in the terminal and transfer it via the FTP app to my PC, but that is kind of cumbersome and also i have not yet tried how well it works to restore. The best would be if there was an app or if the adb tools can be used in a simple way, maybe?

  • @nikhilbhalwankar I think the devs have told us that the Bq E5 android base is close source, as the Bq 4.5 or the Meizus, that's why they can't port them. The core devices (Nexus 5, etc.) are not, that's why they could port them.

  • Hello

    First I want to thank you for the great effort on giving Ubuntu touch / UBports new hope!

    Yesterday I wiped my M10FHD and installed the UBPorts legacy image.
    Basic functionality works as expected. My BT Belkin slim style keyboard and MX Anywhere2 mouse also works and Desktop mode is activated automatically when the mouse is connected.

    Booting takes ages from initial "powered by ubuntu" screen to advance. Any ideas on why that is?

    What I'm missing is "legacy X11" apps like Firefox and LibreOffice. Is there a way to install those??

    Best regards,
    Timo Leppiniemi

  • @darkeye , @Stefano , @Lars Hi, thanks for info! I am looking for more news, may I switch back to UT.

  • @timppa
    Hi there,
    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?


  • @wgarcia Ohh. Ok. Understood.

  • There seems to be a problem with phone overheating while browsing the net on mobile connection(4g, H) and also on wifi. The same problem was reported on original Ubuntu image. Nothing else makes the phone hot, only browsing the net. And it's eating a lot of battery therefore.

    It might be because of the network strenght or a low signal quality, or long distance from a router, I don't know, but it's happening, there might be a problem with Browser though. Clering the history and cache doesn't help.
    I wonder if on other devices there is such a problem.
    I know there is a problem on MX4 and Pro 5, how about BQ?

    Apart from that, there was nothing else spotted, all running well, not a single crash.crash.

    Meizu Pro 5

  • Hi @MrHoliday

    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?

    Yes, you would need to have at least some Linux distro, preferably Ubuntu of course.
    For installation there is a clear guide which you can follow here:

    For the boot time, there seems to be a a bug report in LP:

Log in to reply