Help testing new legacy image

  • @mike Had to install Git then use git clone. Info on UBports devices page. Think it's worked now will let you know when I'm sure.

  • @mike Hi again used the magic device tool. Very straight forward and quick. My initial problem was due to a fault with the usb cable not connecting properly. One other thing if you get a device not detected message during the installation just swop usb ports. Have fun and enjoy.

  • @Lakota sorted my fault must have knocked usb cable.🤔

  • @mike I used system image server method.

  • @mariogrip one humble request. There must be many people who r using BQ E5. If you decide to rebase it to 16.04, then it will be really great !

  • I'm looking forward to try the Nexus 4 image when it comes. Maybe not a completely untested one since it is my primary phone, but something that is likely to be usable. 🙂

    Is there any description on how to do backup and restore somewhere? I have done backup by packing phablet into a zip-file in the terminal and transfer it via the FTP app to my PC, but that is kind of cumbersome and also i have not yet tried how well it works to restore. The best would be if there was an app or if the adb tools can be used in a simple way, maybe?

  • @nikhilbhalwankar I think the devs have told us that the Bq E5 android base is close source, as the Bq 4.5 or the Meizus, that's why they can't port them. The core devices (Nexus 5, etc.) are not, that's why they could port them.

  • Hello

    First I want to thank you for the great effort on giving Ubuntu touch / UBports new hope!

    Yesterday I wiped my M10FHD and installed the UBPorts legacy image.
    Basic functionality works as expected. My BT Belkin slim style keyboard and MX Anywhere2 mouse also works and Desktop mode is activated automatically when the mouse is connected.

    Booting takes ages from initial "powered by ubuntu" screen to advance. Any ideas on why that is?

    What I'm missing is "legacy X11" apps like Firefox and LibreOffice. Is there a way to install those??

    Best regards,
    Timo Leppiniemi

  • @darkeye , @Stefano , @Lars Hi, thanks for info! I am looking for more news, may I switch back to UT.

  • @timppa
    Hi there,
    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?


  • @wgarcia Ohh. Ok. Understood.

  • There seems to be a problem with phone overheating while browsing the net on mobile connection(4g, H) and also on wifi. The same problem was reported on original Ubuntu image. Nothing else makes the phone hot, only browsing the net. And it's eating a lot of battery therefore.

    It might be because of the network strenght or a low signal quality, or long distance from a router, I don't know, but it's happening, there might be a problem with Browser though. Clering the history and cache doesn't help.
    I wonder if on other devices there is such a problem.
    I know there is a problem on MX4 and Pro 5, how about BQ?

    Apart from that, there was nothing else spotted, all running well, not a single crash.crash.

    Meizu Pro 5

  • Hi @MrHoliday

    I own a M10FHD too and I would like to jump on Ubports boat myself.
    can you provide some details how to install. I would be needing to use a ubuntu desktop to load the file on the tablet. is this correct?

    Yes, you would need to have at least some Linux distro, preferably Ubuntu of course.
    For installation there is a clear guide which you can follow here:

    For the boot time, there seems to be a a bug report in LP:

  • @Lakota
    i had for months problems with usb-conection. the simple reason was the diffrence between otg-usb and normal usb cable. in this case i was the failure ;0)

  • Have now flashed my m10fhd as well. All went well and at first glance appears to be running quicker in normal tablet mode, have yet to try connecting keyboard etc. Thanks to all involved for keeping this going.

  • Hey guys,

    I'm running my M10FHD with the UBports image. I confirm it's way faster but I really miss the XApps.
    Any news about Firefox/LibreOffice ?

    Edit : I'm using it with a mouse and a keyboard : it works !

  • @dada
    libre office needs a lot of temporary normal desctop-pc's its run by 2 gb ram shiny. if you have a play-and-fun-old-raspberry with max 1gigabyte ram... os needs ram... abd the rest is not enugh to run all libre-task shiny in ram. so a lot of running libre-task goes to the swap and there its needs time to loading again in the ram. in short i would say.. mobile phones with 1 gigabyte ram would run libre office very lame and lousy... you would not realy like to work so... but newer phones with 2 gb ram ( ubport core-devices...that would be fun)

  • @dada - I have the Ubports Touch on my M10 FHD and the 'Desktop Apps' scope lists LibreOffice, GIMP, Firefox, etc.

  • I don't see the Open Store in Ubports Touch. Should I install it myself, or will that affect currently installed apps?

  • @ronnietucker said in Help testing new legacy image:

    Ubports Touch on my M10 FHD

    Hi Ronnie,

    is the UBports running on your M10 FHD?
    I also have the M10 FHD and tried today flashing it, but it's not working. I tried via commandline by:
    sudo ubuntu-device-flash --server= touch --channel=ubports-touch/legacy --bootstrap --recovery-image=./recovery-frieza.img
    But no success.
    At the end I got this screen for hours:
    See bottom left "Installing Ubuntu update"
    If I choose reboot manually after 15 min. it's rebooting to install Ubuntu 15.04 OTA-15

    If I use the Magic-Device-Tool, it's the same


Log in to reply