I botched an install on a nexus 5. I'm not sure what to try next.



  • I'm trying to install ubports to a nexus 5, 16 gb that was running android 6.

    I tried with magic device tool and the ubports tool. I was able to get the installation to begin but it then hangs on a black screen that says google. I can reboot and get to fast boot. I can get to ubports recovery. I am not sure how I can get the system to boot from there.

    I tried reinstalling four times but it's hung on the black screen every time.

    Do any of you know what my issue could be?



  • @pat In Ubuntu recovery clear the cache, then reboot to recovery and try the installation again with Ubports installer.



  • @pat Also try a few different USB cables and ports. The cables can be really vital to getting things going. Sometimes when it sticks at Ubports recovery simply unplugging the cable and replugging it in works. One other thing start the installer without the phone connected and connect when needed.
    Also nearly forgot this may be useful from yesterday https://www.youtube.com/watch?v=nShXVDXM50A
    A how to install on your device video. Good luck let us know how it goes.



  • @pat MDT is not supported and it doesn't work. The recommended way is to use the ubports-installer.

    This is my usual recommendation to install UT on a Nexus 5 running Android:

    • Update the device to the latest official stock ROM (via OTA)
    • Optional: Back up your data in that device
    • Check that the device is not encrypted (do a factory reset if needed)
    • Turn on developer mode & usb debugging
    • Install the latest installer on your computer
    • Check out that you have adb and fastboot tools on your computer
    • Be sure you have a good usb cable
    • Start the installer and then plug the phone
    • Follow the on-screen instructions
    • Have patience. The installation takes a while
    • Enjoy your new UT device 🎉

    N.B. Sometimes some installer version - package type combination works better than others



  • If anything else fail, try to install with good old '' ubuntu-device-flash '' tool. It worked for me as a last stance, when everything else would just not work.


Log in to reply