WiFi password loss after each and every reboot on MEIZU Pro 5

  • The EFS partition is custom to the phone. Since you have Wi-Fi working correctly when you have Android on the device, it is unlikely that the EFS is the problem. It's more likely that your unsupported device has some hardware difference from our supported devices.

  • @UniSuperBox Thank you. Actually, I don't know if the WiFi is working correctly with Android. I removed Android and installed Ubuntu Touch as soon as I got the device. I haven't tested the password issue with Android.

    Do you mean the EFS partition is custom to the serial number of the phone or custom to the Pro 5 in general (identical to all Pro 5s)?

    I could check what hardware I have in my Pro 5 if only I knew how to install lshw or hwinfo. I am a bit worried about installing anything with apt-get. I once installed a package with apt-get and the phone wouldn't boot afterwards. I had to reinstall the whole Ubuntu Touch OS. Should I use a Libertine container to install such a small package as lshw or hwinfo?

  • @ubuntoutou
    I had this on my m10 fhd, i used the fix on xxx.skyneel.com,which is flashed with twrp, it will stay, thru ota updates ,but if you change rc,to stable etc, you need to reflash it.
    I know how annoying it is reentering the passwords !
    it says it is for mtk devices ,worked for me tho.

  • @Stefano just now I realized I have the TD-LTE one...interesting...so, from what you said, this model is the only one with 4 GB?

  • @ubuntoutou it is possible. I just did it: I have both installed on my phone and they work great when launched with the terminal. I used a software called ATU to install the packages but basically it installs those by apt-get command. I also rebooted my phone after that without any issue. I don't see very useful data among the reported ones with both the commands by the way.

  • @matteo No, there is also LTE international 4GB Ram 64GB version as well.

  • Your WiFi worked with Android, but did you get a WiFi service called " nvram error 0x10".
    If you did and you flash UT, it will not show this error, and you will need to re-enter the wifi ,every time you restart it
    Put TWRP on your device, flash the nvram zip, from " xxx.skyneel.com" check it out ,reflashing stock recovery,as needed, ota updates fix usually stays, .

    See if it works for you , while you figure something else out

  • @Stefano yes I have two like this one with no wifi issue

  • @matteo what is this software called "ATU"? Where did you get it from?

  • fwiw, my nexus 7 also forgets the wifi passwords.

  • @Marathon2422 yes I already checked in Flyme several times and I didn't get such a NVRAM error. That's why I excluded this issue among the possibilities. Thank you for asking by the way.

  • @advocatux yes this is it. Thank you advocatux :). @ubuntoutou anyway if you wish to use it, consider this is not an official tool advised by UBports but you have to use it carefully, because apt-get command is not supported on UT OS.

  • @doniks Nexus 7 were built with more hardware revisions, so this is interesting information, seems it might be a hardware compability issue.I couldn't install UT on Nexus 7, untill it got fixed by OTA-7, so this might be simmilar issue for Pro 5 and some Nexus 5 users as well. It's baffling.

  • @Stefano I also have a Nexus 7 (2013) and I couldn't get UT to boot properly until I replaced the version of Android I had with an older version of Android. I have no issue with the WiFi password on this tablet. The nexus 7 works remarkably well with UT.

  • Yes @matteo I would prefer ATU to be on the Open Store. I haven't installed it. I would prefer to install lshw and hwinfo directly with apt-get install or dpkg -i. But there are some dependencies. I know we are not supposed to use these Ubuntu Desktop tools on Ubuntu Touch. However I have managed to install htop with apt-get without much trouble. There is now an app in the Open Store for htop but it may just install htop with one of these Ubuntu Desktop tools, I don't know.

  • @ubuntoutou Good point, you can maybe try to downgrade first your phone on a old flymeos version in order to get different firmware and then install again UT. if that works, try progressive upgrades of flymeos ...

  • The problem is that I am still in the dark as to whether the EFS partition is the issue or not.

    When you wipe or format with TWRP, there are some options to choose what to wipe and what to keep. Could it be that those of us who wiped everything loose the WiFi password while those who didn't have no such loss?

    I also don't know if re-installing Android would restore the EFS partition or not.

  • @ubuntoutou If your phone works well under Android, it is not an issue with a broken EFS partition. Under Android if you get your WiFi, Bluetooth and IMEIs working well, then the problem can be more related to the firmware. This is only my thinking... Do you get access to the log files of previously connected Wifi router to your phone ? If yes, try to read the previous log to see if you can find your old wifi mac address in your dhcp offered lease history, then compare it with the one of your phone under Android, like that you will be able to see if Android is not able to read the EFS partition and take a default MAC. But again, if that was the case, you should see the error message in your logs. what kind of WiFi band is your actual phone compatible ?

  • @AlainW94 I haven't tried to re-install Android and I am a bit reluctant to do so unless I have some evidence that this is the way to solve the password issue. I haven't tried the WiFi on Android. I replaced the factory OS with UT as soon as I got the phone. I have no reason to think that there was any WiFi problem with the factory settings. I don't know what WiFi "log files" are nor where to find them. I also don't know what WiFi band my phone is using.

Log in to reply