WiFi password loss after each and every reboot on MEIZU Pro 5



  • @ubuntoutou said in WiFi password loss after each and every reboot on MEIZU Pro 5:

    Mar 7 14:44:30 ubuntu-phablet kernel: [ 2.003203] [5: swapper/0: 1] [c5] espresso_wifi_get_mac_addr:create file /data/calibration/mac_addr error(-2)

    We have to investigate this line



  • @ubuntoutou do you have this file : /data/calibration/mac_addr ?

    phablet@ubuntu-phablet:~$ sudo ls /data/calibration/
    /data/calibration/mac_addr
    

    On my phone this file contain the mac address of my WiFi adapter.

    ls -l give :

    -rw-r--r-- 1 root root 18 Feb 11 13:31 /data/calibration/mac_addr
    

    Try also this to check if there is a mac address inside :

    sudo cat /data/calibration/mac_addr
    

    Can you also make a search for that "@@@@ MAC" in your syslog ? on my phone it return WiFi MAC



  • @AlainW94 Yes I do have a /data/calibration/mac_addr file. It contains the same MAC address as the one displayed on Settings -> About.

    Regarding the syslog file, here is the output for a search of @@@@:

    cat /var/log/syslog | grep @@@@
    Mar  7 14:44:30 ubuntu-phablet kernel: [    1.213373]  [7:  kworker/u16:0:    6] [c7] @@@@ SN rsa with sha1 verify failed!!!!
    Mar  7 14:44:30 ubuntu-phablet kernel: [    1.213640]  [7:  kworker/u16:0:    6] [c7] @@@@ MAC verify failed!!!!
    Mar  7 14:44:30 ubuntu-phablet kernel: [    1.213899]  [7:  kworker/u16:0:    6] [c7] @@@@ MAC verify failed!!!!
    


  • @ubuntoutou Ok, we progress... normaly SN should display the serial number of the phone (the one you get with adb devices. And the two line should display your WiFi mac addresses.

    on my phone it give :

    Mar  6 19:02:40 ubuntu-phablet kernel: [    1.246534]  [5:  kworker/u16:1:   59] [c5] @@@@ SN 860BCMSxxxxx
    Mar  6 19:02:40 ubuntu-phablet kernel: [    1.246746]  [5:  kworker/u16:1:   59] [c5] @@@@ MAC 68:3E:34:xx:yy:58
    Mar  6 19:02:40 ubuntu-phablet kernel: [    1.246957]  [5:  kworker/u16:1:   59] [c5] @@@@ MAC 68:3E:34:xx:yy:59
    

    We have now to find what part of the kernel is giving thoses informations, if anybody had an idea ... you are welcome



  • I have the Nvram error on my m10fhd,and fix it by flashing TWRP,and flashing the β€œskyneel” fix.
    But
    I reflashed UB,to catch up after a few weeks on android.
    I am having trouble getting a working TWRP,( stuck at the first screen).
    So that I can flash the fix,to avoid reentering the wifi password
    Curious if something changed, or its my equip
    Anyone know if there is a way to go into Nvram ,change the wifi and wifi custom folders and. Change the permissions while in UB.
    Sorry for digging up an old post, but you guys looked determined to find a cure

    I tried twrp via fastboot and flash-tool, and 3 different versions,and fresh downloads.



  • @Marathon2422 I have no experience with M10fhd but as far as I know, it is not possible to edit the nvram partition while the OS is running. on the Meizu, the nvram is encryted, only the CPU has the certificate inside his memory to access this nvram. did you try one of this TWRP version : https://dl.twrp.me/freezerfhd/ ?



  • @AlainW94
    I used twrp 321 mostly, tried twrp 323, (not surprised it didn't work newer version).
    Twrp 321 worked one time,but the open store was blank no apps and the browser was the same.
    So wiped and started again, tried twrp 3.0.0, still no luck.
    I use the Devel version. it did a reboot while charging,so no wifi as expected, but I tried to connect, and lo and behold it did connect after 15 seconds or so,,, but it would not do it again.
    I will have a clean up andhave another go soon
    ( I am not a dev, just lots of fiddling).
    I have meizu pro 5 also, 32g



  • This post is deleted!


  • @Marathon2422 hi. you don't need twrp to apply the fix. You can do everything from the terminal with these three commands: sudo -i, mv, chmod 755. ( need to have the write permission with ut tweek tool)
    Maybe there is a way using adb ..but i don't know how.



  • @ubuntoutou I loose the WiFi password after reboot of Nexus 5 but if I just cancel the enter password screen then 'pull' the screen down, exposing networks, and click on my normal house WiFi, it connects. It hasn't forgotten the password at all. However, I suspect that the problems reported here are far more complex.

    On my BQ M10 HD, I can no longer connect through WiFi as it no longer gets an ip address for some reason. It 'sees' the WiFi OK and says it is connected, but the icon (top right of screen) turns completely white after about three minutes - no bars. It had worked well for months but now I suspect something is corrupt on the WiFi side. Is there anything I can reset somehow? I've tried rebooting, turning WiFi off and on and have tried connecting to another WiFi network, but with the same problem - no network access despite appearing to be connected.

    Having overcome so many installation problems with UB Ports on the M10 HD, this very nice tablet was growing on me. Despite a few restrictions, it was doing almost everything that I wanted out of a tablet, ie web, emails, notes, nextcloud access, videos (restricted to a few codecs), podcasts, document viewer, ebook reader and no google! ☺

    (Ubuntu 16.04 LTS - armhf (20190220) OTA8)



  • @gregb49 maybe you can try to upgrade to the rc channel and see if that "resets" something (?).
    The current rc image is practically what will be OTA-9, and you can go back to stable when you want πŸ™‚



  • @advocatux Thanks, but with WiFi not connecting, I cannot carry out an update. I could reload the OS, but that was a horrendous experience last time, but if that is the only option, I'll prepare myself mentally for the task. ☺



  • @gregb49 maybe the easier way is to use the installer (without checking the wipe option of course)



  • @advocatux doesn't work with originally Android version, unfortunately 😞 (Ubports installer )



  • @Stefano oh! Do you know why?



  • @advocatux Nope. Tried many times, always fails. Manual installation with ubuntu-device-flash works always. (or update from within system )Go figure. On Nexus 5 or 7 works perfectly, though.



  • @Stefano I see, thanks πŸ™‚



  • @Stefano said in WiFi password loss after each and every reboot on MEIZU Pro 5:

    @advocatux doesn't work with originally Android version, unfortunately 😞 (Ubports installer )

    Thanks Stefano. I wish that I had read your post before installing UBports Installer (0.2.2-beta). It wouldn't work on one Linux machine so I tried a manual install. This wouldn't work either. I tried on another Linux machine and it appeared to work flawlessly. Only problem is that my bq M10 HD now boots to the initial Ubuntu screen and no further. Trying the manual install but adb devices doesn't see my M10. I think I might be the proud owner of a brick!



  • @gregb49 if you see that screen, your device isn't bricked. You can't use adb but you can use fastboot πŸ˜‰

    Anyway, try this sudo ubuntu-device-flash --server=https://system-image.ubports.com touch --device=cooler --channel=ubports-touch/16.04/stable --bootstrap



  • @gregb49 BQ M10 can be restored to Canonical version of UT with Flash tool, then just flash it with Ubports installer. It should work on BQ M10 tablet as I've seen many posts about restoring this tablet with Flash tool. Search it on forum.


Log in to reply