Bq E4.5 upgrade to UBports safety and rollback possibilities



  • Hello, I own a Bq Aquaris E4.5 Ubuntu edition since 2016. As everyone here knows the Canonical support was discontinued long time ago. What I have recently discovered is that UBports took in his hands the project to continue developing it. Here it seems very simple and safe to upgrade this device to UBports Ubuntu Touch, but is it really like this? Now my phone works (at least to call, to send SMS and to access internet inside the smartphone or in external devices through hotspot or tethering). Is upgrading dangerous? Do I risk to brick it? If something doesn't work as expected, is it possible to rollback to the currently installed Canonical OS?



  • @jumpy88 With your existing system you are getting no more updates or anything so you will need to move at some point. Now for the good news. Yes it is that easy to move and Ubuntu Touch is now far better than your current system. You can do all you do now and more. There is a very knowledgeable and helpful community here to help with any issues. So give it ago you will not be disapointed.

    P.S Link to the Telegram Welcome and Install group here and the Welcome info for you to have a look at here



  • @jumpy88 one of my devices is a BQ E4.5 Ubuntu Edition too and it was pretty simple to jump to UT by UBports.

    It's always a good idea to have backups of any data that's important to you but you just need to run the ubports-installer [*] without checking the wipe option and you'll have your data and your OS up-to-date 🙂

    Also we are here to help you if you need anything with the installation!

    [*] https://github.com/ubports/ubports-installer/



  • Thank you all, you make me really feel at home 🙂
    Yes, I know is not a good idea staying without updates, but up to one week ago I didn't know about UBports 😆
    Just some additional questions before this big step:

    • ok, I'm sure I will not desire to go back, but if I do will it be possibile? Is my current ROM stored somewhere around the internet?
    • is there a tool or a guide to backup my data (sms, call register, browser tabs and visited websites, photos...) and have them back after UBports upgrade?

    ps @Lakotaubp perhaps my English is not so good, but I didn't understand your ps 😆 What did you mean?



  • or if everything goes well my data is supposed to stay where it is after the upgrade?



  • @jumpy88 I have added some links if you need them to my original post. Yes your data will stay on the phone as long as you DO NOT CHOOSE THE WIPE option. Yes the original Bq is out there in the UBports Docs



  • Ok, thank you for the links and for the answers.
    It seems clear: NO WIPE, WIPE == DAMAGE Why that option is out there? 😆 (I'm joking, I suppose it is to be used for something else)



  • @jumpy88 Hi. I bought the E4.5 ubuntu edition in 2015 as my first smartphone but by 2017 I had put it away in a drawer! I found it too unreliable, I was missing calls and this was my only phone. In 2018 I took it out again and flashed it to android following instructions on the BQ website at that time; I wanted to help my daughter whose phone had broken. As it turned out she didn't need it!

    Anyway, this was when I discovered ubports. I used the installer to get ubuntu touch on the phone and haven't looked back. It was great then and it's even better now - you are going to really like it! If you have any problems there is all the support you could possibly need in the fantastic ubports community to help you.

    Good luck and enjoy!



  • Ok, you all have convinced me 🙂
    Copied my home with a mere cp -r /home/phablet <microSD card>, removed the microSD card and checked I can read my SMS and call events data (found they are in /home/phablet/.local/share/history-service/history.sqlite which can be read with https://sqlitebrowser.org if someone arriving here needs it).
    I'm ready to start, just the time for reading https://docs.ubports.com/en/latest/userguide/install.html


  • Infrastructure

    @jumpy88 Good Luck! But it should really work out fine, we did not change so much from Canonical times, but one thing: You will find an assistant that will upgrade all apps from 15.04 to 16.04 if there was a new App published for that.

    Between releases Apps might break, so unfortunately a few apps do not have any maintainer anymore and therefore were discontinued. I hope you dont use many of those



  • Done!!! I'm on board from about 45 minutes. Don't worry about the apps. Because the last version by Canonical was few steps away from beta release, I actually used it just for calls, SMSs and as an access point.
    Now the bad news: I can't connect in USB tethering mode. With the previous version I could run

    $android-gadget-service enable rndis
    

    and the phone appeared in my desktop Ubuntu as an ethernet cable connection. Now the command does something, my computer starts trying to connect but actually never connects (it seems as if the computer didn't find an active DHCP assigning an IP to it). Is this a known problem someone can give a quick answer here or do I begin a new topic? In the second case which is the right category for this kind of issues?



  • @jumpy88 very basic question sorry but have you checked developer mode is on first. Lets solve this one while your here to get you going. Anything else relating to a specific issue goes in Support. Have a look at the categories there pretty self explanatory. Oh and welcome to UBports.



  • @Lakotaubp I've tried both with developer mode on and off, but the behaviour is the same. Anyway with the old version it worked with developer mode disabled. Let me know if I've to create a new topic. And thank you for the welcome 🙂



  • @jumpy88 I'm done for tonight sorry. Early start tomorrow. Lets leave the question here for now as I said and get it sorted. Someone maybe along to help soon things are always a bit slow on Sunday. Good luck will check how things are in the morning.



  • @Lakotaubp ok, I'll wait here someone who knows something about this 🙂



  • @jumpy88 said in Bq E4.5 upgrade to UBports safety and rollback possibilities:

    Copied my home with a mere cp -r /home/phablet <microSD card>, removed the microSD card and checked I can read my SMS and call events data (found they are in /home/phablet/.local/share/history-service/history.sqlite which can be read with https://sqlitebrowser.org if someone arriving here needs it).
    I'm ready to start, just the time for reading https://docs.ubports.com/en/latest/userguide/install.html

    If you are used to use (heavy) the MUA Dekko, be prepared to use Dekko2 in the future. For the transition, have your SMTP, IMAP and other credentials handy (because there's no automated update). For the rest of the difference between Dekko against Dekko2, advantages and problems search the forum.



  • @guru no, I didn't use it, but I will take a look in that when Dekko2 will be ready
    About USB tethering? No one has quick advice to make it work?



  • @jumpy88 can you check the steps here http://docs.ubports.com/en/latest/userguide/advanceduse/reverse-tethering.html? Maybe it could give you some additional idea (?) 🙂



  • Thank you @advocatux, I've tried to follow that guide:

    • enabled developer mode
    • enabled rndis (with explicit notification on the terminal)
    • connected USB cable

    The problem is that the computer doesn't get an IP from my phone, so I'm stuck at step 2 of the guide. Moreover, I don't remember if it should, but running ifconfig on the E4.5 terminal there is no interface that seems to deal with rndis and usb connection. Can someone with the same device check if it is possible to enable USB tethering and, if it works, check if enabling rndis makes it appear a new interface? (Check also if it is visible before to connect it to the computer).
    Anyway, if we don't solve in a couple of posts I think I will create a dedicated topic, because we are very OT.



  • @jumpy88 I think that as nothing has been fixed by now it is probably best to create a new thread. Unless of course an answer has appeared before you read this.


Log in to reply