Desktop apps won't open

  • I tried Okular and gnome-dictionary and neither worked. I did get a calculator called qalculate to work. The docs only talk about installing and managing containers and apps, and search results haven't given me any idea how to go about troubleshooting this.

    Nexus 5

    Build number: OTA-8
    Build Description: armhf (20190220)

  • @BrainRenticus It would help others to help you if mentioned what device and update version you are using.

  • @BrainRenticus Many apps may not work under libertine unfortunately. It would help if you specified which ones weren't working, but for example Chromium, Firefox, and electron apps are known to be problematic. Other apps which may require hardware acceleration may also fail to start (as it can't currently be supported via xmir on the phones).

  • This post is deleted!

  • @BrainRenticus Install apps like gnumeric for example, or abiword and try.

  • @dobey How should i go about determining which apps have a higher probability of working so im not just installing and crossing my fingers?

  • @BrainRenticus There are no guarantees, though there are some previous threads on the subject which you could search for (search for libertine), where others discuss apps that do and don't work.

    Apps which require hardware acceleration for graphics likely won't work. Apps that require special drivers to do things likely won't work, or if they do run, won't be usable on the device (arduino stuff for example). Simpler apps that are more straightforward, without external hardware dependencies, are likely to work better.

  • LOTS of apps will crash via Libertine containers right now. KDE apps (like Okular) tend to be problematic in my experience. The best ones to try and run are simpler GTK based ones.

    The following DO work in my experience:
    Abiword (word processor)
    Gnumeric (spread sheet)
    GTick (metronome)
    Pithos (Pandora streaming music service client)
    EasyTag (id3 tag editor)
    Lubuntu-Software-Center (allows you to browse what packages are available in the repository - but do not try and use to install them)
    Shotwell (image browser / editor)
    gthumb (image browser / editor)
    Screenfetch (system info via Terminal)
    youtube-dl (command line video downloader - use in Terminal)
    medit (text editor)
    gedit (text editor)
    Aisleriot (solitaire game)
    gnome-mahjongg (matching game)
    evince (pdf document viewer)
    Xournal (note taking app via touch or stylus, pdf annotator)
    file-roller (archive manager for zip files)
    p7zip-rar (adds rar compatibility)
    p7zip-full (adds 7zip compatibility)

    Web browsers that are semi functional:
    Firefox 65 (runs super slow and barely functional) - must use armhf deb at

    To make the gui of desktop apps a lot more usable on the phone:
    Create a file named .Xdefaults in a text editor (tedit is a good Ubuntu Touch native one for this) with a single line "Xft.dpi: 300" - or whatever other dpi value which you prefer. Save this to the home directory of your chroot environment (.local/share/libertine-container/user-data/xenial/ in your normal home directory) .

    Best regards,
    Steve Berson

  • A couple other apps which work well in my testing:
    Hardinfo (system info via gui)
    Xarchiver (archive manager for compressed file formats)

    Best regards,
    Steve Berson

Log in to reply