power problem



  • I have a BQ Aquarius M10 FHD Ubuntu Edition tablet. It currently is running Ubuntu 16.04/OTA-8. For a long time it has had a very strange problem. I cannot think of anything that may have caused this.

    If I leave the tablet plugged in, the battery indicator shows that it is fully charged, which makes sense. However, if I unplug the tablet while it indicates that it is completely charged (and after it has been plugged in for days), it immediately turns itself off. While it is unplugged, I am unable to restart it. If I plug it in again, then I can restart it. So, basically, I am not able to use the tablet without it being plugged in.

    Does anyone know why this might be happening, and what I can do to fix this?

    (I did contact BQ support. But, the only way they would help is over the phone, and only during a time that they select. They refused to help me via email. But, they are in Spain, so the hours they were willing to help me are only when I am at work in my country. So, they called my home phone when I was not at home - and then sent me an email saying they couldn't help me because I wasn't home to take their call. So I don't see BQ being able to help me with this problem.)



  • @dln949This is very obvious and I guess you will have tried a different charger/ cable to start with? I have a laptop charger that does the same thing. Is the charger original?Sounds like the current is passing through to the tablet when connected to the mains supply but not actually charging the tablet. Try a complete reinstall to rule that out then it starts to look like an issue of hardware. Fault on usb charging point or battery. Not much help but might rule a few things out.



  • Boot the M10 while still connected to power and investigate in the terminal-app or by SSH the values in:

    phablet@ubuntu-phablet:~$ ls -l /sys/devices/platform/battery/power_supply/battery
    total 0
    -r--r--r-- 1 root root 4096 May  2 10:11 BatteryAverageCurrent
    -r--r--r-- 1 root root 4096 May  2 10:11 BatterySenseVoltage
    -r--r--r-- 1 root root 4096 May  2 10:11 batt_temp
    -r--r--r-- 1 root root 4096 May  2 10:11 batt_vol
    -r--r--r-- 1 root root 4096 Apr 23 12:52 capacity
    -r--r--r-- 1 root root 4096 Apr 23 12:52 capacity_2nd
    -r--r--r-- 1 root root 4096 May  2 10:11 ChargerVoltage
    lrwxrwxrwx 1 root root    0 May  2 10:11 device -> ../../../battery
    -r--r--r-- 1 root root 4096 Apr 23 12:52 health
    -r--r--r-- 1 root root 4096 May  2 10:11 InstatVolt
    -r--r--r-- 1 root root 4096 May  2 10:11 ISenseVoltage
    drwxr-xr-x 2 root root    0 May  2 10:11 power
    -r--r--r-- 1 root root 4096 Apr 23 12:52 present
    -r--r--r-- 1 root root 4096 Apr 23 12:52 present_2nd
    -r--r--r-- 1 root root 4096 Apr 23 12:52 status
    -r--r--r-- 1 root root 4096 Apr 23 12:52 status_2nd
    lrwxrwxrwx 1 root root    0 May  2 10:11 subsystem -> ../../../../../class/power_supply
    -r--r--r-- 1 root root 4096 Apr 23 12:52 technology
    -r--r--r-- 1 root root 4096 Apr 23 12:52 temp
    -r--r--r-- 1 root root 4096 May  2 10:11 TempBattVoltage
    -r--r--r-- 1 root root 4096 May  2 10:11 TemperatureR
    -r--r--r-- 1 root root 4096 May  2 10:11 type
    -rw-r--r-- 1 root root 4096 Apr 23 12:57 uevent
    -r--r--r-- 1 root root 4096 Apr 23 12:56 voltage_max_design
    -r--r--r-- 1 root root 4096 Apr 23 12:52 voltage_now
    phablet@ubuntu-phablet:~$ cat /sys/devices/platform/battery/power_supply/battery/capacity
    79
    phablet@ubuntu-phablet:~$ cat /sys/devices/platform/battery/power_supply/battery/status
    Discharging
    

    Maybe this gives some hint, if the device is charged or not.



  • Thanks for both replies.

    @Lakotaubp, Yes, it is original equipment.

    @guru, I ran those commands, everything looked fine to me. It showed battery capacity at 100%, and status as "Full".

    It is strange how, when I unplug the device, it shuts itself off...... Almost as if the connection from the battery that puts out electricity is no longer a good connection. Is that possible? If I go to one of these local mobile device battery replacement shops, perhaps if I get a new battery, while replacing it they could also verify that the connections are good? Or, am I going down a very wrong line of thinking?



  • Can you look into /var/log/syslog and see if the shutdown is done by software, triggered by the cable remove, or if it is just hardware power lost.



  • Does it also shutdown when you unplug the charger from the outlet while letting the cable in the USB port of the M10?



  • I remember my m10fhd did strange things when using a different phone charger ,for convience, there must be some discussion of this ,earlier.


  • Infrastructure

    Also looking at dmesg log can help, there you should find the power reporting of the Android driver. Linux kernel only sees what the low-level driver reports, and maybe those things make more sense



  • Ohhhhh.... I hope someone can explain this to me so I can preserve my sanity!

    To recap: The problem was that when the tablet was plugged in - AND the battery definitely showed that it was nearly FULLY charged, and there was the lightning bolt symbol indicating that it was plugged in and charging - when I would unplug the cord from the tablet, it would shutdown. I have been struggling with this problem for months.

    Reading the more recent suggestions, I decided to try @guru's easiest suggestion first: Seeing what would happen by unplugging the power cord from the outlet instead of unplugging it from the tablet. When I unplugged it from the outlet, the tablet successfully switched to battery power with no problem. So, I plugged it back into the outlet, and then the tablet showed that it was charging. THEN, I tried unplugging the cord from the tablet, and..... It successfully switched to battery power. Now when I unplug the cord from the tablet, I no longer have the original (or any) problem.

    So......

    What is the explanation? What should I be concluding? Am I just being lucky at this time, and next week the problem will return?

    AN UPDATE:

    After I wrote the above, I happily used the unplugged tablet for the very first time in MONTHS!!!!!! While unplugged, I shutdown the tablet. Then, while still unplugged, I tried restarting it. It simply would not. (When I plugged it back in, then it would restart.) But, while it was unplugged and I was trying repeatedly a few times to power it on, I noticed something I had never noticed before: The screen of the tablet was actually "bowed" such that it was separating from the electronics underneath it inside the tablet - I could actually peer inside and see the guts of the tablet. I do not understand why this happened, the tablet has always been treated very gently. Anyway, I am now thinking that likely there may be some resulting hardware problem(s) inside the tablet itself that is causing the power problem????? (You may be wondering, How could he have not noticed that until now? But, because I could not use the tablet unplugged, I always left the tablet where it was, and moved my chair to it, instead of picking it up, especially since where I had the tablet sitting did not leave a lot of slack in the power cord. So, I never picked it up to handle it or look at it all these months. It just never occurred to me that something like this would happen,)

    Now I am thinking, I'd like to simply purchase a new, reliable tablet with Ubuntu Touch from UBports already installed on it, instead of continuing the frustration with this tablet's unreliability. Are there reliable sources for such a tablet that I can examine online?



  • @dln949 If the screen is bowed, it must be that the battery has died and increased on size i'm afraid, i had the same recently on a macbook for which the keyboard started sticking out and the the trackpad was not responsive anymore


Log in to reply