MTP access to Nexus 5 from Windows 10 PC

  • When plugging in my Nexus 5 (OTA-9) into my (up-to-date) Windows 10 PC the phablet home folder does not auto-mount. The device instead enters into charging mode (battery icon turns green).

    Developer mode is enabled and I do unlock the screen. And I have tried 4 different USB/micro-USB cables.

    The device does mount when plugging in into an Ubuntu 16.04 PC. And at Windows' side, I do succeed in auto-mounting another Android (6.0) smartphone.

    In Windows device manager the device is shown as a 'Google Nexus ADB Interface'. And the installed driver is ClockworkMod UniversalADB

    Btw, this post is really about getting the MTP access from Windows working, and not so much about accessing my files. Indeed, apart from accessing them through the Ubuntu 16.04 PC, I can also access them through SSH.

    I hope I'm not missing the obvious here (like installing a dedicated MTP Windows tool) ...

  • @dad_and_alive hi, as I don't use Windows, I've searched for a solution and yes, it looks like you're missing the obvious 😃

    See this for example

    • Your computer is using ADB drivers, not MTP.
    • Open Device Manager (through Control Panel?)
    • Find "Android composite ADB device" or something along those lines
    • Right-click it, and select "Update Driver Software"
    • Select "Browse my computer for driver software"
    • Select "Let me choose from a list of drivers installed on my computer"
    • Find "MTP USB Device"
    • Install it and try again

  • Thanks, advocatux!

    I had actually already seen that thread and I had already tried to follow the advice given there.

    So I tried again, but without too much hope it would now work. But -O ye, of little faith- it did work! The different outcome might be related to the installation of the ClockworkMod ADB driver earlier today (, see step 6 below.

    For future reference I will list the different steps (as the terms are not identical as in your list):

    1. Open Device Manager, fold out "TP-LINK Android Phone"
    2. Right click item "Google Nexus ADB Interface"
    3. Select "Update Driver" on Driver tab
    4. Select "Browse my computer for driver software"
    5. Select "Let me pick from a list of available drivers from my computer"
    6. Assure "Show compatible hardware" is checked and select "USB Composite Device" (I'm inclined to believe previously only "Google Nexus ADB Interface" was available, and the new device might have come along with earlier installation of the ClockworkMod ADB driver).
    7. Select Next, wait for driver installation and close.
    8. The device auto-mounts immediately!!!

  • @dad_and_alive I'm glad to hear that your issue is fixed 👍 🙂

Log in to reply