Raspberry Pi 4 Model B



  • @Pulsar33 said in Raspberry Pi 4 Model B:

    Use wget to download the image :

    wget https://ci.ubports.com/job/rootfs/job/rootfs-rpi/8/artifact/ubuntu-touch-raspberrypi.img.gz
    2019-10-09 15:01:31 (777 KB/s) — Fermeture de la connexion à l’octet 32998104. Nouvel essai.
    2019-10-09 15:02:19 (777 KB/s) — Fermeture de la connexion à l’octet 70251512. Nouvel essai.
    2019-10-09 15:03:28 (777 KB/s) — Fermeture de la connexion à l’octet 122954352. Nouvel essai.
    2019-10-09 15:06:02 (777 KB/s) — Fermeture de la connexion à l’octet 243216040. Nouvel essai.
    2019-10-09 15:07:18 (778 KB/s) — Fermeture de la connexion à l’octet 299912256. Nouvel essai.
    2019-10-09 15:08:06 (776 KB/s) — Fermeture de la connexion à l’octet 333935672. Nouvel essai.
    2019-10-09 15:09:25 (776 KB/s) — Fermeture de la connexion à l’octet 391547952. Nouvel essai.
    2019-10-09 15:11:42 (777 KB/s) — Fermeture de la connexion à l’octet 495116320. Nouvel essai.
    2019-10-09 15:15:15 (776 KB/s) — Fermeture de la connexion à l’octet 657307736. Nouvel essai.
    2019-10-09 15:16:58 (776 KB/s) — Fermeture de la connexion à l’octet 732007056. Nouvel essai.
    2019-10-09 15:17:22 (779 KB/s) - «ubuntu-touch-raspberrypi.img.gz» enregistré [742746631/742746631]
    
    

    SDcard flashed : same partitions as @Aury88
    Try to test asap
    Pulsar33

    Also doesn't seem an etcher error. dd make the same partitions.
    @Pulsar33 do you tested it on rpi4 or rpi3?



  • Hello

    See above
    Dmesg : [ 0.000000] Machine model: Raspberry Pi 4 Model B Rev 1.1

    Starting with a fresh dd of the img file, you should succeed as me.
    Hope you will find what to do to boot in graphical mode.
    Can't test myself until tuesday as said.

    BR
    Pulsar33



  • hi,
    no, my fresh dd didn't solve anything and still I was not able to start in console mode... stuck in the infinite boot inputs errors



  • In a few days I will have a Pi4 (4GB). At the moment I can run Marius' image on my Pi3 although the scaling is out (on a HDMI montor and on the 7" Pi touch screen) and it tends to freeze when the browser is run. I got a wee bit stuck until I realised "phablet" was the passcode it asked for 🙂



  • @Aury88 :
    If you used your 64GB SDcard, try a 32GB one or, after using dd, use gparted to create a 33GB partition at the end of the SDcard. This could help to break the reboot loop.
    BR
    Pulsar33



  • @Mark :
    What was necessary to launch the graphical interface starting from console mode, please ?
    BR
    Pulsar33



  • in the 64GB SDcard, after using dd and adding a 33GB partition at the end of the SD Card I have the following kernel panic:

    [] No filesystem could mount root, tried:
    [] esxt4
    []
    [] Kernel panic - not syncing: VFS: Unable to mount root fs on unknow-block(179,2)
    [] CPU: 3 PID: 1 Comm:swapped/ Not tained 4.19.73-v8+ #1267
    [] Hardware name: Raspberry Pi4 Model B Rev 1.1 (DT)
    [] Call trace:
    []  dump_backtrace+0x0/0x178
    []  show_stack+0x24/0x30
    []  dump_stack+0x9c/0xd4
    []  panic+0x130/0x284
    []  mount_block_root+0x228/0x28c
    []  mount_root0x148/0x17c
    []  prepare_namespace+0x178/0x1c0
    [] usb 1-1.4:New USB device found, idVendor=04d9,idProduct=1702, bcdDevice= 1.01
    []  kernel_init_freeable+0x328/0x3c0
    []  kernel_init+0x10/0x110
    [] usb 1-1.4 : New USB device strings:Mfr=1, Product=2, SerialNumber=0
    []  ret_from_fork+0x10/0x18
    [] SMP: stopping secondary CPUs
    [] Kernel Offset: disabled
    [] CPU features: 0x0,21806000
    [] Memory Limit: none
    [] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknow-block(179,2) ]---
    [] mmc0: Timeout waiting for hardware cmd interrupt.
    [] mmc0: sdhci: ============ SDHCI REGISTER DUMP ===========
    [] mmc0: sdhci: Sys addr:  0x00000008 | Version:  0x00001002
    [] mmc0: sdhci: Blk size:  0x00007200 | Blk cnt:  0x00000000
    [] mmc0: sdhci: Argument:  0x00020000 | Trn mode: 0x00000023
    [] mmc0: sdhci: Present:   0x1fff0000 | Host ctl: 0x00000017
    [] mmc0: sdhci: Power:     0x0000000f | Blk gap:  0x00000080
    [] mmc0: sdhci: Wake-up:   0x00000000 | Clock:    0x00000107
    [] mmc0: sdhci: Timeout:   0x00000005 | Int stat: 0x00000000
    [] mmc0: sdhci: Int enab:  0x03ff100b | Sig enab: 0x03ff100b
    [] mmc0: sdhci: ACmd stat: 0x00000000 | Slot int: 0x00000000
    [] mmc0: sdhci: Caps:      0x45ee6432 | Caps_1:   0x0000a525
    [] mmc0: sdhci: Cmd:       0x00000d1a | Max curr: 0x00080008
    [] mmc0: sdhci: Resp[0]:   0x00000e00 | Resp[1]:  0x01f3ff7f
    [] mmc0: sdhci: Resp[2]:   0x325b5900 | Resp[3]:  0x00000900
    [] mmc0: sdhci: Host ctl2: 0x00000000 
    [] mmc0: sdhci: ADMA Err:  0x00000000 | ADMA Ptr: 0xded3a208
    [] mmc0: sdhci: ============================================
    


  • @Aury88
    Woooo 😞
    Sorry, no more idea to try to help you.
    When I'll be home, I'll give you the sha256sum of my image file to be sure that we have the same
    Have a nice day
    Pulsar33



  • @Pulsar33 NP.
    I sacrificed my smartphone 8GB sdcards and whit the UT image it "work". I was able to login and explore the system in console mode. but was not able to see the DE (it says unity8 is running and after restart unity8 nothing change)



  • @Aury88
    Just back home ... Fine that you were able to explore the system in console mode.
    This confirm that 64GB cause problems not only in the case listed in the link above ...
    I'll take some time to try graphical mode. I'll report here.

    People who know how to launch the graphical mode are welcome to explain here !

    BR
    Pulsar33



  • Sorry but I didn't understand how to launch the graphical user interface.
    And with a console mode only, I don't see what to do with it ...
    I hope someone will describe the solution.
    BR
    Pulsar33



  • Hello,

    Nobody (knows how) is interested in running Ubports in graphical mode on a Raspberry Pi4 ?

    Have a nice day
    Pulsar33



  • Well I, for one, am following UT on Pi with great interest, @Pulsar33.

    I'm still at the "Kernel Panic" stage though, so I can't help much. Sorry.



  • Hello,

    Thanks for your answer, @3arn0wl

    To be sure that we all use the same image, here are the sha256sums of the #8 latest stable build (2019 09 25) I use :
    ubuntu-touch-raspberrypi.img.gz febf1ce00e639ae469bf075bce4472b82b25a6d634a147c01d666f1d4f5033c0
    ubuntu-touch-raspberrypi.img 76a47458b90702a156e6f9741b448db5e4d0e5235ec177ae4dea9224e4e7e2b5

    The flashing process on my Linux Mint 19.2 Desktop :

    lsblk   # the SDcard appears as /dev/sdc
    umount /dev/sdc1
    umount /dev/sdc2
    sudo dd bs=4M if=ubuntu-touch-raspberrypi.img of=/dev/sdc status=progress
    

    BR
    Pulsar33



  • Still no clue from the GURUs ?
    Please help us to progress and launch the GUI ...
    Best regards
    Pulsar33



  • @Pulsar33
    Hi!
    The unity8 log is very similar to this issue in mir-kiosk. It says there is a workaround but I don't understand what it is....we need to study it and or help from @alan_g

    it seems we need to

    --env-hacks MIR_MESA_KMS_DISABLE_MODESET_PROBE
    

    when run mir/unity8 but I don't undestand how...



  • also we are using an old rootfs with missing firmwares (last building image is the #8 from 24 September when the firmwares integration in the common rootfs is from 3 October )



  • @Aury88 said in Raspberry Pi 4 Model B:

    @Pulsar33
    Hi!
    The unity8 log is very similar to this issue in mir-kiosk. It says there is a workaround but I don't understand what it is....we need to study it and or help from @alan_g

    it seems we need to

    --env-hacks MIR_MESA_KMS_DISABLE_MODESET_PROBE
    

    when run mir/unity8 but I don't undestand how...

    That's just one way to set an environment variable.



  • @alan_g sorry but I'm not so skilled about bash and linux. so excuse me for the stupid question:
    I knew that environment variable had to have a value so something like

    ENV_NAME=value
    

    MIR_MESA_KMS_DISABLE_MODESET_PROBE seem only the name...what is its value? is it"true"?



  • @Aury88 said in Raspberry Pi 4 Model B:

    @alan_g sorry but I'm not so skilled about bash and linux. so excuse me for the stupid question:
    I knew that environment variable had to have a value so something like

    ENV_NAME=value
    

    MIR_MESA_KMS_DISABLE_MODESET_PROBE seem only the name...what is its value? is it"true"?

    It doesn't need a value, so "true" will be fine (as will "false").


Log in to reply