Can't install or download document viewer from openstore

  • Hello community.
    I have trouble to install document viewer. In openstore app, after tapping the install button, it begins to download the app, but after about 75% the download stops and install button shows again. No document viewer was installed. I've also tried to download the click package first from openstore website, but the download fails (after about 75%) with "General network failure" message.

    Currently I'm on rc channel with version 49 installed. I think, there is some trouble with click package uploaded to openstore.

    Can you install or download document viewer?

    Thank for answers an insights.

  • @jezek try again. Cloudflare has been experiencing some troubles ( but it seems it's mostly working now 🙂

  • @advocatux still no luck. After 89% direct download of document reader click package fails with the same error. For download I'm using Morph Browser on Fairphone2 with Ubuntu Touch on rc channel, version 50. The space is not a problem

    phablet@ubuntu-phablet:~$ df -h ~/Downloads/
    Filesystem       Size  Used Avail Use% Mounted on
    /dev/mmcblk0p20   26G   14G   11G  58% /home

    Can anybody try to download the mentioned click package and report if successful or not? Thakns.

  • @jezek I've just tested it using a BQ E4.5 running edge, and a Nexus 5 running rc.

    No problem downloading that package with Morph for me 🙂

  • @advocatux I tried it now, and the numbers are inconsistent. Now it failed after 71% with general network failure. I have to try to download the click package on notebook. Thanks for information, that you can download the package.