bq Aquaris E5 HD Ubuntu Edition wants to be OEM unlocked during installation



  • Thank you @advocatux and @Lakotaubp!

    I managed to get the latest installer (0.2.5-Beta) running by manually switching to Fastboot mode using

    adb reboot bootloader
    

    as described here and manually selecting the device as suggested by @advocatux in this thread. The installer shows the same prompt as in version 0.1.21-Beta:

    Device locked

    Unfortunately, it seems to hang now as the prompt doesn't disappear after clicking "Unlock". The terminal says:

    Pug interceptor registered successfully
    info: Welcome to UBports Installer version 0.2.5-beta!
    warn: This is not the latest stable release!
    info: vegetahd selected
    info: Instructing manual reboot
    info: Press and hold the volume down and power buttons until the phone reboots.
    info: fastboot: wait for device
    info: Download complete
    info: Flashing images...
    

    Is this normal? Do I just have to wait?



  • @Tartaros It says its working 'flashing image's' can you see any progress yet? The installer will tell you when finished.



  • No, there is no indication of progress. Neither a filling progress bar in the installer nor some log on the console. Just the animation in the background window (appearing and disappearing dots, circle spinning around the robot).



  • @Tartaros Give it a little longer, can't remember how long it takes with first time flash should be less than half an houryou should then get pushing files to device iron similar. If it appears to have stuck, stop the installer, disconnect your device. Restart installer, then connect device when asked and try again. Perhaps with another version of the installer like the snap if that still doesn't work.



  • @Lakotaubp As I already wrote above, the installer hangs at the point depicted in the image. This also didn't change for about an hour, so I closed the installer, disconnected the device and shut the phone down by holding the volume up and power buttons for about seven seconds. I can still successfully boot into the Canonical Ubuntu Touch, it seems like the installer did nothing at all. I don't think that trying it again would be successful. Is it possible to do the OEM unlock prior to launching the installation process so the installer can directly start its work?

    Unfortunately I have no other choice than using the AppImage as the Snap support is not yet finished for my OS.

    Should I file an issue on Github regarding that the phone cannot be automatically OEM unlocked?



  • @Tartaros You have abd and fastboot installed then in a terminal run adb devices then
    sudo fastboot OEM unlock

    That should do it. As for rerunning the installer, sometimes it progresses a bit further each time. It's always worth another run. Sorry I thought snaps could run on Manjaro



  • @Lakotaubp I expect I need to switch the device to fastboot mode prior to performing the OEM unlock? I will try it tomorrow.

    In theory yes, snaps can be run with Manjaro, but the snap support is still experimental and I do not want a snap error to make my phone a pricy paperweight.



  • @Tartaros Yes after running adb devices to see your device run
    adb reboot bootloader
    Then
    Sudo fastboot oem unlock



  • @Lakotaubp I tried as you suggested, but

    sudo fastboot oem unlock
    

    simply hangs after printing a bunch of whitespace characters. I assume that the installer got stuck the same way. Is there any guide on how to unlock the bootloader of the E5? I found some guides for other bq models but none specifically for the E5.



  • @Tartaros So when you open a terminal and type:
    adb devices
    Your devices is detected, yes. If not you need to grant permisson on your device. There should be a pop up window appear. Then just type the next to commands
    adb reboot bootloader
    Wait for that, then it's
    sudo fastboot oem unlock and that should be it. Your device is unlocked and you can carry on.



  • @Lakotaubp The device is listed by

    adb devices
    

    (yes, I authorized the device by accepting the popup) and after

    adb reboot bootloader
    

    it is also listed when executing

    fastboot devices
    

    but the subsequent command

    sudo fastboot oem unlock
    

    starts, prints some whitespaces and then does nothing.



  • @Tartaros Now please try the installer again, after rebooting your phone.



  • @Lakotaubp The installer still says that the bootloader needs to be unlocked. I think the unlock command didn't work (it didn't even terminate).



  • @Tartaros which version of the installer are you using is it still 0.1.21 If it is please try 0,2.1, .2 or .3 they will unlock a locked bootloader. Then see what happens.
    If you still have an issue after that then I'm a bit stumped if the bootloader is still locked or registering as such. All i can think of is reflashing the canonical UT from BQ to see if that fixes it.

    Edit: Unless your suspicions are correct and the phone had an issue when returned from Bq, especially if it was not your original device. Though not sure why it would be. Unless they flashed a stock item.



  • @Lakotaubp I'm using the latest version (0.2.25-Beta), as stated above, it works when setting the phone to fastboot mode prior to launching the installer. I'm not sure whether I want to reflash the original UT image with proprietary tools, maybe I will contact bq regarding that issue and see if they can help me with unlocking the bootloader.

    I'm pretty sure that the device they sent back to me was a new one as the WiFi and Bluetooth MAC adresses didn't match the ones of the device I sent to them initially. It really seems like they flashed a stock item and locked the bootloader afterwards, maybe with a newer firmware or bootloader version that is not unlockable in the same way as the original devices.



  • @Tartaros Must be worth getting in touch. One last thing would be to try a live usb stick with Ubuntu 15.04 on it to run the installer.



  • Hi,

    I got the exact same issue like @Tartaros , with my BQ e4.5.
    I am on Manjaro too. But I have flashed ubports with it before...

    I also flashed the original old android, then flashed old canonical image and tried again, with exact same result.

    But now as I write, I remember that I got this "oem locked" message for FP2 too, which is already on latest ubports RC.

    So it seems to be definitly an issue with Manjaro... or the fastboot package of Manjaro...



  • Okay.
    I can confirm that the problem is the android-tools package of manjaro-community package.
    I uninstalled it, and installed the android-sdk-platform-tools AUR-package.

    Now it works, although I am not shure, if the installer is using the AUR package or if it is using it's own tools?!



  • @Luksus Thank you for the info! As soon as I find time to, I will try this too!



  • @Tartaros said in bq Aquaris E5 HD Ubuntu Edition wants to be OEM unlocked during installation:

    @Lakotaubp I expect I need to switch the device to fastboot mode prior to performing the OEM unlock? I will try it tomorrow.

    In theory yes, snaps can be run with Manjaro, but the snap support is still experimental and I do not want a snap error to make my phone a pricy paperweight.

    You can try the appimage it works well.
    I just tried today the snap installer since the aur package was giving me the same error as yours and it worked flawlessly.


Log in to reply