Anbox gallery path in FS

  • Hi everyone!

    As for now Anbox does not interact with UT Camera, I wanted to have a .sh file that moves Photos from Android gallery to the main UT gallery and viceversa. The problem is that I do not know where the gallery is located within the filesystem. I found many android folders in /home/phablet/anbox-data/data/data, but I cannot find where the photos are.

    Could someone enlight me? 🙂

    Thank you very much in advance!

  • @ThrillSeeker Does anbox work already ? Via Libertine ?

  • @Emphrath Anbox is in an early and experimental phase. If you want to give it a try, please see

  • I don't currently have Anbox installed on my UT test phones, so I can't check this myself, but is there a folder named DCIM anywhere? That is typically where Android lands photos.

    Also, instead of moving files from directory to directory with a script, could you simply link the two directories at the filesystem level? (Again, I can't test this right now, and it could be that apparmor or something else would be mad if you tried it.)

  • @ThrillSeeker Nice. I want to give it a try but I'd need to set my phone image in writable mode to pass these commands am I right ? Or use a Libertine container ?

  • @Emphrath What I did are exactly the steps detailed in here:

    It worked perfectly for me 😉

  • @trainailleur I just found three DCIM folders, and within a folder named .thumbnail, there are the photos!

    The bad part is, just to do a previous test, I copied a screenshot from my UT to these folders (they are synced), but I cannot see this photo in the gallery... One thing is strange, although these Android photos are within DCIM folders, they are not organized in folders, while in the Android gallery app, I can see that they are arranged in several folders. I do not know if there is the reason why I cannot see the screenshot.

    I understand if you cannot help me further, thank you anyway! 🙂

  • Hmm, not sure what's going on. On my Android devices, in the user data (wherever that resides; it is mounted at /storage/emulated/0 on a lot of recent LineageOS devices, but not sure about AOSP, and it has changed from version to version anyway), there will be DCIM directory. Within that there may be a directory for thumbnails (.thumbnails) if used by the given camera software, then a separate directory for the name of the camera software (e.g., Camera, OpenCamera, 100ANDRO, to name a few I see in some of my old backups).

    So If you've not already tried this, I think perhaps within the directory where you see the subdirectory of thumbnails, you should create a subdirectory called Camera if it doesn't already exist and put your images there.

    But I admit I'm stabbing in the dark here. Unfortunately it will probably be several weekends before I have time to test Anbox again and try this for myself. Perhaps someone else with Anbox running now will see this and be able to help.

  • @ThrillSeeker this step:
    "sudo mount -o rw,remount /"
    Is about mounting the filesystem in writable mode. isn't it supposed to break the system ? I don't want to have to flash ut all over again because next image update conflicts with apt...

  • @Emphrath I am sorry, but I do not know enough to answer your question with details. The only thing I can assure you, is that in my case it broke nothing, after following these steps I just had anbox in my UT, and it was not even necessary to restart the phone (or flashing it again.

  • @trainailleur I tried creating this Camera directory, but to no avail. Anyway, thank you very much for your help! 🙂

Log in to reply