Failing to flash on Aquaris M10 FHD



  • Hi together,

    today I tried to revive my old M10 by upgrading from canonical ubuntu touch to the current one. I first tried to install via the ubports-installer (appimage on manjaro) which fails, for unclear reasons:

    info: Flashing images...
    error: Devices: Error: undefined
    

    Then I tried the manual way as suggested on the ubports website:

    I formated cache, system and userdata, and tried then to flash the recovery.img:

    fastboot flash recovery recovery.img
    fastboot: core/libsparse/sparse.cpp:131: int write_all_blocks(struct sparse_file *, struct output_file *): Assertion `pad >= 0' failed.
    [1]    411 abort (core dumped)  fastboot flash recovery recovery.img
    

    That looks erroneous to me, and rebooting into recover mode was not possible. So, can anyone help me and suggest a way to go?

    Could it be that the recover partition is too small for the image? If so, can someone point me to how to change that?

    fastboot getvar all
    ...
    (bootloader) 	partition-size:cache: 40000000
    (bootloader) 	partition-type:cache: ext4
    ...
    (bootloader) 	partition-size:recovery: 1000000
    (bootloader) 	partition-type:recovery: raw data
    (bootloader) 	partition-size:boot: 1000000
    (bootloader) 	partition-type:boot: raw data
    ...
    (bootloader) 	warranty: no
    (bootloader) 	unlocked: yes
    (bootloader) 	secure: no
    (bootloader) 	kernel: lk
    (bootloader) 	product: frieza
    (bootloader) 	version: 0.5
    all: Done!!
    

    I appreciate every help! Thank you in advance!



  • @toschio Try the method mentioned here https://github.com/ubports/ubports-installer/issues/593 you need to scroll down a bit to find it



  • @Lakotaubp Thanks for the really fast reply!

    Sadly, this seems not to work. You mean the suggested solution by running the installer with su, right? It still shows the meaningless error message as above.

    Or do you mean the solution that suggests to install Lineage OS first and then install ubuntu touch?



  • @toschio I ment the first. Haven't tried the other.



  • @toschio which android-tools version are you using? Some people reported issues with some versions in Arch. See for example https://bugs.archlinux.org/task/63370



  • @advocatux Wonderful! I wouldn't have thought of it. Downgrading android-tools did the trick, and the ubports-installer worked. Thank you very much!



  • @toschio I'm glad to hear that. Kudos!


Log in to reply