Continuation of rpi effort and how to test

  • Administrators

    @jezek We have images here that are designed for the pinebook 🙂 but please note that these are really early images, so they are not stable at all, and there is some bugs 🙂

  • This post is deleted!

  • @mariogrip so I tried again ( I still don't know why those links works) and this is my PR with this diff

  • Good to see great progress.
    Using the latest image the Pi4 boots and runs well although a graphics issue means that you can't read anything opened in a window.
    Scaling is now sorted on the monitor and when using the 7 inch touch screen.
    The graphics issue does not affect the Pi3 but it is (understandably) frustratingly slow.
    The touch screen worked on the first image but not on the most recent one. UPDATE It woked after a reboot but as the left and right edges are slightly offscreen it restricts its usefuleness.
    UT on the Raspberry Pi feels much closer now to something that will work. Thanks to those who understand all this far more than me for putting the work in.

  • Hello,

    Trying v66 on RPI4B 4GB flashed on SDCard with dd command :

    • Connected to 1920x1080 screen through HDMI0 => ok
    • Need to disconnect/reconnect radio interface for keyboard/mouse
    • Overscan is always activated : ~48 pixels/lines black borders
    • First and second boot : horizontal view, initial parameters, keyboard layout ok
    • Third boot login : rotated, after login : switched to horizontal by itself
    • Third boot : wrong keyboard layout (uk instead of previous fr selected)
    • Ethernet connected but not seen, WiFi activated, Bluetooth not found
    • After third boot, shutdown makes a restart, not a shutdown
    • Next time, the shutdown was complete

    Main problem :

    • The window manager displays the frames and menus correctly
    • The application show a correct initial display for one second
    • Then, the inner part of the window becomes garbage
    • It reminds me something like incoherent window size and viewport size

    Rotated login

    Calc just started (correct)

    Calc after one or two seconds (garbage)

    Multiple apps : all garbage, menu and notification : all clean

    Best regards

  • To remove overscan, uncomment this line


    in /firmware/config.txt

    If your mouse lags, try to add this :


    at the end of the line in /firmware/cmdline.txt


  • Another tip : print screen key works
    Easy to access to the snapshots by reading the SDCard on my desktop
    Will use it next time instead of the ugly pictures above ... Here is a reduced to 720p example :

    Maintaining the Super (Windows or Apple) Key displays the available shortcuts. They work AFAIK.

    Unfortunately, I was looking for CTRL-ALT-F1 and CTRL-ALT-F7 shortcuts but they don't seem to exist, do they ?


  • As said above ethernet is not seen (in the notification area) however ethernet is working !

    So, one more tip if you want : ssh works too
    On your desktop/laptop, use the following command in the /firmware folder of the SDCard

    touch ssh

    After booting, you can login from your desktop/laptop with

    ssh phablet@[local-IP]
    password: phablet

    Have a nice evening

  • @Pulsar33 the CTRL-ALT-F1 and CTRL-ALT-F7 I confirm they don't work

  • Hello,
    Is there some progress about graphical problem for Pi4 ?

  • Hum, seems to regress.
    Tried the #77 and I've a black screen after the boot listing and reboot.
    However ssh works but don't know what to do with it.

  • @Mark The work on preparing UT apps for other arm64 platforms gives us something to work with now. The UT Tweak Tool seems to work reasonably as does TELEports and File Manager. I can get sound output from the terminal but not through the apps. Mouse behaviour is a little odd and seems to deteriorate - most of my experience is on the Touchscreen which seems more stable and easier to use. Adding Swap has been helpful, particularly when having multiple open tabs on the Morph Browser. If someone can get to the bottom of the (compositor?) issue with the Pi4 the resource related issues should be much reduced, particulatly with the 2 and 4 GB versions.

  • Would the approach taken here (with Gentoo running arm64 including camera, sound and display) work for us or is it too far from the way UT works?

Log in to reply