Video files, specifically mp4, won't play on my Nexus 5

  • I did a brief search for a solution, and found this, which suggests that there is no solution. Is that correct? I tried using the core media player, and I also tried UTmedia. Neither worked.

  • @MarkG_108 I have same problem with my nexus 5

  • UTmedia should work, but it will use software decoding and no hardware accelerated rendering, as it's in the browser, IIRC.

    Yes, otherwise, the video issue on Nexus 5 still has not been fixed.

  • Well, I guess I'm not alone then. I tried a webm file, and it plays, but I don't see the video -- I can only hear the sound (in Media Player and UrPlayer, whereas UTmedia just freezes). ogv also doesn't work.

    I then installed lubuntu-restricted-extras via the terminal using APT (after making the session read-write and adding the multiverse repository to the sources.list), and that did nothing. Then I tried installing VLC in the Libertine Container, but that didn't work (my Nexus 5 doesn't have enough juice to run it). I gotta say, it's disappointing that it doesn't play videos.

  • @MarkG_108 Hello.

    I have already mentioned elsewhere that reading in UT media can be more and more problematic (at least for me on RC).

    Anyway, try this which works (usually) for me:

    1. make a copy of the file with File manager, paste the file into UT media and then proceed as usual and the file should open and be read.

    2. If that's not enough, reboot the phone and go to 1.

    Not very fluid, but it can help !

  • @domubpkm Thanks. Yes, even though it's a bit awkward, it does work.

  • Im also on the Nexus 5 having no MP4.
    I tried using the UTMedia with copy / paste (or reboot) method without success, instead I get another error!
    Im directed to download this:

    So I tried video conversion from mp4 to webm.
    VP89 VIdeo File in Webm container
    Now Im getting sound with a black display.
    So which codecs are safe?
    Vlc Options:

    * H.2Options64 video format  in MP4 file container
    H.264 video format in TS file container
    Dirac video format in TS file container
    MPEG video format in TS file container
    Theora video format in OGG file container
    WMV video format in ASF file container
    DIV3 video format in ASF file container
    MPEG 1080p/720p video format for TV/device in MP4 file container
    DivX video format in AVI file container
    SD video format for iPod in MP4 file container
    HD video format for iPod HD/iPhone/PSP in MP4 file container
    SD low and high video format for Android in MP4 file container
    VP89 VIdeo File in Webm container

  • I see that, I can't read my personnal movie that I take with the camera app . it's the mp4 format, maybe we can create video with an another format ?

  • @mito77 The problem isn't the video format. The problem is video playback on Nexus 5 is broken. Once someone fixes the bug, then all those videos will also play on Nexus 5 just fine.

  • @dobey OK, so I view my video taked by this phone , how to? I transfert the video by USB cable to ubuntu laptop and upload on youtube. now on my phone , I watch my movie not with the software . but with the website Youtube.

  • @mito77 Again, there is an issue on the Nexus 5 with video playback, so you cannot really play videos locally right now. The solution is to find and fix the bug, which is apparently quite difficult as nobody has succeeded yet to fix it.

  • @dobey no problem. If I can compile. I try to make a portage of vlc for ubports. Or create an executable. So the problem maybe is the size of the screen or the design and the accessibility of the menu.

  • @mito77 This is not a fix for the problem.

  • YouTube work correctly but Vimeo is slow or the movie is chopped or "Fine cut " maybe It’s the player of vimeo need more cpu
    charge capacity not like this nexus 5?

  • @mito77 There is, as has already been mentioned a well known bug on the Nexus 5 that is ( for various reasons) not easy to fix. Replying with odd off site links to video streaming sites and such does not help fix the issue and looks more like spam to the casual viewer. Can you you please stop doing this, I am removing the links this time. Thanks for your understanding

  • Is it known if this problem will be addressed for OTA-13? I can't find my way around Github or whatever it is called to look for myself.

  • @cliffcoggin I don't see issue on OTA13 project board currently. As it concern only one device, i guess it is not a high priority thing. The project board:

  • Thanks for the links. Such a shame it is unlikely to be fixed, particularly as it apparently worked in OTA-11.

  • @cliffcoggin yes call for volonteers 🙂

  • I tried converting an MP4 video into OGG, but it made no difference. Media player needs serious work.

Log in to reply