Sony Xperia X (suzu/F5121 & F5122)

  • @libremax GitHub is fine for bug reports.

  • So I tried to install following your steps, but I always get this error in the last step:
    Cache formatting was not succesful, flashing may fail, check your partitions on device
    Where did I go wrong?

    bkos@T430:~/Letöltések$ fastboot erase cache && fastboot erase userdata && fastboot erase system
    ******** Did you mean to fastboot format this ext4 partition?
    erasing 'cache'...
    OKAY [  0.012s]
    finished. total time: 0.012s
    ******** Did you mean to fastboot format this ext4 partition?
    erasing 'userdata'...
    OKAY [  0.094s]
    finished. total time: 0.094s
    ******** Did you mean to fastboot format this ext4 partition?
    erasing 'system'...
    OKAY [  0.040s]
    finished. total time: 0.041s
    bkos@T430:~/Letöltések$ fastboot flash oem SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_loire.img
    target reported max download size of 536870912 bytes
    sending 'oem' (220783 KB)...
    OKAY [ 12.517s]
    writing 'oem'...
    OKAY [  3.171s]
    finished. total time: 15.688s
    bkos@T430:~/Letöltések$ ubuntu-device-flash touch --device=suzu --channel=16.04/community/fredldotme/devel --bootstrap
    2019/10/26 21:30:40 Device is |suzu|
    2019/10/26 21:30:40 Flashing version 23 from 16.04/community/fredldotme/devel channel and server to device suzu
    2019/10/26 21:30:50 Cache formatting was not successful, flashing may fail, check your partitions on device
    2019/10/26 21:30:52 Waiting for device to enter recovery mode ...
     Cache formatting was not succesful, flashing may fail, check your partitions on deviceFailed to enter Recovery

    After this the device is in the endless boot loop.
    Thanks in advance.

  • @bkos said in Sony Xperia X (suzu/F5121):

    Does your device boot into recovery by pressing the VolDown + Power button? What happens then? Also does adb devices show any device in its list?

  • @fredldotme
    Before flashing with Android installed, VolDown and Power button, blue light.
    After trying to install UBports, it enters some recovery.
    adb devices doesn't show any device, neither before flashing, nor after.
    I had Sailfish installed on this device, maybe that screws up something?

  • @bkos I also had sailfish on my device before and the same failed to recovery problem as you.
    I managed to install it eventully a few days ago by installing twrp with version 3.2.3-0 that that was mentioned in an earlier post.
    The I got a bit further with it failing with "/cache/recovery/': remote couldn't create file: Is a directory" and then checked with adb shell and saw that the directory /cache/recovery was not there and created it.

    then it got further and ended with

    2019/10/28 21:30:45 Created ubuntu_command: /home/sonny/.cache/ubuntuimages/ubuntu_commands273504541
    2019/10/28 21:30:45 Rebooting into recovery to flash

    and then twrp came and i could not see those ubuntu commands.

    Then I tried

    fastboot flash oem SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_loire.img

    again and then

    ubuntu-device-flash touch --device=suzu --channel=16.04/community/fredldotme/devel --bootstrap

    and this time it worked with another recovery screen.

    I have no idea, this is my first time flashing ubports, but maybe its that there was something missing which twrp then provided and then flashing the recovery from the AOSP worked then.

  • @fredldotme

    Thank you for your work, I managed to install it with a slightly different procedure as I wrote in my last comment.
    Today I got a system update and installed it and now the phone is stuck in a reboot loop until I force shutdown it with power and volume up and waiting for three vibrations.

    Is that expected that over the air updates do not work yet?
    And I had no sim inserted in case that is relevant. I just tested it with wifi so far.
    I will try to reflash it again soon.

  • @sonny Xperia X is not yet included in UBports Installer and in the same way, I see not reason why It could be included at this step in UBports OTA system.

  • @libremax I don't know for sure, but I could imagine that suzu gets otas. Its in the ci and the image server, so that whole machinery might just work. Even though the graphical installer application is not able to serve it yet.

    If that is the case, then @sonny you just updated to the brand new mir and unity versions that got promoted from edge channel. There's another post where they explained the edge merge.

    Maybe that new image is causing the problem on this halium built device?! You can probably switch back to an older dev image with ubuntu-device-flash. I don't know the syntax by heart, buy just check -h.

    If that theory is correct, then @fredldotme maybe some older devel image could be promoted to rc?

  • @doniks In fact, I was not looking at this from a technical point of vue but from a "logical" one.
    Given it's an early pre-release without polishing for the install step, I did'nt expect that OTA would be enable.

  • My phone was actually able to startup today after being shut off over night.
    I then checked the updates again and Ubuntu touch Version 26 was listed as available again.
    I tried to install and got a glowing circle like I did when I initially installed it and then it booted up to show the update is still available.
    I leave that update for now while I check the system out.

  • @sonny OTAs should work, they do with most Xperia X devices but I've gotten reports of failing OTAs on some devices where the Circle Of Flash(tm) doesn't even show up. So if your device runs through the install process with the circle it should be lucky.

  • The Sony Xperia X is now in the installer

  • @Lakotaubp

    Great ! Super! Here is a Sony Xperia X working ... 🙂

  • @fredldotme
    I was able to update to Ubuntu Touch Version 33 today without problems.

  • can i install it on a Sony xperia x compact ?

  • @sahirul No, as that one is neither Suzu nor F5121.

  • Is there a way to make sure the Xperia X we will get is the correct version?
    Perhaps in the about page on Android we can see the model?

  • Yes, you can see it.

  • @fredldotme oke thank

  • @fredldotme Sir i have xperia x f5122, can i install on it?

Log in to reply