How should I set up my environment for developing?



  • Hi, I want to develop for UT with Atom or the Qt Creator, but are to bad to set up one of them correctly.
    At first I create a project with Clickable.

    On Atom I can open the project, edit some lines of code, save it and compile this via Terminal and Clickable.
    The problem is, that there is no autocompletion and code-hint underlining (for me), what makes it very difficulty. I have the atom-build-clickable package installed, but don't know how to use it.

    On Qt Creator I can develop "normal" Qt programs. If I want to open a Clickable project, there are a lot of Errors with the CMakeLists.txt and I cannot edit this project.

    On this tutorial they set up only the unsupported(?) SDK.
    In the official documentation I cannot find good hints...

    So how did you do it?

    I hope my English is good enough. Thanks a lot!



  • @Kanduras
    Hello, you can build a clickable project with F9 or Package>Build>Build Project
    But you need to configure the atom-build-clickable addon. For this go to Edit>Preferences

    Go to "Packages" click on settings for atom-build-clickable
    If you click on "View code" you can edit the plugin to adapt to your configuration.
    I did it to use SSH to push my code instead of ADB, this way my phone can be free from the cable.

    I hope this would help.



  • @AppLee
    Thank you very much!
    On Atom I needed also the 'build' package, but now it works 🙂

    Is there a way for autocompletion and code-hint underlining in qml, on Atom?



  • @Kanduras said in How should I set up my environment for developing?:

    On Qt Creator I can develop "normal" Qt programs. If I want to open a Clickable project, there are a lot of Errors with the CMakeLists.txt and I cannot edit this project.

    If you want to stay on QtCreator, you can have autocompletion for Ubuntu Components by importing them on your PC:
    (see topic 1 or 2 ) https://gist.github.com/lduboeuf/dcf22607207d5b7abc8ac966d20942ce



  • @AppLee would you kindly explain how did you manage to compile via ssh with the clickable plugin? I followed your instructions and got to look at its code but didn't find out how to enable ssh...it would be very nice for me also not relying anymore on the usb cable 😉



  • @matteo you can find information about connecting with ssh here : https://docs.ubports.com/en/latest/userguide/advanceduse/ssh.html

    Don't know if phablet-tool still exist, but with that its pretty straight forward



  • @lduboeuf thank you for your pointer, it is very appreciated to understand how to set up the ssh between phone and PC. However, what I'm more interested into is how to "force" the Atom clickable plugin to compile via ssh wireless instead than do it in the "normal" way, i.e. by adb tools with usb cable, which is the standard behavior. According to what @AppLee said above, if I didn't misunderstand, he was able to change something in the Atom clickable code, enabling the ssh communication.



  • @matteo click on "View code", go to the clickable.js, in the "settings()" function (Line 99), and add:

    {
            name: 'Clickable: Build and run [phone (ssh)]',
            exec: 'clickable',
            args: [ '--ssh YOUR_PHONE_IP' ],
            sh: true,
            functionMatch: function (terminal_output) {
              return errorHelper.checkBuildError(terminal_output)
            }
          }
    

    P.S. don't forget the "," at the beginning or end



  • @Kanduras thank you very much 🙂
    Before changing the clickable plugin code following your instructions, I wanted to be sure the ssh connection was working but I didn't succeed yet. I also tried to generate again the ssh key and push it to the phone, but no joy up to now.
    In the PC terminal, if I type the command ssh phablet@<ip-address> (ip-address found typing hostname -i in the terminal), I get an error message stating that the connection is refused on Port 22.
    Any recommendation about how to fix that? I know ssh is very sensible with authorizing a connection and I believe I'm just slightly off the road....

    Matteo



  • @matteo I set up the SSH connection with the first answer of this question



  • @Kanduras Great, it works!! Thank you very much 🙂 You made my life much easier 👏 Now the set Atom/clickable really rocks!

    Kind regards to you all @AppLee, @Kanduras and @lduboeuf

    Matteo


Log in to reply