noobie OnePlus WiFi issue



  • i just got my OnePlus One working, sort of. no SIM card yet. I just got my phone 2 days ago. i couldn't get the graphical installer to work, so i tried the command line in my mac. i have never used it without close supervision. before i got UT, i configured the WiFi in Android. in UT it doesn't see any networks and i see no way to enter info. any suggestions? the command line seems like magic, but all i know about it is copy, paste, hit enter. i feel i am living on the edge, like driving without a license. I wouldn't know exactly what that feels like, i can only imagine, or use the terminal. using it in the phone is less of a risk, but it sounds like SSH is the way to go. i am thinking that if i rerun the command lines maybe my WiFi will work? are the lines i copied out of the UBPorts installer temporary? do they delete themselves after a while? i still see them sitting there

    also i don't have the ability to navigate in what i think is the boot loader. the place you go when dpressing the power and volume down button at the same time
    i set the clock in one place, in the set up process, it still shows a different time and date most other places in the phone, 3:38 Jan 3 1970, as i recall

    what file system does the installer or phone use?
    what programming language is (are?) used to make the OS?

    thanks to Canonical for making it, i wish they didn't drop it, thanks to the maintainers and developers and UBPorts that maintain and develop it, thank you. i am very excited to working with it at the moment

    edit: i was reading some of the other posts. "Wifi not connectiong after reboot" has a few things to look at



  • @nobhobbor Try rerunning through the installer without wipe that should sort any issues out.



  • i'll try that, thanks. i really appreciate your response!



  • I am wondering if I have an unsupported model:

    OnePlus 1 64gb Sandstone Black A0001 (Unlocked) GSM World Phone M-VG



  • I have the same phone. Bought on eBay about 2 weeks ago. Changed from Cyanogen Mod to Ubuntu Touch last week. Noodled around without SIM card for a while. Phone seemed OK, but not snappy. Immediately noticed that WiFi spots in the area (nearby apartments) failed to show on phone with Ubuntu, whereas they did with Cyanogen Mod. As well, with T-Mobile "tourist" SIM card touch screen sporadically responsive— would not consistently end a call / answer a call. With Cyanogen Mod touch was less nimble than on iPhone X, but seemed to work well enough that there was no problem, per se. Definitely an issue, now. I'm brand new to Linux, and would like to hear how others may have solved these issues. Big thanks.



  • hi x24,
    my first thought was to sell the phone and get one that doesn't have "world" in the model. but i really should read the "supported models" again. i ordered a nexus 5X and realized that it isn't supported, so, i'll just check if works and then put it back on ebay and get just a nexus 5. am amazed that you got it working as well as you did. check out the t-mobile starter kit SIM with free data every month for under $6 and free shipping on amazon. i was in the mall and asked at the t-mobile store and they had no idea that this SIM existed. i have it but i don't know which phone to put it in



  • @nobhobbor Thanks for your reply. I'll look into T-Mobile deal. As for the OPO, well, aside from not recognizing WiFi, it works well enough. Again, as an Android it picked up the area networks, so I don't think it's a hardware issue. Seems like some others out there have experienced the same snag, while others have a fully functioning phone. Could be a hardware / OS compatibility problem, as in some models of the phone have some peculiarity that hasn't been addressed by the UT developers. Maybe it's rare enough that it'll continue to be overlooked in updates, but I hope not.



  • There is a bug report for this issue here:
    OnePlus One wifi switch after OTA6 #995

    Specifically this comment:
    WCNSS_qcom_cfg.ini

    One needs to enable developer mode in settings. Then connect with a device with adb tools installed.

    Then:

    adb shell
    

    Once you're in the shell:

    sudo mount -o remount,rw /
    

    That is to mount the root partition read/write. Now you can replace or edit the WCNSS_qcom_cfg.ini file. The one mentioned in #995 was sufficient to get wifi working for me.

    Hope this helps


Log in to reply