(Solved) I can't get the wifi working

  • I can't get the wifi working on my Nexus 5. Previously it's worked, but now it does not show any potential connections when I select Network from the top menu and then "Wi-Fi settings..." It only shows "Previous networks", but gives no option to connect to these. Anyone know how I can fix this?

  • @MarkG_108 Do you know what was going on before it stopped working?

    I have seen this happen after using the hotspot feature on Nexus 5. Or switching off airplane mode on other devices.
    Rebooting seems to bring it back when that happens to me though.
    Or double check that wi-fi is enabled.

  • I intentionally disabled it a while ago, to avoid the internet for a bit (I do this on my desktop sometimes too). Usually I can just re-enable it, and be connected again. But that's not the case this time (there doesn't seem to be an opportunity to re-enable it). Also, I tried turning it off and back on, but that fails.

  • I just did a factory reset, using the Ubuntu Touch Recovery program, and I still can't get wifi. It says that "no wifi is available", which is ridiculous, given that I live in an apartment building, and everyone here has wifi.

  • Some further information:

    mark@debian:~$ adb shell
    phablet@ubuntu-phablet:~$ nmcli g
    disconnected  none          enabled  enabled  enabled  enabled 

    The command "nmcli r all on" gave a similar result. Wifi still doesn't work.

  • @MarkG_108 As a a one off try installing the dev channel check wifi. if it's ok you can go back to stable or whatever and the fix should stay.

  • @Lakotaubp, thanks. Where do I find this "dev channel check wifi"? Is this an app from Open-Store? Or is it a package from Ubuntu? I'll assume the former... perhaps wifiscanner will do something. I'll have to figure out how to install it via my desktop with adb.

    Also, it could be a hardware issue with my phone. So, perhaps I should try to install LineageOS on it to test.

  • @MarkG_108
    I think he meant 😇 :
    1- Install the dev channel
    2- Check if the wifi works
    3- Go back to stable channel

  • @AppLee Oh. Is this an option in the Recovery program?

  • @MarkG_108 It's in the system settings.
    You go to Updates, then at the bottom click on Update settings, then tap on Channels and select Development

  • Thanks, @AppLee. However, the problem is that it's not currently connected to the internet, so it can't connect to the dev channel to install it.

  • @MarkG_108 🤦 right 😔

  • @MarkG_108 Try the installer

  • Okay, doing a factory reset from the Recovery utility failed. But, doing a fresh install did fix the wifi. I'm not sure what broke it in the first place, but it is now working. So, problem solved.

    mark@debian:~/Templates/Nexus5/ubuntutouchinstall$ adb shell
    phablet@ubuntu-phablet:~$ nmcli g
    connected  full          enabled  enabled  enabled  enabled 

  • Well, a reinstallation fixed this, but I think I discovered why it stopped working in the first place. I was attempting to install Anbox on it, and, apparently, from this bug report, that can mess up Wi-Fi: https://github.com/ubports/ubuntu-touch/issues/1264

    Some time ago, I had previously installed Anbox on my Ubuntu Touch phone, and that didn't affect Wi-Fi. So, this bug seems to be new.

  • @MarkG_108 had the same problem mentioned in the first post: System Settings -> Wi-Fi only shows "Previous networks", no Wi-Fi button. Also dekko2 crashed when I tap on a mail subject in the list to open. Dekko2 had been running fine before, although sometimes I had to restart the phone.

    Never saw this before and restart did not solve the problem.

    I had three apps installed: dekko2, sudoku js (played often), fishy shooter (never tried this). It appeared sudoku js suddenly had disappeared.

    I uninstalled dekko2 and fishy shooter, restarted and the problem was gone: System Settings -> Wi-Fi showed the Wi-Fi button again ... magic ...

    Running Ubuntu 16.04 (OTA-12) on OPO.

  • @ut yesterday again had the same problem: no Wi-Fi button in System Settings -> Wi-Fi. It appears there is also a Wi-Fi button in System Settings -> Battery but toggling this did not appear to change anything (but maybe i am inpatient). Discovered another Wi-Fi button in the top (notifications) bar -> Network. Switching this to On gave me Wi-Fi again and the Wi-Fi button magically reappeared in System Settings -> Wi-Fi.

  • My pinephone UBports edition just came in the mail. Out of the box, no wifi networks detected. WIFI is enabled, no networks are being detected. there are buttons for 'connect to hidden network...' and 'previous networks'.

  • @jcress410 Haha same here no wifi.

  • @ToxyPoxy Did you double check the kill switches on the back?

Log in to reply