How do I or would I a few things



  • Hi

    For about two days I have had a odd issue with my Meizu MX 4 Ubuntu Phone and the Ubuntu Touch OTA 15, and I don't know why. , makes the phone unusable here and there. It may still be worth trying to fix anyway, and to learn something, but the plan was to re flash eventually, or if not wait for a Ubuntu Touch to Ubports way of doing things without re flashing, however I haven't re flashed a smart phone before, despite having a few different ones.

    The Ubuntu Touch issue is still connected to the wireless or mobile data, not sure which I assume wireless. So some new email notifications will come up, and I can use the browser even. However there is no screen anymore with wireless networks etc, instead on the top when swipeing it says network-indicater with a icon instead as well Also for updates it seems to think that its offline, Hope this makes enough sense, how to possibly fix that?

    As for re flashing with Ubuntu Touch it seems possible going by the guide, https://wiki.ubports.com/wiki/How-to-flash-existing-ubuntu-touch-devices-with-Ubports-images however I would prefer to get the photos and videos off the phone, and texts as well, before attempting to re flash. I have had some issues with micro usb cables recently in Ubuntu and Windows, but with one it came up with a blank mtp earlier in Ubuntu for the MX 4 Ubuntu Edition folder, and worked in Windows to get hold of photos and videos. As for texts apparently stored in a database but I don't know how to access that or work with that, for just the texts.

    Closest I got to re flashing a phone was I guess recoverying Salifish OS on a Jolla phone after an issue, but don't quite remember what I did to do that now, However didn't use some btfs snapshot that's for sure to do it, since the shipped version was so old, and so lost everything on phone, when doing some way to do a factory re set.



  • I may be missing it here but are you saying your phone had an issue with wi-do and network, but now you have flushed your phone and all is ok? If I have that wrong please let me know. With the issue you originally had, if you have not already please log a defect for it. That way it will not be lost or forgotten and if anyone else has it they can add comments to it and there is a record. Also adding screenshots in the bug if you have them are useful.



  • Hi Phil thanks for your reply :).

    The phone is still on the Canonical OTA 15. I intend to re flash it to Ubports later on, however since the issues I got with it now, that later on may be sooner than planned. Then again I got a LUG meeting next week anyway, and might be nice to show at least someone there my phone again, but running a Ubports image instead. I know going to look rather similar currently.

    By the looks of it your from the UK, well despite also being from the UK, England, I think the original message wasn't worded that well in parts of it.

    I now have this on the phone, with one of them being wrong, (each one has its own icon as well, but those are ok I think,), in fact I'll try to put that in bold:

    Notifications Rotation keyboard layout Files Location Bluetooth indicater-network Sound Battery Time & Date System

    indiicater-network shouldn't say that, and also should have the wifi networks that are availalbe allowing me to connect and disconnect etc, but instead its now blank. Also if I go into system settings and go to Wifi it only has the previous networks option now, where as I think before would have allowed me to connect or disconnect in there, but can get a few detials for the network such as last connected.

    I ran out of space since had various videos on the phone, taken lots of those off onto computer now, and still these issues, but I thought maybe that had caused the issue this time some how, since kept on having a message up saying was on 0 percent free space before that.

    How do I back up texts thats my other question! I want to keep all the text messages and in a easy way. I want to transfer them to a computer even I guess, but where I can actually read them if possible? Or have on a computer as well if possible like that?

    I don't care about saved app settings, for apps in general, or even the browser as in bookmarks etc.. Once I have the things I want off the phone, I think yes re flash. Seems a little risky too me just following the guide in case something goes wrong, but I haven't properly backed up the contents of a phone and ,re flashed a phone before as I mentioned.



  • @sebsebseb I have had a similar thing, but in my case the problem occurs with the sound indicator. I don't know why it happens, but i suspect that "indicater-sound", "indicater-network" etc. is shown when the connection with the HW is lost (i.e. driver or HW) error. In my case with the sound indicator, it is back just by switching off the phone for half a minute or so and when the system is started up again it is back to normal. Just rebooting without leaving it off for a while does not fix the problem i have.

    For backup of texts, your messages are in .local/share/history-service/history.sqlite

    You can use the DB Browser for SQLite in Ubuntu to browse the db on your PC.

    You can also make a full backup of your phone with rsync as described in the wiki and in some forum threads. I use terminal on the phone to type in the suggested:
    rsync -avz --delete /home/phablet/ <usernsme>@<ip address>:<remote path for backup on your pc>/

    The ending '/' are important.



  • @hans1977se Hi thanks for response, was able to open up the phone in Windows to take off images and videos, later tried again with Ubuntu as well, and it opens up as MTP device with the folders such as videos and music etc. However I can't just show hidden files and folders and have it showing .local and anything else like that. I have tried some MTP command stuff just now, but didn't really work, I guess may be a way to get into .local via terminal as well. Next thing is to try and get the texts off the phone. I don't know what I am doing with MTP commnands and things like that, so any help appreciated.

    As for the DB browser graphical program installed that, and looks like will probably be easy to use once pointing it to a database.



  • @sebsebseb Yes, i think you would not easily be able to show the hidden files over the usb like that. You could try using the terminal to copy the file locally on the phone to for instance the download directory before you connect the usb, or install the ssh server on the Ubuntu PC and copy the file with the scp command from the phone terminal:
    scp .local/share/history-service/history.sqlite <user>@<ubuntu PC IP address>:.

    Hopefully that could get you somewhere quickly. :)


  • Infrastructure

    Guys,

    simply do an rsync avz --delete /home/phablet/ <destination> where destination can be the SD card in /media/phablet/<card_name>/ or an ssh server username@servername:$HOME/backup_folder

    Then all important files are saved, except system settings like Ringtone, alarm sounds, etc.

    You can later rsync the things back by exchanging source and target. Its also nice for incremental backups since it only transfers changed or new files.
    BR



  • @Flohack That's what suggested him initially as well, altough he wrote that he does not want to do that. :) So I try to as well suggest on how to achieve his goal. :)


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.