Nexus 5 - In both Pure Maps and Unav, maps will "hang" during navigation

  • Hello - new user here, I bought a Nexus 5 specifically for Ubuntu Touch to (hopefully) rid myself of the Android | IOS duopoly. Profuse thank you to the UBPorts community! Aside from a couple of quirks like above, I love it (fwiw)!

    If this issue is addressed elsewhere in another thread please kindly point me to it after appropriately flogging me (but I didn't find it).

    When I start navigation using either Unav or Pure Maps (both affected): at some point, the progress of current location on the map hangs (Interestingly in the case of Unav, it continued to issue voice directives for waypoints). If it matters, I'm not sure to be honest which Android version I started with when I received phone, as I simply unboxed it, powered it, and proceeded to install Touch. What can I do to remedy the navigation apps stalling/hanging, if there is in fact a current remedy path?

  • @DDInWi
    One thind you could try is to restart the phone right before your trip, it should helps.

    Hanging GPS, AFAIK is system related not app.

  • I've had the same issue on a OnePlus One. It's disappointing as it makes the phone unusable for GPS navigation and tracking.

    I hope this gets improved in the future.

  • +1 - Same issue on turbo. Usually happens to me when driving by car, never happened while walking around with gps. Most of the cases after hanging and restarting the app, the access to the gps is denied s.t. it needs to be rebooted to get navigation back. I only tried unav up to now, so I wasn't sure if its a problem with unav or with the system. If you say it happens with both unav and puremaps, it smells like being a system issue... (but ofc no evidence)

  • It happens with uNav, Pure Maps, Activity Tracker and ernst's gps-utouch-tracker python script launched from the terminal. I haven't tried walking but I tried biking and driving.

  • @normandc hello, do you mean my initial script or the "app" Utrack ? it cannot be put in the same list as it is an hack not using the system protocol to get the coordinates.
    So i don't expect to have the same issue, please report it I could look at it.

  • Your initial script, I installed Utrack but didn't try it yet (my biking season is over).

    Not sure if it's the same issue or not, the end result is the same: unreliable GPS location, losing it and not getting it back most of the time. I've been wondering if it was a system or hardware issue.

  • @normandc said in Nexus 5 - In both Pure Maps and Unav, maps will "hang" during navigation:

    Not sure if it's the same issue or not, the end result is the same: unreliable GPS location, losing it and not getting it back most of the time. I've been wondering if it was a system or hardware issue.

    Or my poor coding 🙂 you can forget about the initial script Utrack should be more stable. (however i still need to nail one issue...)

  • As I said I have the same problem with apps, so I doubt your coding is at fault.

  • @normandc Hello, I'm using Pure Maps on Nexus 5 and I'm experiencing the same problem regarding the "unreliable GPS location".
    Having a look at the SensorsStatus app, it seems normal not to have a pinpoint accuracy because the indicated "accuracy" (which indeed might be the standard deviation computed by the GPS receiver itself) is never under around 10 m.
    So I have another question pending: is it possible to find a datasheet of the GPS receiver? That would be helpful to know what's behind the receiver's outputs (GPS alone? GPS + GLONASS? GPS + SBAS?) and to know if the observed positioning accuracy is consistent or not with them.
    Thanks for your help, and as I'm pretty new here, if there's on this forum a dedicated section for GPS receivers on UT phones feel free to tell me but I haven't found it yet 🙂

  • I'm afraid I can't answer here - it much exceeds my knowledge.
    I would just like to clarify my statement about GPS positioning: my problem is not one of accuracy, it's that it loses its position altogether. When I use an app that requires GPS tracking, either it never starts tracking, or it loses tracking along the way; sometimes I get tracking back, sometimes I don't.

  • Ok thanks I better understand your problem.
    Just a quick question: are you satisfied with the positioning accuracy when you're using apps such as Pure Maps, Unav or Utrack?
    I'll continue to try to find out why there's such a poor positioning accuracy (in my point of view) on the Nexus 5 and what could be done to improve it.

  • @waynejohnson Hi,
    There is no A-GPS available I think.
    So it's hard to have a better precision than 5 to 10 meters AFAIK.

  • @AppLee that is not what AGPS does.
    AGPS is referencing the coordinates from the nearby cell tower to speed up initial location finding, accuracy is not improved at all.

    Maybe UT doesn't reference additional GLONASS, Galileo etc. sattelites to increase accuracy of the intentionally low accuracy GPS?

  • @poVoq I thought AGPS could also use local adjustment to improve accuracy. And not just speed up the GPS fix...

  • @poVoq I agree with you AGPS is here to improve the Time To First Fix (TTFF) but it has no influence on the positioning accuracy.
    We would just need to find out what output of the Nexus 5 GNSS receiver is used in UT; most of the time a receiver offers different types of outputs, more or less accurate: GPS alone, GPS coupled with GLONASS (seems like the Nexus 5 GNSS receiver uses both constellations), GPS coupled with SBAS (WAAS over the US, EGNOS over Europe, etc.).
    Maybe we should get in touch with the developers of UT regarding this specific issue in order to find a way to improve the positioning accuracy. How can we reach them on that subject?

Log in to reply