M10 HD on boot loop after trying usbports-installer



  • Hi everyone,

    I've tried to install the stable version on my M10 HD (cooler) using usbports-installer from my Linux laptop but the installer froze on the reboot part and the tablet is now caught on a boot loop while showing:

    Orange State
    Your device has been unlocked and can't be trusted
    Your device will boot in 5 seconds

    I can't even turn it off or reboot it using power and volume buttons...

    What can I do to fix this?

    Thank you so much!



  • @Angela_92 What OS was on your m10 before you tried the installer?



  • Read this https://docs.ubports.com/en/latest/userguide/install.html

    and this https://web.archive.org/web/20180118130643/http://www.mibqyyo.com/en-articles/2015/09/16/ubuntu-android-installation-process-for-bq-aquaris-e4-5-and-e5
    you might need to go back to android first then try Ubuntu Touch again. If this doesn't solve it please ask here https://t.me/WelcomePlus as it may be quicker over the weekend. I will be back later on today but someone else should be here later.



  • Lakotaubp,

    It had Android on it. The problem with the guides you linked is that the tablets keeps showing the message and it doesn't finish to boot. Also, adb devices does not list it, so I don't know how to undo what I did to get back to Android and then proceed with the install.



  • @Angela_92 Not done it myself but you can flash twrp using fastboot which should get you started then get android or lineage on from that there will be online guideds.Alsoo check out the Bq support site or ask in our Welcome and Install group if you hit any problems https://t.me/WelcomePlus Those other links will help when you try again with Ubuntu Touch. I will check back later to see how you are getting on. Good luck



  • i have the m10 fhd
    you should use the spflash tool to reflash android ,and start again .
    if you have never used flashtool . it can mess up your wifi if you use the wrong setting.
    dont worry about it boot looping,, you set up fashtool with your device disconnected , press the neccessary buttons and then connect it, and as it bootloops it will trigger flashtool to do ," work"
    I will look for a link to help with visual aids



  • try this link
    https://www.getdroidtips.com/flash-twrp-recovery-mediatek-sp-flash-tool/

    i can supply a link to the files you need . later......
    https://drive.google.com/open?id=1zWw8tVifUowrDXOx6UOZxIoN9icMKqN1
    While i think of it, you should tell us what version of linux you are using, as this can give a problem also ( modemmanager)



  • @Marathon2422 I am not sure if you mean the Linux version on the laptop I use to install or the one I intended to install on the M10, but both are 16.04 xenial. I selected this for the tablet because it's the one that appears as suggested as stable version on usbports-installer.



  • @Angela_92
    i mean the version on your laptop .
    ok ,so you are you familiar with flashtool.....
    it seems to me, that your adb connection was not good.
    you can reflash android , and start again, or see the link,and flash TWRP, ( that way you still need someone to supply you with a TWRP backup.
    the link has the latest android and TWRP.
    there are lots here to help you ( i have the FHD ,so my stuff willl not work on yours)
    we are all here to help



  • https://www.getdroidtips.com/stock-rom-zyrex-zt-918/

    this is for a different device :- but shows what to do with flashtool.
    go there scroll down half the page ,and there are 2 links , one for pics the other to a video .
    turn your sound on , so you can hear what happens when you connect your device
    make connecting your device ,the last thing you do , ie press the download to start everything, then plug the device up,and watch and listen, if no activity after 10 secs or so,try to turn device on or off . flashtool should start working and take control .
    anybody got more info for using 16:04 ( modemmanager etc)



  • Hi everyone,

    I'm still working on this. My situation:

    • The device is on boot loop as described originally.
    • I'm charging the device on a wall charger before proceeding to the install.
    • Previous OS is Android 6.0 but I don't know if this is working any more.
    • My laptop runs Ubuntu 16.04.
    • adb and fastboot are properly installed (they work with other devices) but they don't detect the device as it is now.

    I've been told that flashing the TWRP recovery via flashtool will stop the rebooting and I'm trying to do so. I've installed flashtool and I've downloaded the TWRP recovery image and the UBports recovery image for my device (https://storage.googleapis.com/otas/2015/Tablets/Freezer/Ubuntu/OTA_13_FW_version/cooler-image-stable-6.zip).

    I understand the following steps are:

    • Charge the device.
    • Open flashtool, go to the download tab, select the MT8163_Android_scatter.txt from the UBports recovery image and select "download only" from the drop down menu.
    • Hit download then connect the device.
    • Listen and watch, wait for red then purple then yellow in the status bar and a final double check.

    Sorry for the long post and my doubts but after my initial failure I want to be sure I'm doing it properly, so am I missing something before proceeding?

    Thank you so much.



  • Try Ubuntu touch first ,with Adb and fastboot working, flashing with spflashtool, should get you into a working Ubuntu Touch, then you flash it to Ubports as explained in "Ubport Docs"

    When think you have enough charge in the device, go-ahead and try with spflashtool.
    Set it all up ( firmware upgrade),and press the download button then connect your device and listen and watch the progress bar.



  • @Marathon2422 What's the difference between UBports and Ubuntu Touch? I thought it was the same OS for this device...

    I've tried to flash it with spflashboot (with the MT8163_Android_scatter.txt from the UBports recovery image, hope it was the right one) but I got the following message:

    "PMT changed for the ROM; it must be downloaded.
    Please select Fomat All+Download scene and try again"



  • @Angela_92
    do not use that format all option, it will mess up your nvram (wifi)
    Ubuntu Touch is the "cannocial version that m10 ubuntu devices came with #flashing it unlocks your device# then you can install the Ubports version which gets updates and improvements.



  • do you have the m10 android firmware , you could try going back to android to fix your rebooting problem.
    Then start again.
    or make sure you reboot your PC ,so everything is freshened up .and just try again ( using "firmware upgrade "option).



  • @Marathon2422 I managed to get back to Android and finally fix the rebooting system, thank you!

    I intend to do this now: https://docs.ubports.com/en/latest/userguide/install.html i.e. use SP flashtool with the Ubuntu Touch ROM for my device choosing “Firmware Upgrade” and not any other option.

    After this, I expect to end up with an old version of Touch so I'll have to use the UBports installer.

    Before proceeding... is it OK, am I missing something?



  • @Angela_92
    glad you got back to a functioning device , now try again, check your os on your PC against the info / intructions about "libris" or "modemanager" just to be sure
    good luck



  • I've tried to use the flashtool with the Ubuntu Touch ROM following these instructions (https://docs.ubports.com/en/latest/userguide/install.html#install-on-legacy-android-devices) and previously fixing the modemmanager issue, as per this (https://web.archive.org/web/20180118130643/http://www.mibqyyo.com/en-articles/2015/09/16/ubuntu-android-installation-process-for-bq-aquaris-e4-5-and-e5).

    However, I'm getting a #1013 error, i.e. SP flash tool encountered an error while attempting to communicate with the phone via the target port. I don't know why this happens, as I'm using the last version of the tool, the very USB cable that came with the device, the one 2.0 USB port my laptop has (and not the 3.0) and the device is switched off with a loaded battery. I can't try in any other computer, what else can I do?



  • @Angela_92

    I had a similar problem back in 2018 although my device was 'ubuntu edition' to start with.

    I've just looked up my old post on the forum and found that I was getting an error 1013 too. Here is an extract from my post after finally succeeding with the flashtool:

    "It took about five or six goes on the flash tool before it took off. The flash tool could not detect the usb port a few times.Then there was a BROM ERROR : S_COM_PORT_OPEN_FAIL (1013). Research suggested this could be cured by swapping usb port or cable."

    You can see the thread here if it is of any use (You'll recognise some of the names ☺)

    I have usb 2.0 and 3.0 ports on my laptop and I'm pretty sure I would have tried them both, but sadly can't remember which port made the breakthrough.



  • @ziggutas It's USB 2.0 despite what the instructions said. Thank you!


Log in to reply