Connecting N5 via USB to my arch machine fails



  • I never had problems connecting any utPhone to a debian linux machine. Since one year now I am using Manjaro (arch based) as my main system. If I connect my BQ E5 to Manjaro via an USB cable everything seems fine. But if I try to connect the Nexus 5 I have troubles. In the past I only had to reconnect the phone sometimes - and it worked. But since today - I do not get any connection.

    THUNAR crashes when connecting - and THE FILES shows sometimes this: Bildschirmfoto vom 2020-01-24 13-27-33.png



  • @Mic_ Hello,
    I guess you are on devel, else I'd say that you have to check your cable as it may be faulty.
    But I also guess your tried this obvious manipulation.

    If the above doesn't apply, then maybe you can have a look on MTP side on your desktop.
    Have you tried to connect your N5 while on stable (OTA11) ?
    And if you can try with the same cable with a debian based distro, it may help narrow it down.

    I don't have Arch or Manjaro to test if I can reproduce.



  • Yes, I always use devel - on the BQ E5 and N5. And no I did not check with stable. And I always used the same cable.

    MTP I have to check.



  • @Mic_
    I thought so, but it's always good to check 😉

    Do you have any log to help figure out what happens ?



  • If u explain me what I have to do - I would post everything u want / have an idea of



  • @Mic_ I don't know the specifics about Arch/Manjaro

    But I hope it's the same and you should have inputs in /var/log/syslog or with dmesg command when you plug the phone.
    So try this :
    1- run the following command : tail -f /var/log/syslog
    2- plug your phone in
    3- wait until the error message (the popup you posted)
    4- Ctrl-C to stop the tail command
    5- run the following command in another terminal : dmesg

    If it's OK, you can copy the whole output from the first command and the end of the other one so we can have a look.
    If you have an error on one of the command then it's probably because your OS doesn't handle the logs the way I'm used to, so it'll require some internet search or someone who knows manjaro/arch.


Log in to reply