Ubuntu Touch won't install on Oneplus One. Apparently successful install won't boot up.



  • Been trying to install Ubuntu Touch on my Oneplus One. First, I had trouble due to awful USB cables. Bought a new one and had what seemed like a successful install (in terminal and the installer). After "Your device will now reboot and complete the installation. Enjoy exploring Ubuntu Touch!" it would only reboot, blank screen. Reboot, blank screen...and on, and on...

    I did what I thought was suggested in a response to a thread back in December:
    "Lakotaubp 13 Dec 2019, 15:51

    @polyglossia If fastboot worked you should have UBports recovery, boot to that factory reset, clear cache(Android Actions) reboot and try adb devices again maybe with a different usb cable just incase.
    Did you grant permission on the device the first time you connected to the pc?"

    Should I have done wipe data/factory reset on both the Ubuntu actions and Android actions screens?



  • @Rowboth Give it a try and double check the ADB connection. What was on the device beforehand? Have any of the partition sizes been changed. Then run the installer with wipe option selected.
    Edit: One other thing is the battery charging OK. One of mine wasn't resulting in not booting, it needed a new battery.



  • Oh my goodness...it works. The only difference between this time and my previous attempts was not having the wipe option selected.

    Although, I just noticed that it only works when it's connected to my computer. I plugged my USB cable into the wall to top up the phone's charge faster, and it did the reboot to blank screen. Why would that happen?



  • @Rowboth Hate to say it but when mine did that it was a battery issue. If yours consistently shows battery at 50% that's another sign. Try leaving it conected to the PC and see how much charge you get in System Settings, Battery.
    On the upside if it is the battery, they are cheap and easy to replace.



  • The battery is slowly charging through the computer USB. It's up 10% since I've been messing around getting used to it...at 86% now. I have a battery on the way and I'll swap it out as soon as it arrives. I'm fine leaving it to charge through my computer overnight until then.



  • I thought I'd be able to use my device and just use the computer to charge it, but it turns out the device reboots and goes blank as soon as the cable is unplugged. Is this what you experienced too, Lakotaubp?



  • @Rowboth Yes just the same 😞



  • So I installed the best replacement battery I could find, and things looked good...it charged normally through an outlet rather than do the reboot to blank screen thing. But, when I unplugged it and restarted it, it did just that. It still only boots to UT when plugged into my computer. Is there anything else I can do??



  • @Rowboth Think mine took a couple of reboots to work but not sure, can remember thinging it hadn't worked then all OK. Try reflashin with the installer?



  • @Rowboth Have a read through this thread there is a command you can use to see the output of your battery from @wdehoog https://forums.ubports.com/topic/3615/oneplus-one-battery-at-50-issue


Log in to reply