Couple of issues after switching to Nexus 5

  • Hello, I switched from my BQ e4.5 with the official Ubuntu to a Nexus 5 and UBports. A couple of things are already reported here (notification LED, today scope). Here are a couple of other thngs that bother me:

    1. uTorch doesn't work anymore. The switch works, but the flashlight doesn't turn on. Going to system settings to see the app restrictions, the camera section is greyed out and shows 0/0, so there's no way to give uTorch permissions.

    2. When making a phone call, the (voice) volume of the other person is noticably quieter than on the BQ. I installed uVolMan and the call volume is already at the maximum. Maybe this is hardware related instead of UBports?

    3. I have a WiFi repeater in the house. It's the same SSID as the router. With the BQ I was able to just move around and the network would switch between the router and repeater seamlessly. Now with the Nexus I get disconnected and it's asking me for the password each time. I can just cancel and select the network from the dropdown, but still.

    Point 3 is probably the most annoying one. Any help, ideas or tips are welcome. I can provide logs and further debugging if neded.

  • @RandomUser I confirm 1. Let's see if we can open a ticket. On 2. I'm not sure, I also switched from a Bq E5 to a Nexus 5, but I think I can hear my calls OK.. 3. I can't confirm as I don't have that setup.

  • @RandomUser, I think Nexus 5 is not a supported device for utorch.

    Supported devices:
    ✔ BQ Aquaris e4.5
    ✔ BQ Aquaris 5
    ✔ Meizu MX4
    ✔ Meizu Pro5
    ✔ Nexus 4

  • @wgarcia

    1. If I open uTorch LED doesn't work, but if I open the System Setting: Security & Privacy -> App permissions (Camera is greyed out), the LED comes ON and I can switch the light on and off.
    2. Not tested, because no SIM card
    3. The first time I used the N5 at home it could not find the Wifi network, only after I set the Channel from automatic to a single channel, the N5 could see the SSID; next I switched back to automatic channel and N5 worked without problems.
      Seems there is something odd with Wifi using N5.

  • Now I got a call, and I think @RandomUser is right that the volume is low.
    On the led, I don't understand what you do, @cherrie , the camera permission is greyed out so nothing can be changed, right? In any case, uTorch also allows to use the screen as the flashlight, so that can be used.

    I opened a ticket on the volume of incoming calls:

  • @advocatux Thanks for pointing out, I didn't check the description and just assumed it would work.

    @wgarcia Thanks for your comments. About the volume, just to be clear as possible. It sounds like it's also the dialing tone when making a call.

  • @wgarcia Well I open uTorch, try to switch it on, not working, very briefly a blue messages appears on top of
    window, saying something to need to allow access; next I open the System Setting, go to Security & Privacy -> App permissions -> click on the greyed out Camera item and then back to uTorch and it worked.
    Today I am not able to make it work, the LED only flashes briefly when I switch from System Settings to uTorch.

  • @cherrie Weird, I can't even tap on the greyed out camera option. Does it also say 0/0 for you?

  • @RandomUser It says: Camera 0 and it is greyed out. Now I managed to get it working again! Kept switching between uTorch and System Setting (Apps permissions), but it is very unreliable. Best to report a bug:

  • Since a couple of days ago I'm having issues with GPS in my Nexus 5. Whenever I try to use uNav, after I tell it to get the location, a black screen appears with "GPS access disabled". GPS is enabled. Also: the GPS indicator is always full white, even if I disable GPS. Curiously it was working perfectly only two or three days ago, and I haven't received any updates or changed anything in my settings AFAICT

    I'm on 15.04/rc.

Log in to reply

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.