Nexus 5 vs Nexus 5x



  • @jjconstr Did you get the device unlocked? Does it register on T-Mobile's network as well as AT&T? You'll find that info in settings, cellular, APN. It should show APNs for either AT&T or T-Mobile depending on which network they put you on. I think they handle the other network with roaming but not sure. So I'm curious if you get both networks at the same time and better coverage than with just AT&T alone



  • @rocket2nfinity Sorry to say, when I checked Tmobile online, they said Nexus 5 was incompatible due to no VoLTE. I know of no one with TMoble here. This is a very low population area. I paid one service to send me an unlock code, but they never did. I'm not concerned about resale value because the phones are very inexpensive. Under carrier and apn, there were no carriers listed until I installed a live sim card. Then there was only the one carrier. I'll go ahead and check again on Tmobile online. Just to make sure. I could still use better service here at the house. FYI We tried a Verizon booster. It worked well for increasing the service, but the increased radiation made us sick.
    Thanks,
    jjconstr



  • @jjconstr Wow, that was fast. They weren't supposed to be stopping non-VoLTE devices on their Network until next year so I read. They are really moving on their network configuration changes!



  • @jjconstr Which unlock service did you use? Some of them take some time to send you the unlock code. All the ones in that article were vetted at the time.



  • @rocket2nfinity And we read that our leaders in washington passed a law to roll out 5G as fast as possible now were under stay at home orders.



  • @rocket2nfinity Im going to have to look that service up later. I have to get to bed. 15 to 4 here.



  • @rocket2nfinity
    R
    rocket2nfinity 2 days ago

    @jjconstr Which unlock service did you use? Some of them take some time to send you the unlock code. All the ones in that article were vetted at the time.

    That unlock store was code-unlock-store.com. Reread their email. The system wasn't able to generate an unlock code automatically. So, they have to do it manually. Guess I was at fault for not getting the code. The last paragraph asked for more info on the phone and I didn't see that. Now the code should come.



  • Depends what you want out of the phone and if you're willing to wait, Ubuntu Touch on the Nexus 5x is very early days whereas on the Nexus 5 it's quite mature, as well as that Ubuntu Touch on the Nexus 5 is plenty fast enough for everything you could want to do and the camera is actually alright, plus the Nexus 5 can be had for bargin prices



  • @rocket2nfinity said in Nexus 5 vs Nexus 5x:

    @jjconstr Which unlock service did you use? Some of them take some time to send you the unlock code. All the ones in that article were vetted at the time.
    code-unlock-store.com is the unlock store and they emailed me saying:
    Dear Jerry Johnson,

    Sorry I have been unable to generate the correct unlock code for your mobile. There are so many mobile out there sometimes the firmware on certain versions mean I can't generate the code.

    I have sent your details over the accounts team who will send you a refund. Although normally quicker please allow up to 5 days for the refund to get back into your account.

    Once again I apologise for not being able to get the correct code for your mobile. Your only option may be your network operator or a local shop who can unlock via a cable.

    Thanks

    Tom

    Code-Unlock-Store.com



  • @ImmyChan Now have 3 Nexus 5's and am very pleased with UT. I agree with your accessment. Thanks for your input.



  • @jjconstr So you successfully replaced the power switch and all is good?



  • @rocket2nfinity Good timing. Was just wondering where that switch is. I ordered it the day you gave me the link. Usually by the time I'm wondering, the order arrives shortly.
    cheers



  • @rocket2nfinity

    @rocket2nfinity said in Nexus 5 vs Nexus 5x:

    @jjconstr So you successfully replaced the power switch and all is good?

    No, not so good. I replaced the switch and the Nexus 5 still had a boot loop, but was able to access UBports installer, unlock OEM, but after that, the boot loader would not stay on. By that I mean a couple times I saw the screen of arrows coming down. Other times, the installer would say 'waiting for device'. After a while. it would say 'yikes', error. Selecting 'recovery' did not fix the interrupted install as it did in my first two Nexus 5's. The phone displayed a new, smaller icon and the words, 'No Command'.

    When 'waiting for device' timed out, the phone no longer was OEM unlocked. Repeating the installation process several times resulted in an error message;

    Error:fastboot:flash:error:flashing failed:error:{"error":{"killed" :false,"code":1,"signal":null,:"cmd":/snap/ubports-installer/275/app/resources/app.aser.unpacked/platform-tools/linux/fastboot flash recovery "/home/jjconstr/snap/ubports-installer/275/.cache/ubports/hammerhead/firmware/recovery-hammerhead.img""},"stdout":"",stderr":"Sending 'recovery' (11828 KB) OKAY [ 0.740s]\nWriting 'recovery' FAILED (remote: 'flash write failure')\nfastboot: error: Command failed"}

    Thanks,
    jjconstr



  • @jjconstr Do you know how to use TWRP? The bootloader is likely corrupted - it happens often after the power switch problem.

    You need to reflash the boot loader and maybe the partitions. Try flashing the OTA factory images from Google or Lineage 14. If Android successfully reinstalls and is stable, unlock the boot loader and run the script again.

    https://developers.google.com/android/ota
    You need the 5.1 image Lineage OS 14

    http://docs.halium.org/en/latest/supplementary/devices/hammerhead.html

    https://wiki.lineageos.org/devices/hammerhead



  • @rocket2nfinity No, I've never used it. I'll give it a try. If there are instructions, maybe it will work for me. Thanks for the help. Where do I get Twrp? Snapstore?



  • @jjconstr

    https://twrp.me/lg/lgnexus5.html

    Basically, you need to install a stock Android image so that all your software is in the right place. You can flash a factory image just using fastboot by following Google's instructions, but if you run into trouble, TWRP gives you other options to try. It's also the easiest way to install an after market ROM, or flash Google play store.

    Be sure to go to the XDA-Developers support page, TWRPs home page or Lineage device page to make sure you understand what you are supposed to be doing before you do it.



  • @jjconstr It is concerning that fastboot did not retain a connection. But as long as you got one, you're doing better than you were before.

    Checking via terminal using the commands:

    adb devices
    fastboot devices

    Applies here. But by your description above, fastboot appears to have been connecting.



  • @jjconstr I had a similar issue when I received my brand new N5 in last february. I was unable to install corretly UT (lot of bugs, even after multiple reinstallations). I had to flash a new factory image.
    To do so, the easiest way (from my side), if you have a Microsoft Windows PC, is to use "Nexus tookit" software:

    https://www.wugfresh.com/nrt/

    Just install the programm and follow the instructions, everything is done through the software. It's exceptionaly easy.

    Once done, install UT again using UT installer
    My experience was conclusive. Never encoutered any problem since...



  • Wow, that's quite a tool. He's using Ubuntu, so in his case, he should try using it through WINE or Windows in a Virtual Machine. I use Virtual box for those occasions but I haven't looked to see what's new and easy. There might be something better these days.



  • @rocket2nfinity Or maybe by a friend or relative who has a Windows PC.
    Nexus toolkit is very easy to use, even for newbies like me. It restores Android with latest rom, factory image and firmwares, the whole process in a few clicks.

    Than activate developer mode, enable USB debugging, reboot in bootloader, connect to Ubuntu PC (warning: fastboot and ADB should beforehand been installed), run UT installer and... enjoy 😉

    That’s what I did to make my N5 working smoothly on UT.


Log in to reply